ToqAN Fixes Android 5.0 Notification Bug on Qualcomm Toq

The Qualcomm Toq is probably one of the lesser known smartwatches on the market … more

How to Root and Unlock the Google Nexus 6 on a Mac – XDA TV

In the past, XDA Developer TV Producer droidmodd3rx has shown you how to … more

Set Up Your MediaTek Device with Comprehensive Beginner’s Guide

As can be seen with the use of MediaTek chips in Android One devices … more

Sony Updates AOSP Sources to Android 5.0.1

Just a few days ago, Sony did an utterly fantastic job by pushing out numerous device trees for … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] How to stop Bluetooth from auto-playing on connection?

OP hydeah

11th December 2013, 06:05 AM   |  #1  
OP Senior Member
New York
Thanks Meter: 18
 
357 posts
Join Date:Joined: Nov 2011
The moment I get in my car, it starts playing "Life is Good" or other pre-loaded crappy music that's on my phone. How do I stop this?
I know that if I have any other music on my phone's storage, it will start playing that instead but I prefer to use streaming music and it's really annoying that I have to stop it every single time.
11th December 2013, 06:47 AM   |  #2  
Jocelyn's Avatar
Senior Member
Orlando, FL
Thanks Meter: 222
 
930 posts
Join Date:Joined: Jul 2008
More
Wow that sounds horrible lol. If I had to guess, it would probably be that it's playing the flac files located in Preload/LG seeing as 01_Life_Is_Good.flac is the name the first file. Maybe try moving those up a level or two or rename them to .bak

Sent from my LG-LS980 using Tapatalk 2
11th December 2013, 09:57 AM   |  #3  
Joppykid's Avatar
Member
Flag St. Louis
Thanks Meter: 13
 
55 posts
Join Date:Joined: Oct 2010
More
That's strange. Mine doesn't play anything until i tell it to. Does the car have a menu option auto play? I assume you prob messed around with it already.

Sent from my VS980 4G using Tapatalk
11th December 2013, 10:59 AM   |  #4  
smtom's Avatar
Senior Member
Thanks Meter: 53
 
846 posts
Join Date:Joined: Aug 2010
Mine doesn't automatically play either. Ford Sync, Malladus 1.2.2 ROM, Verizon device.

Sent from my VS980 4G using xda premium
Last edited by smtom; 11th December 2013 at 11:01 AM.
11th December 2013, 04:17 PM   |  #5  
votinh's Avatar
Senior Member
Thanks Meter: 431
 
2,246 posts
Join Date:Joined: Jul 2011
Some love it but I personally think it is one of the useless feature in car.
11th December 2013, 04:19 PM   |  #6  
OP Senior Member
New York
Thanks Meter: 18
 
357 posts
Join Date:Joined: Nov 2011
I don't think there is any option on vehicle but I will check. It is setup as if it hits play as soon as it establishes connection.

I moved them out of LG Preload folder but music player stills finds them. If player finds them, BT will still auto play them. I will just delete them to stop this. However it doesn't solve the problem which will return when I add any other music to my phone, in that case that will start playing.

I will check around car forums.
Thanks for confirming this is not Android related issue.

Sent from my LG-D800
11th December 2013, 06:16 PM   |  #7  
Member
Thanks Meter: 10
 
59 posts
Join Date:Joined: Nov 2008
More
Auto play is a feature of A2DP just as auto connect is. There is mostly likely a setting somewhere in the vehicle's system to shut it off. If not, well then just remember, life's good...
11th December 2013, 06:55 PM   |  #8  
Senior Member
Flag Boynton Beach
Thanks Meter: 450
 
1,704 posts
Join Date:Joined: Nov 2010
More
You could remove the preloaded music files, cant play them if they arent there. I also use the app Bluetooth connect and play. It starts any app you want when a specific bluetooth connection is made.
11th December 2013, 07:22 PM   |  #9  
ars0n's Avatar
Senior Member
Flag Las Vegas
Thanks Meter: 140
 
418 posts
Join Date:Joined: Feb 2012
Donate to Me
More
This happened to me, it was google music, or play music, whatever your default music player is usually does this. Sometimes its poweramp, or other.. but usually it was google music for me. IN music settings, turn off bluetooth or auto connect.
11th December 2013, 07:52 PM   |  #10  
OP Senior Member
New York
Thanks Meter: 18
 
357 posts
Join Date:Joined: Nov 2011
Quote:
Originally Posted by stevessvt

You could remove the preloaded music files, cant play them if they arent there. I also use the app Bluetooth connect and play. It starts any app you want when a specific bluetooth connection is made.

But I want to keep some music files in my phone - eventually..
What I need is the way to hide music files from Music Player unless I play them back using something like ES Explorer or other file manager, or until I browse in Music app.

Quote:
Originally Posted by ars0n

This happened to me, it was google music, or play music, whatever your default music player is usually does this. Sometimes its poweramp, or other.. but usually it was google music for me. IN music settings, turn off bluetooth or auto connect.


I can't find Music Settings, is it in the app or general settings somewhere?
If I turn off Bluetooth or auto connect then will I still be able to play streaming music? I really don't mind if I can disable auto play or bluetooth streaming for Music Player or Google Play Music since I probably will never stream stored music from my phone via bluetooth, all of my stored music is generally duplicated on my car anyway..

Another way to solve this issue would be to assign another dummy Music player as default music player, and when it runs it won't be able to find music that's stored on the phone.

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes