Default [HELP] Keylayout files are broken

Hi,

For few weeks I've been struggling with making my Xbox 360 gamepad to work with my ASUS Nexus 7 tablet. I bought an OTG cable and connected my wireless pad via Microsoft receiver. Everything seemed to work, except gamepad deadzones were not set right (I doubt Android devices consider gamepad deadzones at all), thus making all games unplayable: characters or camera kept turning left even when I wasn't touching an analog sticks at all.

I followed the thread http://forum.xda-developers.com/show....php?t=2492251, the guy who posted it seemed to have worked it out so I gave it a shot. I needed to root the device first, everything worked like a charm. I'm such an idiot I tried and edited Generic.kl file and made changes like the guy in mentioned thread.

Now I don't know what the heck is going on, beacuse hardware keys don't work at all, and I can't type numbers with on-screen keyboard. Which means I have to use my USB cable to even wake the screen, which is ridicilous enough. I found what seems to be an original Generic.kl file from here:
https://android.googlesource.com/pla...rds/Generic.kl

But no matter what I do, I cannot get it to work. My tablet seems to be ignoring any changes that are being made in /system/usr/keylayout.

Also, I don't know why, but I have an empty folder "keylayout" inside /system/usr/keylayout (which makes /system/usr/keylayout/keylayout) and another empty folder "keychars" in /system/usr/keychars.

Everytime I make change in keylayout dir I chmod the file to -rw-r--r-- and perform a mount operation in my Terminal Emulator, which goes:

Code:
Select Code
> su
> mount -o remount,rw /system
I don't know what to do - currently I'm trying to restore a backup of my tablet's data I made before rooting the device, but I'm not too sure it'll help. I'm thinking about installing a custom ROM, but do ROMs affect keylayout files?