Post Reply

[Q] Ubuntu touch read only [Solved]

OP Logen_Kain

1st March 2014, 05:35 PM   |  #1  
OP Junior Member
Thanks Meter: 0
 
2 posts
Join Date:Joined: Mar 2014
I have installed Ubuntu touch on my flo via multirom. Everything is running great except, I cannot figure out how to access root (directory). When I try to remount root it spits out that it is write protected as read only. Does anyone know how to make root writeable? I would really like to be able to use apt-get.

I am also interested in wether or not ADB is supposed to work with Ubuntu Touch, so if either of these questions could be answered I would be gratefull. Google has been no help to me.


Reference: http://forum.xda-developers.com/show....php?t=2011403
Last edited by Logen_Kain; 1st March 2014 at 07:01 PM. Reason: solved
1st March 2014, 06:57 PM   |  #2  
OP Junior Member
Thanks Meter: 0
 
2 posts
Join Date:Joined: Mar 2014
I have found my answer. First off, in the updated version of TWRP for multirom, in the multirom subsettings there is a tick box for ADB access. Doing this will let you connect to your Ubuntu rom through ADB.

Once I figured that out everything was rather easy.

Code:
adb shell
cd /
cd userdata
touch .writable-image
After that I reboot my device and I was able to use apt-get again. Hope this helps someone else.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools
Display Modes


Top Threads in Nexus 7 (2013) Q&A by ThreadRank