FORUMS

XDA Recap: This Week In Android (Apr 26 – May 2)

Here in the digital XDA newsroom, we spend our days pouring over an average of … more

Sunday Debate: Great Camera Hardware, or Software?

Join us in a fun Sunday Debate on phone cameras. Come with your opinions and feel … more

XDA Picks: Best Apps of the Week (Apr 25 – May 1)

Apps are at the front and center of any smartphone experience, and with over a … more

Lollipop Xposed Framework Alpha 4 Released

Good news to all Xposed Framework fans. XDA Senior Recognized … more
Post Reply Subscribe to Thread Email Thread

[solution] "There was a problem communicating with google servers."

2nd March 2014, 04:43 PM |#1  
enjid's Avatar
OP Junior Member
Flag Hillsboro, OR
Thanks Meter: 4
 
More
I recently removed knox and rooted my phone following the guide. Worked great... I got into my phone with CM10, except for a constant "There was a problem communicating with google servers. Try again later." error message. I thought it was a bad wipe, so I rewiped and reflashed the ROM. No joy. I did a full factory reset from the menu. No joy.

Searching on Google and XDA yielded a lot of messages about the Google servers going down a few years ago. Obviously this wasn't the case. Finally, I found something that worked:
  • Disabled 2-step Authentication (mostly to make it easier on myself)
  • Removed the account
  • Cleared the data on the "Google Account Manager"
  • Readded said account

This worked for me. I'm on CM10.2.1-dspr (stable).
The Following 4 Users Say Thank You to enjid For This Useful Post: [ View ]
 
 
2nd March 2014, 07:23 PM |#2  
CodenameCyborg's Avatar
Junior Member
Thanks Meter: 0
 
More
Thumbs up
It worked! I reflashed rom and did a lot of things but removing the 2-step verification worked! I love you man! Thx.
18th April 2014, 01:48 PM |#3  
Junior Member
Thanks Meter: 16
 
More
don't have 2-step Authentication enabled on my google account...
Quote:
Originally Posted by enjid

I recently removed knox and rooted my phone following the guide. Worked great... I got into my phone with CM10, except for a constant "There was a problem communicating with google servers. Try again later." error message. I thought it was a bad wipe, so I rewiped and reflashed the ROM. No joy. I did a full factory reset from the menu. No joy.

Searching on Google and XDA yielded a lot of messages about the Google servers going down a few years ago. Obviously this wasn't the case. Finally, I found something that worked:

  • Disabled 2-step Authentication (mostly to make it easier on myself)
  • Removed the account
  • Cleared the data on the "Google Account Manager"
  • Readded said account

This worked for me. I'm on CM10.2.1-dspr (stable).

Hi, I don't have 2-step Authentication enabled on my google account...
this is a newly flashed rom on this phone (from here: http://forum.xda-developers.com/show....php?t=2589303) - every thing is o.k. but I cant connect to the google play / add new account to the phone etc...
i get error:
"there was a problem communicating with google servers/ try again later"

installing the Google Play Store 4.6.16 did not help - still the same error.
can you help??
Last edited by ramf_od; 18th April 2014 at 02:03 PM.
6th July 2014, 03:27 PM |#4  
Lange-199's Avatar
Junior Member
Thanks Meter: 4
 
More
Quote:
Originally Posted by ramf_od

Hi, I don't have 2-step Authentication enabled on my google account...
this is a newly flashed rom on this phone (from here: http://forum.xda-developers.com/show....php?t=2589303) - every thing is o.k. but I cant connect to the google play / add new account to the phone etc...
i get error:
"there was a problem communicating with google servers/ try again later"

installing the Google Play Store 4.6.16 did not help - still the same error.
can you help??

I don't know if you've fixed this already, but I deleted the data and cache of every Google app and I'd worked.
The Following 2 Users Say Thank You to Lange-199 For This Useful Post: [ View ]
6th July 2014, 05:33 PM |#5  
Junior Member
Thanks Meter: 16
 
More
Thanks for the info.
Quote:
Originally Posted by Lange-199

I don't know if you've fixed this already, but I deleted the data and cache of every Google app and I'd worked.

Thanks for the info.
I solved it by installing PrebuiltGmsCore.apk from here * can't post the link...
Thanks again,
Ram
The Following 16 Users Say Thank You to ramf_od For This Useful Post: [ View ]
18th July 2014, 03:10 PM |#6  
Junior Member
Thanks Meter: 0
 
More
thanks a ton mate
Quote:
Originally Posted by ramf_od

Thanks for the info.
I solved it by installing PrebuiltGmsCore.apk from here * can't post the link...
Thanks again,
Ram

you are awesome mate!
thanks a ton!
6th August 2014, 12:48 PM |#7  
revano's Avatar
Junior Member
Flag jakarta
Thanks Meter: 4
 
More
Thumbs up
Quote:
Originally Posted by ramf_od

Thanks for the info.
I solved it by installing PrebuiltGmsCore.apk from here * can't post the link...
Thanks again,
Ram

OMG Thx alot man you save my life

i had this error for about 2 weeks can't sign in google account....

and now just simply reinstal the PrebuiltGmsCore.apk it work again like charm
The Following User Says Thank You to revano For This Useful Post: [ View ]
17th August 2014, 08:27 AM |#8  
Junior Member
Thanks Meter: 1
 
More
correct gapps
The same error happened to me when I was trying to use the most recent gapps that cyanogenmod links to when I needed an older version
The Following User Says Thank You to daniel451983 For This Useful Post: [ View ]
24th August 2014, 07:47 PM |#9  
Junior Member
Thanks Meter: 1
 
More
Quote:
Originally Posted by ramf_od

Thanks for the info.
I solved it by installing PrebuiltGmsCore.apk from here * can't post the link...
Thanks again,
Ram

This work like charm. Thanks
29th August 2014, 11:23 PM |#10  
Member
Thanks Meter: 3
 
More
Quote:
Originally Posted by Android Tz

This work like charm. Thanks

It Worked!!! i was losing hope on this phone
Google PrebuiltGmsCore.apk and the first link is the one you need
The Following User Says Thank You to ZeroCool11 For This Useful Post: [ View ]
Post Reply Subscribe to Thread

Tags
account and sync, server error, sync error
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes