FORUMS

Battery State Showing always 100% after flushng LegacyXperia CM11

236 posts
Thanks Meter: 52
 
By chiragvagh, Senior Member on 16th February 2014, 12:45 PM
Post Reply Subscribe to Thread Email Thread
Dear All,

I am having Xperia Pro MK16i

I am having problem in battery percentage output shown by android system, after flushing custom kernal which is supplied with legacyXPERIA CM11 rom (no issue at this time) and than I return back to stock ICS kernal, the battery is showing always 100%. Even if I connect charger it shows me charged.

Before flushing legacyXPERIA CM11 kernal, I have tired so many different custom kernal but, I like CM10, 10.1, NaA 3.4.0 kernal and return back to stock ICS, I was not having this issue any time.

For recovery of this issue I have tried to flush again the legacyXPERIA CM11 kernal (it will show the correct battery percentage) and get back to stock ICS will agnain show battery 100%. Than I tried to flush jush my backuped stock GB rom (it will show the correct battery percentage) and get back to stock ICS will show correct battery percentage.

Also the important thing it that, I found that this problem is happening every time i remove the battery.

If any one can help me, please give your suggestions what to do.

Thanks in advance
Last edited by chiragvagh; 17th February 2014 at 04:11 AM.
 
 
20th February 2014, 04:44 AM |#2  
karanrajkapur's Avatar
Senior Member
Flag New Delhi
Thanks Meter: 609
 
More
@chiragvagh it's because of frequent ROM flashing. Flash stock ftf, give it a full charge, calibrate the battery and then reflash your desired ROM.

Sent from my Xperia Neo V using XDA Premium 4 mobile app
Last edited by karanrajkapur; 20th February 2014 at 04:47 AM.
2nd March 2014, 07:44 AM |#3  
Member
Flag INDIA
Thanks Meter: 22
 
More
I have this issue several times and realised that flashing firmware will not help. Flashed different ROM no HELP, Flashed GB, ICS Fw no HELP.
Only thing helped me is changing the kernel - try anything except stock kernel. Hope this helps you
3rd March 2014, 08:01 AM |#4  
bettencourt90's Avatar
Member
Thanks Meter: 1
 
More
Just flash another kernel may fix it

sent from my motorola t190
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes