FORUMS

What Features Do You Look for in a Gallery App?

With so many different options to choose from, finding the right Gallery app may be a … more

Google Photos ‘Unlimited’ Storage Reportedly Being Capped

When Google Photos was announced, many of us thought very highly … more

Sprint Moves to Lift Video Streaming Limit for All-In

Yesterday, Sprint announced a new unlimited scheme that offered customers an … more

Xiaomi Releases Kernel Source Code For Mi4i

If you’ve been following the XDA News Portal lately, you might have noticed an … more

[Q] Bricked XT890

3 posts
Thanks Meter: 0
 
By rwl, Junior Member on 5th March 2014, 01:23 AM
Post Reply Subscribe to Thread Email Thread
Hi. The problem is as follows: phone stuck on boot screen. I can boot into fastboot mode, but choice of any menu item returns to the boot screen. Accordingly, I can't boot into recovery. I flashed a different recovery (stock, CWM, TWRP), but still can't boot into it. I also tried to flash system. Fastboot writes following: "BLKDISCARD ioctl /dev/block/mmcblk0 fail".
I could be wrong, but I think that is a hardware problem, because /dev/block/mmcblk0 is internal memory.
I hope for your help.

P.S. Sorry for my bad english.
Attached Thumbnails
Click image for larger version

Name:	IMG_1944.jpg
Views:	329
Size:	246.9 KB
ID:	2613782   Click image for larger version

Name:	vc.png
Views:	201
Size:	9.4 KB
ID:	2613783  
 
 
5th March 2014, 01:08 PM |#2  
Senior Member
Flag Hamburg, DE
Thanks Meter: 46
 
More
Quote:
Originally Posted by rwl

also tried to flash system...

i cant tell if its a hardware failure.
but did you try RSD-Lite to flash? if not go for it.
5th March 2014, 11:42 PM |#3  
OP Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by 5m00v3

i cant tell if its a hardware failure.
but did you try RSD-Lite to flash? if not go for it.

Yes, I tried to flash using RSD lite, also unsuccessfully.
Attached Thumbnails
Click image for larger version

Name:	rsdlite.png
Views:	77
Size:	22.5 KB
ID:	2615605  
6th March 2014, 10:09 AM |#4  
Junior Member
Thanks Meter: 26
 
More
Quote:
Originally Posted by rwl

Yes, I tried to flash using RSD lite, also unsuccessfully.


That seems really odd.

Do you have your bootloader unlocked? If not, you may return the razr on warranty.

If it is unlocked, please give it a last try flashing my recovery from there: http://android.matthias-larisch.de/razr-i/recovery/

using fastboot flash recovery recovery.img

When that succeeds, boot into recovery (use volume down to navigate in fastboot and volume up (NOT power) to select) and try flashing your rom from zip. If that fails but recovery boot suceeds, please use adb and enter "parted /dev/block/mmcblk0 print" and post output here (maybe you should do that BEFORE trying to flash rom).

If even recovery does not flash/boot, then it really seems like a hardware error. Last try is razr i unbrick from http://forum.xda-developers.com/show....php?t=2283433 that guide although I don't think this can help.

Appreciate your feedback!
6th March 2014, 11:20 AM |#5  
OP Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by PosixCompatible

That seems really odd.

Do you have your bootloader unlocked? If not, you may return the razr on warranty.

If it is unlocked, please give it a last try flashing my recovery from there: http://android.matthias-larisch.de/razr-i/recovery/

using fastboot flash recovery recovery.img

When that succeeds, boot into recovery (use volume down to navigate in fastboot and volume up (NOT power) to select) and try flashing your rom from zip. If that fails but recovery boot suceeds, please use adb and enter "parted /dev/block/mmcblk0 print" and post output here (maybe you should do that BEFORE trying to flash rom).

If even recovery does not flash/boot, then it really seems like a hardware error. Last try is razr i unbrick from http://forum.xda-developers.com/show....php?t=2283433 that guide although I don't think this can help.

Appreciate your feedback!

Thank you very much, but phone is already sold. Most likely your recovery not be loaded as the rest. Unbrick also gave nothing.
6th March 2014, 11:49 AM |#6  
Junior Member
Thanks Meter: 26
 
More
Quote:
Originally Posted by rwl

Most likely your recovery not be loaded as the rest. Unbrick also gave nothing.

Okay. It was not really clear to me if you flashed recovery the right way, that's why I posted. Only thing special in recovery version I posted is the included parted binary which I told you later to execute, that's why I recommended that one.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes