Now Gesture Tweaks Replaces Google Now with Custom Action

On most modern Android devices with software navigation keys, swiping up from the … more

ToqAN Fixes Android 5.0 Notification Bug on Qualcomm Toq

The Qualcomm Toq is probably one of the lesser known smartwatches on the market … more

How to Root and Unlock the Google Nexus 6 on a Mac – XDA TV

In the past, XDA Developer TV Producer droidmodd3rx has shown you how to … more

Set Up Your MediaTek Device with Comprehensive Beginner’s Guide

As can be seen with the use of MediaTek chips in Android One devices … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

WiFI Signal Dropping - Nexus 7 (2012)

OP tizza2k

14th February 2014, 07:47 PM   |  #1  
OP Junior Member
Thanks Meter: 1
 
20 posts
Join Date:Joined: Feb 2014
Recently the WiFi signal on our Nexus 7 (2012/Wifi only/16gb) has been dropping regularly.

Its that bad now that even if we use the device in the same room as our router its only showing one/two bars on the signal. If we go upstairs or even in the kitchen it either disconnects or its super slow.

I have no idea why this is happening, i thought it may have been kitkat so ive downgraded back to 4.3 and im using SmoothROM with Mkernel.

Still have the same problem...

Ive tried the usual fixes that seem to be pasted all over the net... ie, changing channel on router, rebooting device, changing wifi settings

The tablet has been dropped a few times, could this have anything to do with it??
17th February 2014, 03:09 AM   |  #2  
Senior Member
Flag Toronto
Thanks Meter: 130
 
589 posts
Join Date:Joined: Apr 2011
More
Quote:
Originally Posted by tizza2k

Recently the WiFi signal on our Nexus 7 (2012/Wifi only/16gb) has been dropping regularly.

Its that bad now that even if we use the device in the same room as our router its only showing one/two bars on the signal. If we go upstairs or even in the kitchen it either disconnects or its super slow.

I have no idea why this is happening, i thought it may have been kitkat so ive downgraded back to 4.3 and im using SmoothROM with Mkernel.

Still have the same problem...

Ive tried the usual fixes that seem to be pasted all over the net... ie, changing channel on router, rebooting device, changing wifi settings

The tablet has been dropped a few times, could this have anything to do with it??

Likely the antenna in the device is loose. Dropping the tablet can cause hardware failures. That or the WiFi radio has been damaged.

deltatux
17th February 2014, 03:03 PM   |  #3  
Member
Thanks Meter: 7
 
58 posts
Join Date:Joined: Aug 2011
I briefly had similar problems after dropping my Nexus 7. The problem was that the back cover had popped loose along one side. Once I snapped it back into place the wifi signal was back to normal. It wasn't obvious that the back cover we loose until I began squeezing the front and back together and working my way around the edges.
11th March 2014, 02:53 PM   |  #4  
Junior Member
Thanks Meter: 1
 
8 posts
Join Date:Joined: Mar 2014
I would check if the pins are making contact on the back case. Pull off the back cover and bend the 2 pins out slightly so it will make a better connection. There are 3 sets of pins there, it's pretty straight forward which pins are for the wifi. There are labels on the back cover to identify which pins go to what. Good luck. This should fix your problem, unless there is a hardware issue.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes