Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,742,816 Members 39,035 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Battery always charging / Always connected to the PC?

Tip us?
 
lowamc86
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 3
Join Date: Mar 2014
Default [Q] Battery always charging / Always connected to the PC?

Hi.

After searching through the forum to find an answer to this issue, I didn't find anything. Therefore I'm creating this thread.

This issue started when I updated OTA to a CM11 nightly. Now whenever I plug my phone on the outlet to charge it or to the computer, it doesn't assume that I unplugged it when I'm done. In other words, it's always charging / always connected to the computer. I've tried to do a full wipe of the phone but it didn't solve the issue. This only happens in certain roms. I do not remember doing a factory reset and flashing the stock rom with ODIN.

However, when I unplug the phone and remove the battery, the issue is fixed. Whenever I plug it back, it starts again.7

I appreciate your help.

Thanks alot.
 
lowamc86
Old
#2  
Junior Member - OP
Thanks Meter 0
Posts: 3
Join Date: Mar 2014
Someone?
 
Mandark52
Old
#3  
Mandark52's Avatar
Senior Member
Thanks Meter 66
Posts: 231
Join Date: Aug 2012
Quote:
Originally Posted by lowamc86 View Post
Hi.

After searching through the forum to find an answer to this issue, I didn't find anything. Therefore I'm creating this thread.

This issue started when I updated OTA to a CM11 nightly. Now whenever I plug my phone on the outlet to charge it or to the computer, it doesn't assume that I unplugged it when I'm done. In other words, it's always charging / always connected to the computer. I've tried to do a full wipe of the phone but it didn't solve the issue. This only happens in certain roms. I do not remember doing a factory reset and flashing the stock rom with ODIN.

However, when I unplug the phone and remove the battery, the issue is fixed. Whenever I plug it back, it starts again.7

I appreciate your help.

Thanks alot.
Never had this problem. The only options are to flash stock rom via Odin OR wait for CM11 stable update. Try giving a hard reset.


Sent from my OCTA CORE I9500
The Following User Says Thank You to Mandark52 For This Useful Post: [ Click to Expand ]
 
black nebur
Old
#4  
Senior Member
Thanks Meter 115
Posts: 148
Join Date: Mar 2007
Quote:
Originally Posted by lowamc86 View Post
Hi.

After searching through the forum to find an answer to this issue, I didn't find anything. Therefore I'm creating this thread.

This issue started when I updated OTA to a CM11 nightly. Now whenever I plug my phone on the outlet to charge it or to the computer, it doesn't assume that I unplugged it when I'm done. In other words, it's always charging / always connected to the computer. I've tried to do a full wipe of the phone but it didn't solve the issue. This only happens in certain roms. I do not remember doing a factory reset and flashing the stock rom with ODIN.

However, when I unplug the phone and remove the battery, the issue is fixed. Whenever I plug it back, it starts again.7

I appreciate your help.

Thanks alot.
Hey my friend!
Well if you'd bought a huawei nothing of this would be happening lolol
Just kidding, well it may be related to the way how you switch off the usb connection, have you tried already to select in windows the safe switch off USB mode?
If it isn't that problem, after a nanbackup try to wipe cache and dalvick cache, and if the problem continues a full wipe may be needed, formatting system, data and cache... And freshly installing the new update from CM11...
If still continues... Well you can always trade your device with your neighbor LMAO
Anyway I would wait for a new update or a stable release...
Good luck.
Huawei Ascend G615 1GB Ram + SD Card 32 GB Samsung Class 6 HC + Custom Rom (Already tried all of them, now using B708 from JawadEly and waiting for Kholks CM11 )+TWRP V4+ Unlocked Bootloader and without modded kernel.
The Following User Says Thank You to black nebur For This Useful Post: [ Click to Expand ]
 
sh.manish11
Old
#5  
Junior Member
Thanks Meter 1
Posts: 2
Join Date: Mar 2014
Location: Bikaner
Quote:
Originally Posted by lowamc86 View Post
Hi.

After searching through the forum to find an answer to this issue, I didn't find anything. Therefore I'm creating this thread.

This issue started when I updated OTA to a CM11 nightly. Now whenever I plug my phone on the outlet to charge it or to the computer, it doesn't assume that I unplugged it when I'm done. In other words, it's always charging / always connected to the computer. I've tried to do a full wipe of the phone but it didn't solve the issue. This only happens in certain roms. I do not remember doing a factory reset and flashing the stock rom with ODIN.

However, when I unplug the phone and remove the battery, the issue is fixed. Whenever I plug it back, it starts again.7

I appreciate your help.

Thanks alot.
Try to clean up your charging point by brush or any suitable thing. some shorting might be there by dust or any other thing.
I had the same problem and resolved.
The Following User Says Thank You to sh.manish11 For This Useful Post: [ Click to Expand ]
 
lowamc86
Old
#6  
Junior Member - OP
Thanks Meter 0
Posts: 3
Join Date: Mar 2014
I did everything you suggested a couple of days ago. It didn't work.

Nebur, m8, could it be related to the modem baseband? Because it also happens when I connect it to the charger. After I unplug it, the phone says it is still charging...

The plot thickens.
 
black nebur
Old
#7  
Senior Member
Thanks Meter 115
Posts: 148
Join Date: Mar 2007
Quote:
Originally Posted by lowamc86 View Post
I did everything you suggested a couple of days ago. It didn't work.

Nebur, m8, could it be related to the modem baseband? Because it also happens when I connect it to the charger. After I unplug it, the phone says it is still charging...

The plot thickens.
Hmm... Baseband / Ril mismatch perhaps!?
But doubt it... I think that the problem is more related with usb permissions (kernel config) than with any other thing... But that's MHO...
Huawei Ascend G615 1GB Ram + SD Card 32 GB Samsung Class 6 HC + Custom Rom (Already tried all of them, now using B708 from JawadEly and waiting for Kholks CM11 )+TWRP V4+ Unlocked Bootloader and without modded kernel.

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes