Google Play Developer Distribution Agreement Due Tomorrow

Every once in a while, Google updates theGoogle PlayDeveloper Distribution … more

LG to Release Octa-Core “Nuclun” SoC in the LG G3 Screen

LG is set to follow the likes of Samsung and other manufacture its own … more

Lockdown Pro 2 Brings Material Design and Media Support

Back in March of this year, we took a look at a rather innovated security application … more

Mural Watchface Brings 500px to Android Wear

On a traditional watch, you can’t really do too much to change its appearance once … more
Post Reply

Installing modified keyboard layouts on windows 8.1

OP SixSixSevenSeven

7th March 2014, 08:04 PM   |  #1  
OP Senior Member
Thanks Meter: 324
 
1,620 posts
Join Date:Joined: Dec 2012
I've recently been trying to learn german just to expand my knowledge a bit, this of course requires german characters however I am using a laptop with a UK English keyboard for which there is no way to type german characters without the old alt+numpad trick, which is great but my laptop doesnt have a numpad either as phyical keys or a Fn+something else combo.
My intended solution was to over-ride the existing alt-gr + u = as is default on a UK keyboard to be instead and managed to create this new layout with the old Microsoft Keyboard Layout Creator tool here: http://www.microsoft.com/en-us/downl....aspx?id=22339

But I cannot for the life of me work out how to activate a file created with that tool as my actual keyboard layout.
The only guide I found simply said to double click the .ksc file and windows will do the rest, no, it opened the tool again. If I select project > test keyboard layout it works 100% perfectly. I did find build DLL and setup package in that menu too, this gave me a setup.exe which I have ran but my new layout does not appear as an option in control panel as a selectable layout for any language?

I have tried rebooting the system, it still doesnt appear as an option. Is it not possible to use 3rd party keyboard layouts anymore?
7th March 2014, 08:32 PM   |  #2  
OP Senior Member
Thanks Meter: 324
 
1,620 posts
Join Date:Joined: Dec 2012
Rebooted (again), re-ran the setup program, rebooted again and it still wasnt there but was importable as a layout in the editing tool, rebooted yet again and it suddenly enabled itself as the active language.

So I guess its sorted but being very temperamental about installation in the first place.
7th March 2014, 09:11 PM   |  #3  
e.mote's Avatar
Senior Member
Thanks Meter: 873
 
2,133 posts
Join Date:Joined: Feb 2011
Why not just install the German keyboard via Control Panel | Language. It's fast to toggle between keyboards with Win+Space. Umlauted vowels (and anything language-specific) are then easily accessible.

For single-key mapping, the old KeyTweak still works fine in 8.1. Pretty simple to use. My old KB doesn't have the Windows key, and I was surprised that it could be remapped.
7th March 2014, 09:28 PM   |  #4  
OP Senior Member
Thanks Meter: 324
 
1,620 posts
Join Date:Joined: Dec 2012
That was my original workaround, but that stuck the umlauted keys ontop of things like - and ; At least with my reconfigured keyboard I can make the connection between u and and I no longer have to cycle languages occasionally, didnt appreciate the swapping of Y and Z much either.

Although thats another weird issue. right now win key + space does nothing because I have turned german language off again, but sometimes after restoring from hibernate English US appears as an option I can switch between, then hibernate and resume the machine again and English US disappears? Very strange, not a major issue at least.
8th March 2014, 12:06 AM   |  #5  
e.mote's Avatar
Senior Member
Thanks Meter: 873
 
2,133 posts
Join Date:Joined: Feb 2011
>but that stuck the umlauted keys ontop of things like - and ;

If you're learning Deutsch, I doubt a single key remap is adequate. Have hard-copy printout of the KB layout next to you, and refer to it. Or, if you just need the occasional //, toggle out, type the char, and toggle back to ENG. Although English is now my primary language, this is what I do when I need to type in my native tongue.

Have not encountered issues with hibernating and disappearing keyboards. Then again, I don't do hib. The active keyboard has an indicator on the taskbar, so there shouldn't be confusion.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes