Post Reply

Help Watch doesn't switch back on

OP death_entry

19th May 2014, 07:53 PM   |  #1  
OP Senior Member
Flag London
Thanks Meter: 26
 
258 posts
Join Date:Joined: Nov 2006
More
I went to restart my TS and now it won't switch back on at all.... nothing happening and no response... I have left it on charge and it gets slightly warm but nothing happens?? Any ideas??
20th May 2014, 03:16 PM   |  #2  
Senior Member
Flag London
Thanks Meter: 28
 
407 posts
Join Date:Joined: Apr 2009
Quote:
Originally Posted by death_entry

I went to restart my TS and now it won't switch back on at all.... nothing happening and no response... I have left it on charge and it gets slightly warm but nothing happens?? Any ideas??

You tried holding the power button down for more than 2 seconds?
20th May 2014, 03:28 PM   |  #3  
Senior Member
Thanks Meter: 81
 
428 posts
Join Date:Joined: Nov 2013
I don't think that will help. The watch arrives set in quickboot mode and it can crash in that mode and not restart right. Might be the problem here, or his display backlight might have failed. Or his power button might have failed.

Anyway, try a battery pull. A full restart after a real shutdown via battery pull will probably recover the watch to where you can go in and disable quickboot.
Instructions are in other threads.

Sent from my Nexus 5 using Tapatalk
20th May 2014, 08:42 PM   |  #4  
OP Senior Member
Flag London
Thanks Meter: 26
 
258 posts
Join Date:Joined: Nov 2006
More
Yeh I tried holding down every button etc for looong time... Today it's actually it's started working again clever tactics I tried....

Stop playing it with it for a day (Vital part this!)
Plug it into computer for 15mins
Hold power down.... it came on Woop
The Following User Says Thank You to death_entry For This Useful Post: [ View ]
22nd May 2014, 09:18 AM   |  #5  
Senior Member
Flag Somewhere in Asia
Thanks Meter: 728
 
1,844 posts
Join Date:Joined: Apr 2012
More
Quote:
Originally Posted by death_entry

Yeh I tried holding down every button etc for looong time... Today it's actually it's started working again clever tactics I tried....

Stop playing it with it for a day (Vital part this!)
Plug it into computer for 15mins
Hold power down.... it came on Woop

One thing that people need to be aware of--after doing a Cache and Dalvik wipe in TWRP Recovery--the phone can 'seem' like it's stuck in Boot mode--BUT, it's just taking it's time to re-align all the apps, software etc... and I mean at least 10 minutes of looking at a stationary Boot screen--it worried me first time.
22nd May 2014, 09:24 AM   |  #6  
Member
Thanks Meter: 0
 
37 posts
Join Date:Joined: Mar 2014
Well, mines gone too. It was fully charged. I was listening to music, turned off the app, put watch on standby and when I went to check the time the thing won't turn back on. Tried connecting it to the charger but no response. I'm going to open it up and see if that works. I know I'll loose my warranty for this (doubt I have one as I got mine through Expansys.jp), If it doesn't work then I can confirm that swett, and not much of it will break your truesmart.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes