FXP Team Delivers Lollipop to Various Xperia Devices!

From all of us here at XDA-Developers, we’d like to wish you Happy Holidays! If … more

Turn Your Camera Into a Live Puzzle Game

The classic sliding puzzle game hasnt changed much, if at all, over the years. Dating all the way … more

Samsung Begins Production of 8 Gb RAM Chips

With the release of Android 5.0, our favorite mobile operating system has become 64-bit ready. … more

CM, Micromax and OnePlus – Sales Ban Lifted

It’s less than a week since our recent in-depth analysis of the legal battle over the … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

Pac-Rom + Pink kernel 20140319: WiFi not working: workaround

OP matttbe

20th March 2014, 09:20 AM   |  #1  
matttbe's Avatar
OP Junior Member
Thanks Meter: 9
 
18 posts
Join Date:Joined: Mar 2014
More
Hello,

Sorry, I have to post this workaround here because I'm new on xda and I can't post an answer on the development forums. So if someone see that, please post a link to this thread on PAC ROM or pink kernel topic

It seems there is a new file in the modules directory which is a symbolic link named wlan.ko. As an easy workaround, simply replace this file (/system/lib/modules/wlan.ko) by this one: /system/lib/modules/pronto/pronto_wlan.ko (move this file to the parent directory and rename it). Then reboot, you should have the WiFi working now

PS: I guess it's maybe better to modify the symlink or load the correct module but it's harder to write command lines with a smartphone
The Following User Says Thank You to matttbe For This Useful Post: [ View ]
21st March 2014, 03:14 PM   |  #2  
matttbe's Avatar
OP Junior Member
Thanks Meter: 9
 
18 posts
Join Date:Joined: Mar 2014
More
According to some people, this bug should be fixed now.
22nd March 2014, 08:46 PM   |  #3  
Mycroft-Dev's Avatar
Member
Flag Right here!
Thanks Meter: 36
 
60 posts
Join Date:Joined: Mar 2014
More
Arrow Doesn't work!
Sadly, doesn't work on PA/C-RoM.

Edit: Thought I'd elaborate a bit. There's no wlan.ko in /system/lib/modules/, so I just copied the pronto_wlan.ko, renamed it to wlan.ko, repacked it and flashed it.
Last edited by Mycroft-Dev; 22nd March 2014 at 08:58 PM. Reason: Elaboration
22nd March 2014, 08:57 PM   |  #4  
matttbe's Avatar
OP Junior Member
Thanks Meter: 9
 
18 posts
Join Date:Joined: Mar 2014
More
Quote:
Originally Posted by Mycroft-Dev

Sadly, doesn't work on PA/C-RoM.

Did you try the latest nightly version? I no longer have this problem with the latest PAC-ROM (And I think there is a another fix for your XT1033 )

PS: You can also try to just remove the symlink: /system/lib/modules/wlan.ko
The Following User Says Thank You to matttbe For This Useful Post: [ View ]
22nd March 2014, 09:14 PM   |  #5  
Mycroft-Dev's Avatar
Member
Flag Right here!
Thanks Meter: 36
 
60 posts
Join Date:Joined: Mar 2014
More
Thumbs down
Quote:
Originally Posted by matttbe

Did you try the latest nightly version? I no longer have this problem with the latest PAC-ROM (And I think there is a another fix for your XT1033 )

PS: You can also try to just remove the symlink: /system/lib/modules/wlan.ko

Well, Wi-Fi still refuses to work after removing the symlink!
D'you know any other fixes? Tried lots of stuff, meself, but that is one stubborn bug!

Cheers, mate!
Last edited by Mycroft-Dev; 22nd March 2014 at 09:18 PM.
22nd March 2014, 09:37 PM   |  #6  
matttbe's Avatar
OP Junior Member
Thanks Meter: 9
 
18 posts
Join Date:Joined: Mar 2014
More
Quote:
Originally Posted by Mycroft-Dev

D'you know any other fixes? Tried lots of stuff, meself, but that is one stubborn bug!

No :-/

Maybe you can try to reinstall the latest nightly version of your rom (released after March 20th -- I think it's the case for C-RoM), reboot and check if the WiFi is working. If yes, don't disable it now then reinstall the latest version of Pink kernel.
But if the WiFi is still not working, it's annoying... You can reformat /system where kernel modules are installed but I think it's automatically done when installing a rom. Maybe they are not using the latest version of the kernel?
22nd March 2014, 09:51 PM   |  #7  
matttbe's Avatar
OP Junior Member
Thanks Meter: 9
 
18 posts
Join Date:Joined: Mar 2014
More
Quote:
Originally Posted by Mycroft-Dev

Edit: Thought I'd elaborate a bit. There's no wlan.ko in /system/lib/modules/, so I just copied the pronto_wlan.ko, renamed it to wlan.ko, repacked it and flashed it.

What did you mean by saying: "repacked it and flashed it"? If you flash the ROM, it will format and reinstall /system partition (correct me if it's wrong).
When I had this bug, I replaced wlan.ko symlink file by this one: pronto/pronto_wlan.ko. Then I rebooted (or I guess you can use this command if modprobe is available but it's easier to reboot : adb shell "modprobe -r wlan && modprobe wlan").
22nd March 2014, 10:23 PM   |  #8  
Mycroft-Dev's Avatar
Member
Flag Right here!
Thanks Meter: 36
 
60 posts
Join Date:Joined: Mar 2014
More
Lightbulb Clarification
Quote:
Originally Posted by matttbe

What did you mean by saying: "repacked it and flashed it"? If you flash the ROM, it will format and reinstall /system partition (correct me if it's wrong).
When I had this bug, I replaced wlan.ko symlink file by this one: pronto/pronto_wlan.ko. Then I rebooted (or I guess you can use this command if modprobe is available but it's easier to reboot : adb shell "modprobe -r wlan && modprobe wlan").

As in, I repacked the kernel, and then flashed it.
I'll try tweaking a bit here and there, and let you know how it goes.
And yes, I flashed the latest C-RoM.

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes