Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,740,872 Members 52,999 Now Online
XDA Developers Android and Mobile Development Forum

Urgent Help required. Please solve my problem

Tip us?
 
Aashirg
Old
#1  
Member - OP
Thanks Meter 0
Posts: 34
Join Date: Aug 2012
Info 2 Urgent Help required. Please solve my problem

i have Xperia mini (st15i) cell phone. there was a lot of dust inside it and over its LCD screen so i opened the screws of this and cleaned the dust from inside and from the screen also. but when i assembled the phone again and turned the phone ON there is no display. only the light on the top of the phone is turning ON and there is no other light on the phone or screen is turning ON. phone also vibrates when i turn it on as usual only display is not coming.

I have replaced the LCD screen with new one but problem is same. i dont know what to do know please help me to solve this problem. i will be very thankful to you..
 
bejunk
Old
#2  
bejunk's Avatar
Senior Member
Thanks Meter 1173
Posts: 1,150
Join Date: May 2013
Location: Berlin
Quote:
Originally Posted by Aashirg View Post
i have Xperia mini (st15i) cell phone. there was a lot of dust inside it and over its LCD screen so i opened the screws of this and cleaned the dust from inside and from the screen also. but when i assembled the phone again and turned the phone ON there is no display. only the light on the top of the phone is turning ON and there is no other light on the phone or screen is turning ON. phone also vibrates when i turn it on as usual only display is not coming.

I have replaced the LCD screen with new one but problem is same. i dont know what to do know please help me to solve this problem. i will be very thankful to you..
probably u damaged yr board or the connection cable. thats why u never should do sth if u not know what u are EXACTLY doing.

we cant really help here, bcuz to do this we would dissassemble the device & take a look. bring it to a tech shop, bcuz like said sth with the HW is surely damaged. sry
.../// LT18i /// LegacyXperia 4.4.4 /// baseband .77 ///...
 
 
Aashirg
Old
#3  
Member - OP
Thanks Meter 0
Posts: 34
Join Date: Aug 2012
today i was checking the phone LCD today and during checking phone display appeared for few moment and than disappeared again.



Quote:
Originally Posted by bejunk View Post
probably u damaged yr board or the connection cable. thats why u never should do sth if u not know what u are EXACTLY doing.

we cant really help here, bcuz to do this we would dissassemble the device & take a look. bring it to a tech shop, bcuz like said sth with the HW is surely damaged. sry
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes