FORUMS

[Q] Stuck in 3G, have to switch to 4G manually... why?

3 posts
Thanks Meter: 0
 
By falenus, Junior Member on 9th March 2014, 07:47 PM
Post Reply Subscribe to Thread Email Thread
Hello,

Recently my HTC One's antenna began acting strange. I flashed LiquidSmooth 3.0 beta with the provided Nuk3K3rn3l for m7spr. My phone was stuck in roaming and after calling *226, my phone apparently successfully activated itself to Verizon.

I've since reflashed back to a stock ROM/kernel, and while my 4G connectivity works fine, it will default to 3G any time it gets the chance and won't automatically switch back. I have to go into my settings, switch the GSM mode, and then switch back to CDMA/LTE (PRL) and 4G works perfectly. It will do this no matter what ROM/kernel I'm running.

Do I need a new RUIM? Do I need to reset my PRL and if so, how? Or am I just ****ed?
 
 
9th March 2014, 08:00 PM |#2  
yojoe600's Avatar
Senior Member
Flag Greensboro, NC
Thanks Meter: 452
 
Donate to Me
More
Go get a new Sim card to fix the issue.

Sent from my only One.
9th March 2014, 10:14 PM |#3  
Senior Member
New York
Thanks Meter: 28
 
More
Question
Quote:
Originally Posted by falenus

Recently my HTC One's antenna began acting strange. I flashed LiquidSmooth 3.0 beta with the provided Nuk3K3rn3l for m7spr.

You're asking a out a problem on an m7spr in a Forum devoted to the m7vzw???
9th March 2014, 10:59 PM |#4  
cmlusco's Avatar
Senior Member
Flag Michigan City, IN
Thanks Meter: 936
 
Donate to Me
More
Wrong forum, but look into updating your firmware.
10th March 2014, 02:04 AM |#5  
OP Junior Member
Thanks Meter: 0
 
More
The phone is an m7vzw, the kernel provided in the thread was an (allegedly) modified m7spr kernel. Thanks for the responses, that was what I figured... $11 mistake I suppose lol
10th March 2014, 03:03 AM |#6  
Senior Member
Flag Bentonville
Thanks Meter: 72
 
More
New sim freind had same issue
A new sim card will fix this issue hoped this helped.



Quote:
Originally Posted by falenus

Hello,

Recently my HTC One's antenna began acting strange. I flashed LiquidSmooth 3.0 beta with the provided Nuk3K3rn3l for m7spr. My phone was stuck in roaming and after calling *226, my phone apparently successfully activated itself to Verizon.

I've since reflashed back to a stock ROM/kernel, and while my 4G connectivity works fine, it will default to 3G any time it gets the chance and won't automatically switch back. I have to go into my settings, switch the GSM mode, and then switch back to CDMA/LTE (PRL) and 4G works perfectly. It will do this no matter what ROM/kernel I'm running.

Do I need a new RUIM? Do I need to reset my PRL and if so, how? Or am I just ****ed?

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes