FORUMS

Hands-on With T-Mo LG G4 and Q&A

XDA Senior Member WinDroidGuy posted a hands-on video of the T-Mobile LG G4, and he is now … more

Quick Notes – Notification Panel Reminders

This app by XDA Senior Member yogi.306 is a quick and productive tool that … more

Who Is Your Favorite YouTuber That Covers Mobile?

There are dozens of talented YouTubers who cover mobile, but we want to know which … more

Galaxy S6 Shipping with Different Camera Models

One of the Galaxy S6’s most flaunted features is its spectacular camera, its 16MP … more
Post Reply Subscribe to Thread Email Thread

[q] 4.3 jellybean ota questions

8th March 2014, 06:24 AM |#1  
OP Junior Member
Thanks Meter: 0
 
More
I've got a Galaxy S3 I747 it is currently running 4.1.1, I747UCDLK3 Baseband. I'm not exactly a noob when it comes to flashing and rooting, I know my way around CWM and Odin pretty well. But I have a few questions on this 4.3 OTA. (I am a forum noob)

-Will I still be able to root? (I heard CF works for it)

-Can I install CWM? (Is the Bootloader locked??)

-Will I be be able to I flash other roms than the 4.3 TW like CM11Snapshot? (Is the bootloader locked?)

-What the h*ll is knox and why should I be worried?

-What is with the boot loader downgrading thing? (Have to do with locked bootloader??)

I AM NOT AT ALL WORRIED ABOUT A FLASH COUNTER OR VOIDING A WARRANTY I AM NOT ON A CONTRACT . I JUST DO NO WANT TO HARD BRICK MY PHONE.
 
 
8th March 2014, 01:20 PM |#2  
audit13's Avatar
Senior Member
Flag Toronto
Thanks Meter: 1,776
 
More
If you take the OTA 4.3 update, it will install Knox and the 4.3 bootloader.

The 4.3 bootloader cannot be downgraded and attempts to do so will probably brick the phone.

You can root the stock 4.3 ROM with auto root but Knox may interfere with the process of cause issues after the fact.

You can still install CWM. I rrefer Philz Touch which is CWM-based.over TWRP.
8th March 2014, 09:26 PM |#3  
OP Junior Member
Thanks Meter: 0
 
More
So can I still flash roms?

Sent from my SAMSUNG-SGH-I747 using xda app-developers app
8th March 2014, 09:59 PM |#4  
audit13's Avatar
Senior Member
Flag Toronto
Thanks Meter: 1,776
 
More
Yes, you can flash ROMs. Is your phone unlocked? Since you're on 4.1.1 stock, you can unlock it for free.

Personally, I avoided the 4.3 update because it installs knox and the 4.3 bootloader which can cause problems when using Odin to get back to stock.

I have a Canadian version of the s3 and I'm able to run KK ROMs with a stock 4.1.2 bootloader.
The Following User Says Thank You to audit13 For This Useful Post: [ View ]
9th March 2014, 12:00 AM |#5  
OP Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by audit13

Yes, you can flash ROMs. Is your phone unlocked? Since you're on 4.1.1 stock, you can unlock it for free.

Personally, I avoided the 4.3 update because it installs knox and the 4.3 bootloader which can cause problems when using Odin to get back to stock.

I have a Canadian version of the s3 and I'm able to run KK ROMs with a stock 4.1.2 bootloader.


Unlocked as in Bootloader? Yeah I've been able to flash roms via CWM and Odin on 4.1.1 and as in Carrier unlocked? Yes I use Straight Talk on this ATT S3 :P
If I got the 4.3OTA I wouldn't need Odin to go back stock if I flashed a ROM would I? I could just make a back up via CWM then restore later if I wanted right rather than using ODIN?
See I can't use KK roms because I have the 4.1.1 BL so is there a way I can upgrade my boot loader to the 4.1.2 version??

Would I lose my carrier unlock if I upgraded to 4.3 or if I upgrade my bootloader??
Last edited by SapiasLupus; 9th March 2014 at 12:11 AM.
9th March 2014, 12:17 AM |#6  
audit13's Avatar
Senior Member
Flag Toronto
Thanks Meter: 1,776
 
More
I suggest downloading a ROM you want to try, then unzip the ROM and look at the updater script to see which bootloaders are supported. The updater-script file is located in \META-INF\com\google\android\updater-script. You can use a text editor to open the updater-script file.

The first few lines will list the bootloaders that are supported. I run Validus which is a KK ROM using a stock 4.1.2 i747m bootloader.
9th March 2014, 12:24 AM |#7  
OP Junior Member
Thanks Meter: 0
 
More
Do you know about this > "If I got the 4.3OTA I wouldn't need Odin to go back stock if I flashed a ROM would I? I could just make a back up via CWM then restore later if I wanted right rather than using ODIN?"

Also couldn't I just upgrade my Bootloader and Modem from here?
http://forum.xda-developers.com/show....php?t=2321310
http://forum.xda-developers.com/show....php?t=1831898

I feel like if I upgrade my boot loader then I won't have to worry about restrictions.


Would I lose my carrier unlock if I upgraded to 4.3 or if I upgrade just my bootloader??
9th March 2014, 05:24 AM |#8  
OP Junior Member
Thanks Meter: 0
 
More
I ended up flashing the MG2 Modem and Bootloader, I'm good now, also if I want 4.3 I saw loserskater has a leak version that will be good and wont not let me downgrade my bootloader.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in AT&T Galaxy S III Q&A, Help & Troubleshooting by ThreadRank