Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

Unhappy Z1 Power Button issue

OP stratplayer

18th January 2014, 11:22 PM   |  #1  
stratplayer's Avatar
OP Senior Member
Flag Bristol
Thanks Meter: 16
 
390 posts
Join Date:Joined: Nov 2009
More
A couple of weeks ago I noticed that my power button felt different on my Z1. At first I thought it was my imagination, but more and more I was sure something wasnt right.

Last week on the way to work, my colleague who also has a Z1 used my phone to look at something and his first comment was "Whats up with your power button??"

It has no definite feeling when pressing it, its almost impossible to tell if you have pressed it or not, it looks and feels recessed too.

When trying his phone it was exactly as I remembered it to be, when you push it you can feel as response (small click or resistance), on mine there is nothing!

So I contacted Sony Xperia, who were suprised by the described issue. Long story short I have to return the phone to them for a 5 - 7 day turnaround repair.

Anyone else had the same issue? Or even sent their phone back to Sony in the UK? I am a little concerned that once it is prised open to be repaired it will never be the same again! All in all, for the 550 I paid for a premium handset, it is the first one that I have had any hardware issues with.
18th January 2014, 11:31 PM   |  #2  
eclyptos's Avatar
Senior Member
Planet Earth
Thanks Meter: 617
 
2,984 posts
Join Date:Joined: Jun 2008
Quote:
Originally Posted by stratplayer

Anyone else had the same issue?

I saw a problem like that with a device of my friend and he felt exactly in the same way, it's a faulty botton, have to be replaced.

Quote:
Originally Posted by stratplayer

I am a little concerned that once it is prised open to be repaired it will never be the same again! All in all, for the 550 I paid for a premium handset, it is the first one that I have had any hardware issues with.

I can truly understand you. Same here. I always get a mid range phones and never had problems. This one I paid a lot of money, issues everywhere. I sent mine back to Sony as well, but for different reason.
The Following User Says Thank You to eclyptos For This Useful Post: [ View ]
19th January 2014, 12:09 AM   |  #3  
stratplayer's Avatar
OP Senior Member
Flag Bristol
Thanks Meter: 16
 
390 posts
Join Date:Joined: Nov 2009
More
Quote:
Originally Posted by eclyptos

I saw a problem like that with a device of my friend and he felt exactly in the same way, it's a faulty botton, have to be replaced.



I can truly understand you. Same here. I always get a mid range phones and never had problems. This one I paid a lot of money, issues everywhere. I sent mine back to Sony as well, but for different reason.

Was your device ok when it came back? All the edges aligned, sealed etc etc?? It is a worry for me, how do I know it is waterproof still for example?
19th January 2014, 12:18 AM   |  #4  
eclyptos's Avatar
Senior Member
Planet Earth
Thanks Meter: 617
 
2,984 posts
Join Date:Joined: Jun 2008
Quote:
Originally Posted by stratplayer

Was your device ok when it came back? All the edges aligned, sealed etc etc?? It is a worry for me, how do I know it is waterproof still for example?

Mine do not come back yet, I sent it back via warranty 2 weeks ago. I will let you know. Anyway Sony Service have to provide best service for your phone and it should be still under warranty even when the phone come back to you but in which condition this is a mystery for all of us.
19th January 2014, 12:23 AM   |  #5  
stratplayer's Avatar
OP Senior Member
Flag Bristol
Thanks Meter: 16
 
390 posts
Join Date:Joined: Nov 2009
More
Quote:
Originally Posted by eclyptos

Mine do not come back yet, I sent it back via warranty 2 weeks ago. I will let you know. Anyway Sony Service have to provide best service for your phone and it should be still under warranty even when the phone come back to you but in which condition this is a mystery for all of us.

They said 5 - 7 days on the phone Friday, if you sent it two weeks ago and are still waiting then that's pretty poor I think.
19th January 2014, 12:27 AM   |  #6  
eclyptos's Avatar
Senior Member
Planet Earth
Thanks Meter: 617
 
2,984 posts
Join Date:Joined: Jun 2008
Quote:
Originally Posted by stratplayer

They said 5 - 7 days on the phone Friday, if you sent it two weeks ago and are still waiting then that's pretty poor I think.

I know but what I can do. At the moment are 10 working days. Next week I will start call them and complain to rush they asses.
25th January 2014, 03:54 PM   |  #7  
NiM72NiK's Avatar
Senior Member
Flag Tehran
Thanks Meter: 33
 
200 posts
Join Date:Joined: Jun 2012
More
I have the exact same problem guys. repairing it needs a special technique? (for water resistance issues)
25th January 2014, 04:22 PM   |  #8  
eclyptos's Avatar
Senior Member
Planet Earth
Thanks Meter: 617
 
2,984 posts
Join Date:Joined: Jun 2008
Quote:
Originally Posted by NiM72NiK

I have the exact same problem guys. repairing it needs a special technique? (for water resistance issues)

I think is needed a experience because you have to take apart all phone and I will suggest to let do this job to Sony. And of curse it will have to be seal again to make the water resistance working again. If you do all of this the warranty will be gone.
25th January 2014, 04:39 PM   |  #9  
stratplayer's Avatar
OP Senior Member
Flag Bristol
Thanks Meter: 16
 
390 posts
Join Date:Joined: Nov 2009
More
An update on mine, it got worse and now has been sent back for warranty repair at Sony, well they use a company called SBE Ltd in the UK

I'm not very impressed to be honest, this is the first phone I've had to return to the manufacturer for repair, this was meant to be a quality product. So there is at least 3 people with the same problem, maybe more who haven't noticed. Potentially there is an issue with the design or button component.

In so cheese off as I have to use a crappy Nokia Lumia 800 Windows phone for the period it is away!

I have been looking at a Nexus 5 or Note 3 as a replacement, selling mine on eventual return from repair..

Sent from my Nexus 7 using XDA Premium HD app
25th January 2014, 05:30 PM   |  #10  
Senior Member
Flag Haverhill MA
Thanks Meter: 884
 
2,992 posts
Join Date:Joined: Oct 2010
More
I'm having issues with my volume down rocker. It is much harder to press then volume up it also doesn't have the clicking sound volume up gives when you press it. Of course I'm within my return window so I'm waiting for my replacement phone to get here so I can ship the one I currently have back

Sent from my Xperia Z1s

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes