Post Reply

[Q] Garbled phone quality after flashing

OP kaptr1d

11th March 2014, 10:19 PM   |  #1  
OP Junior Member
Thanks Meter: 0
 
1 posts
Join Date:Joined: Aug 2012
I'm a first-time poster here but I've been using XDA for years to root and flash phones. My first android phone was the EVO 4G and I've had about 5 since then, all of them rooted and flashed multiple times with no issues to date... until now!

My wife has an older T-Mobile Galaxy S2 (T989). She was having problems with the keyboard hanging and text messages lagging so rather then wipe it and restore the stock ROM I figured I might as well update it.

I used the latest release of CWM and rooted the phone with SU.

Then I flashed a new radio ( SGH-T989D_TLMC4_radio ).
Then I flashed Paranoid Android 4.0 beta 6.
Then I flashed mini gapps.

Everything on the phone seemed to be working great but then today at work she tried making phone calls.

The phone is able to dial and make calls and pickup and receive calls but the actual call quality is terrible. The voices are all broken up and have high pitched digital noise mixed in with the voice of the other caller.

Should I experiment with flashing different radios? I did a search and couldn't find much but I wasn't sure how to word the problem so it might be a common issue that I'm not aware of. Thanks!
12th March 2014, 04:49 AM   |  #2  
Junior Member
Thanks Meter: 6
 
26 posts
Join Date:Joined: Nov 2010
Quote:
Originally Posted by kaptr1d

I'm a first-time poster here but I've been using XDA for years to root and flash phones. My first android phone was the EVO 4G and I've had about 5 since then, all of them rooted and flashed multiple times with no issues to date... until now!

My wife has an older T-Mobile Galaxy S2 (T989). She was having problems with the keyboard hanging and text messages lagging so rather then wipe it and restore the stock ROM I figured I might as well update it.

I used the latest release of CWM and rooted the phone with SU.

Then I flashed a new radio ( SGH-T989D_TLMC4_radio ).
Then I flashed Paranoid Android 4.0 beta 6.
Then I flashed mini gapps.

Everything on the phone seemed to be working great but then today at work she tried making phone calls.

The phone is able to dial and make calls and pickup and receive calls but the actual call quality is terrible. The voices are all broken up and have high pitched digital noise mixed in with the voice of the other caller.

Should I experiment with flashing different radios? I did a search and couldn't find much but I wasn't sure how to word the problem so it might be a common issue that I'm not aware of. Thanks!

I think the radio you named above is for the Telus version of the phone (not T Mobile). Here is a link to the radio thread:

http://forum.xda-developers.com/show....php?t=1895400
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes