Default [Q] LG Lucid 2 VS870 wifi saved but not connecting

I recently got an LG Lucid 2 (VS870) which is running android 4.1.2 software VS7011A. I have also tried it on VS87010B. When i go into the wifi settings, I can see and add networks, which then say "saved, secured." it does not try to obtain an ip address or anything, it just says it is saved. It worked fine for about a day, but then stopped connecting.

I have rooted it with framaroot 1.9.1 (apk attached), which installed with no problem. I have used CWM touch recover, which does not need flashing, by playfulgod (apk attached)

It has this problem for all wifi networks i have tried, and resetting the router did not help. Other than initially rooting it, i have not changed anything along those lines. I have looked all over the internet with no successful solution, and any help would be appreciated.
Attached Files
File Type: apk lte2_l1m_recovery.apk - [Click for QR Code] (3.05 MB, 3 views)
File Type: apk Framaroot-1.9.1.apk - [Click for QR Code] (1.03 MB, 12 views)