Chainfire Turns Your Bootanimation into a Logging Center

Having a nice boot animation certainly adds a little bit of aesthetic polish to your … more

Android TV Launcher Pushed to Google Play

Over the past decade, the tech universe has seen two drastic and widely contrasting changes with … more

Cyngn, OnePlus, Micromax – The Legal Battle

Recently, a battle has been waging in India over the rights to distribute the commercial … more

Lean Mean Battery Power Saving App Review

We talk a lot about battery topics here at XDA TV. We talk about everything from Power Banks to USB … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

USB Audio not working on AOSP

OP xdadevnube

10th March 2014, 01:39 AM   |  #1  
xdadevnube's Avatar
OP Senior Member
Thanks Meter: 102
 
804 posts
Join Date:Joined: Jun 2011
I tested the following ROMs and discovered they DO NOT support USB Audio:

AICP 3/06/14
AOSB 2/26/14
Carbon 3/02/14
CM10.2 2/01/14
CM11 3/07/14
Liquidsmooth 3/05/14
PACman 3/05/14
Slimkat 2/16/14

I can confirm that USB Audio DOES work with the GPE ROM. My understanding is that the GPE ROM is built from Sense, so I haven't encountered a single non/Sense ROM that supports USB Audio.
Has anybody had any luck with AOSP and USB Audio on the VZW HTC One?
Last edited by xdadevnube; 10th March 2014 at 07:24 AM.
12th March 2014, 01:41 AM   |  #2  
disconnecktie's Avatar
Senior Member
Thanks Meter: 1,248
 
5,299 posts
Join Date:Joined: Oct 2011
USB audio requires support in the kernel to work. It is highly likely this support is lacking from the aosp kernel. It is completely possible that a dev could include usb audio though. I recall seeing it as not set in the config but the proper files would also need to be put into place and who knows if that would even compile properly into aosp from sense.

Sent from my One using Tapatalk
12th March 2014, 10:22 PM   |  #3  
xdadevnube's Avatar
OP Senior Member
Thanks Meter: 102
 
804 posts
Join Date:Joined: Jun 2011
Quote:
Originally Posted by disconnecktie

USB audio requires support in the kernel to work. It is highly likely this support is lacking from the aosp kernel. It is completely possible that a dev could include usb audio though. I recall seeing it as not set in the config but the proper files would also need to be put into place and who knows if that would even compile properly into aosp from sense.

Sent from my One using Tapatalk

I tried using Lunar kernel in addition to the bundled kernel with each ROM.
I will have to check over on the Lunar thread to see if they know whether support is included in the kernel.

Interestingly, I made a little progress by flashing the latest version of the USB Audio Patcher MOD in the thread started by JackNorris. Now I get the familiar HTC One USB Audio stepping (0 or 100%, no middle steps) as well as audio being routed from the speaker.
The problem is no sound comes out of the external DAC, although it is routed away from the speaker. Basically, it is the same behavior after flashing the patch as it is in the Sense ROMs, but just no audio coming from the DAC.
I believe the issue is something missing from the Services.jar part of the framework. I am now in over my head.

Sent from my HTC6500LVW using Tapatalk 2
13th March 2014, 11:10 PM   |  #4  
nitephlight's Avatar
Senior Member
Thanks Meter: 71
 
245 posts
Join Date:Joined: Mar 2012
So on GPE roms audio works and you get output on the DAC, Sense you get stepping but no output, and AOSP stepping with patch but no output

Get the app Sound About from store and try on patched AOSP and report back plz

Sent from my HTC6500LVW using Tapatalk
6th April 2014, 05:50 AM   |  #5  
Senior Member
Thanks Meter: 6
 
129 posts
Join Date:Joined: Oct 2010
Any update, im on liquid smooth and may flash back to gpe rom.
7th April 2014, 05:54 AM   |  #6  
GrayBoltWolf's Avatar
Senior Member
Flag Raleigh, NC
Thanks Meter: 2,169
 
5,073 posts
Join Date:Joined: Mar 2012
Donate to Me
More
USB DACs work on CM11. The issue is that the phone doesn't automatically route all sound to the DAC like the stock ROM does.

It is there and working, but you wouldn't know it since the phone won't play sound through it. It is probably the same case with many other ROMs.
9th April 2014, 03:28 AM   |  #7  
Senior Member
Thanks Meter: 6
 
129 posts
Join Date:Joined: Oct 2010
Quote:
Originally Posted by GrayTheWolf

USB DACs work on CM11. The issue is that the phone doesn't automatically route all sound to the DAC like the stock ROM does.

It is there and working, but you wouldn't know it since the phone won't play sound through it. It is probably the same case with many other ROMs.

Then how does one fix the problem and get audio out of the external dac?
9th April 2014, 04:58 AM   |  #8  
GrayBoltWolf's Avatar
Senior Member
Flag Raleigh, NC
Thanks Meter: 2,169
 
5,073 posts
Join Date:Joined: Mar 2012
Donate to Me
More
Quote:
Originally Posted by coolguy71261

Then how does one fix the problem and get audio out of the external dac?

Dunno. Going to have to talk to an expert for that.
11th April 2014, 05:33 PM   |  #9  
Senior Member
Thanks Meter: 6
 
129 posts
Join Date:Joined: Oct 2010
I'm willing to do a bit of coding work to help out if needed, GPE roms are not bad at all just shouldn't be the only roms that offer usb audio.
16th April 2014, 04:26 AM   |  #10  
Senior Member
Thanks Meter: 6
 
129 posts
Join Date:Joined: Oct 2010
Any update on an aosp rom with usb audio

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes