Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

Question [Q]Xperia Pro - Screen Issues

OP ajabhi95

2nd March 2013, 07:04 PM   |  #1  
ajabhi95's Avatar
OP Senior Member
Flag Chennai
Thanks Meter: 33
 
162 posts
Join Date:Joined: Mar 2010
Donate to Me
More
Hey guys,

My Xperia Pro has been running into some problems with the display as of late. What happens is after a short period of keeping the phone idle, it doesn't wake up. When the power button or the home button is pressed, it just shows a blueish-black screen and the lights between the physical buttons light up. Same thing happens when the keyboard is slid out. The backlight of the keys work but the screen still shows a blueish-black color. After trying again and again, the screen finally works, just to run into the same problem after locking the screen.

I tried changing the ROM and flashing a different kernel to no use. Then I finally flashed a stock Gingerbread firmware. Now the screen doesn't show any blueish-black shade or anything else at all!!!! I have currently just left my phone to charge because I don't want the battery to run out during this crisis. I have also re-booted many, many times by pulling out and re-inserting the battery.

Any suggestions and tips would be highly appreciated! Thanks in advance guys!
2nd April 2013, 08:15 AM   |  #2  
AeonWorld's Avatar
Recognized Contributor
Flag Somewhere I Belong
Thanks Meter: 2,362
 
1,079 posts
Join Date:Joined: Jun 2009
Donate to Me
More
My Xperia Pro have the same issue . Like when unlock , no screen (black) ,
The issue I found out is having something to do with my back cover
ie. If I remove the cover and reboot , and then unlock /lock , no problem, As soon as i put the back cover , it unlocks with black screen , I was sure no kernel or fw was the reason , as i have been through diff kernels and fws /roms without an issue like this , and as soon as the black screen shows and you try to restart it wont even show the logo , so i was damn sure ,its no kernel issue , Please check this method , i will try to find the exact issue why the back cover is making this.

Update: Found out that the push made by back cover with the battery (which basically may be jamming the strip or something inside) is making the problem , It may have more to it than this ,anyway this is my phone's problem
The Following User Says Thank You to AeonWorld For This Useful Post: [ View ]
27th October 2013, 06:22 PM   |  #3  
Junior Member
Thanks Meter: 1
 
27 posts
Join Date:Joined: Mar 2013
Screen on but no display
Quote:
Originally Posted by AeonWorld

My Xperia Pro have the same issue . Like when unlock , no screen (black) ,
The issue I found out is having something to do with my back cover
ie. If I remove the cover and reboot , and then unlock /lock , no problem, As soon as i put the back cover , it unlocks with black screen , I was sure no kernel or fw was the reason , as i have been through diff kernels and fws /roms without an issue like this , and as soon as the black screen shows and you try to restart it wont even show the logo , so i was damn sure ,its no kernel issue , Please check this method , i will try to find the exact issue why the back cover is making this.

Update: Found out that the push made by back cover with the battery (which basically may be jamming the strip or something inside) is making the problem , It may have more to it than this ,anyway this is my phone's problem

I have the same problem, and back cover was not the solution for me. What should I do???
10th March 2014, 05:42 PM   |  #4  
phaninder.ch's Avatar
Junior Member
Thanks Meter: 0
 
5 posts
Join Date:Joined: Oct 2012
Yep the back cover is a problem!
Quote:
Originally Posted by AeonWorld

Update: Found out that the push made by back cover with the battery (which basically may be jamming the strip or something inside) is making the problem , It may have more to it than this ,anyway this is my phone's problem

That actually worked for me initially..removing the back cover and rebooting. But its not now, what ever I do I only see the dim lit LCD screen.
But yeah, I am able to unlock the phone in the blind and also hear the increase/ decrease in the volume by pressing the volume rocker and also touch and hold on the home screen to feel the vibration (guess for removing the widget or something that's already there).

So is there any solution for this, or any first aid before I get my Xperia Pro to the service centre ??
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes