FORUMS

What Do You Think About Fingerprint Scanners?

More and more phones are featuring fingerprint scanners, and with many promising … more

What’s Next for Samsung and Its Flagships?

If we were to say that the Galaxy S6 was a leap of faith made by Samsung, we … more

The Ultimate Showcase of dBrand Skins

In the search for ways to protect, accessorize, and personalize; a user has many options. One … more

Huawei’s Rapid Rise to Third Place in the Smartphone Race

Huawei has quickly grown to become one of the world’s biggest … more

[Q] Phone Incorrectly Reads Battery Level

18 posts
Thanks Meter: 0
 
By anthonyherbz, Junior Member on 11th March 2014, 06:18 AM
Post Reply Subscribe to Thread Email Thread
Hey all, I'm in need if some advice/help. My Galaxy S3 seems to be incorrectly gauging how much battery life it has.. For a better explanation, here's a familiar scenario: phone is 100% and will slowly keep creeping down by a percent with little to no use. In a few hours it "dies." If I leave it for a couple of minutes or do something like take the battery out however, it'll have a reading of 36%. I can do this several times in a row! Another instance is say it was at 100% and drops down to 80% in an hour or so. If I leave it in standby the battery level will actually start creeping back up after a couple of minutes.

I have tried these steps and suggestions to combat this problem:
  • flash to CyanogenMod
  • buy an extended battery
  • calibrate the battery with apps
  • wipe battery stats

I've run out of ideas short of bringing the phone in to T-Mobile and have it replaced. Google searching has turned up pretty fruitless so I'm asking here before I make anymore moves! Thanks for all the anticipated help.
Last edited by anthonyherbz; 11th March 2014 at 04:22 PM.
 
 
11th March 2014, 05:57 PM |#2  
Perseus's Avatar
Forum Moderator
Atlantis
Thanks Meter: 5,633
 
Donate to Me
More
Please do a factory reset and leave just the Rom and Gapps. Nothing else on there for a some time to experiment.

Please install BetterBatteryStats from the Play Store. Make sure to enable Root Features from under settings >Advanced Settings > Enable Root Features checkbox.

Next reboot the phone and then leave it alone for some time. Preferably overnight. In the morning, hit the Share button in upper right corner of the app. Choose text as the output format. It will save a text log in /SDCARD folder. Attach that here.
The Following User Says Thank You to Perseus For This Useful Post: [ View ]
12th March 2014, 11:06 AM |#3  
OP Junior Member
Thanks Meter: 0
 
More
ok I will try this
13th March 2014, 04:15 AM |#4  
OP Junior Member
Thanks Meter: 0
 
More
Currently letting my phone run the tests. Just out of curiosity I have noticed something funny already. With 55m 49s on battery, it says Wi-Fi has been running the whole time (100% ratio), and I definitely have Wi-Fi turned off.
13th March 2014, 04:33 PM |#5  
Perseus's Avatar
Forum Moderator
Atlantis
Thanks Meter: 5,633
 
Donate to Me
More
Quote:
Originally Posted by anthonyherbz

Currently letting my phone run the tests. Just out of curiosity I have noticed something funny already. With 55m 49s on battery, it says Wi-Fi has been running the whole time (100% ratio), and I definitely have Wi-Fi turned off.

There are variety of reasons. Please Turn off Google Location Reporting.

Please post a log as I described before.
14th March 2014, 04:49 AM |#6  
OP Junior Member
Thanks Meter: 0
 
More
Here's the log from BBS
14th March 2014, 01:45 PM |#7  
Perseus's Avatar
Forum Moderator
Atlantis
Thanks Meter: 5,633
 
Donate to Me
More
Are you sure you turned off Google Location Reporting ? If not then do so first. If you had done so, please turn off location service all together.
Under Settings >Wireless>Advanced, do you have "Keep Wifi on during sleep" set to never ? Also uncheck Scanning always available. Lastly what's the deal with your calendar ? Do you have so many events on there ?
14th March 2014, 01:57 PM |#8  
OP Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by Perseus71

Are you sure you turned off Google Location Reporting ? If not then do so first. If you had done so, please turn off location service all together.
Under Settings >Wireless>Advanced, do you have "Keep Wifi on during sleep" set to never ? Also uncheck Scanning always available. Lastly what's the deal with your calendar ? Do you have so many events on there ?

Location services are disabled all together. I did however have to set "Keep Wi-Fi on during sleep" to never. And no I don't have any events... Could that be the problem lol?
Last edited by anthonyherbz; 14th March 2014 at 02:03 PM.
14th March 2014, 02:10 PM |#9  
Perseus's Avatar
Forum Moderator
Atlantis
Thanks Meter: 5,633
 
Donate to Me
More
You most certainly have some Location Service going on. Please check again. You will need to wipe data for Calendar and then sync it just the one time with Google Account.
14th March 2014, 02:17 PM |#10  
OP Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by Perseus71

You most certainly have some Location Service going on. Please check again. You will need to wipe data for Calendar and then sync it just the one time with Google Account.

I checked again, all disabled. I also just wiped the data and cache for the Calendar and Calendar Storage.
14th March 2014, 02:50 PM |#11  
Perseus's Avatar
Forum Moderator
Atlantis
Thanks Meter: 5,633
 
Donate to Me
More
In that case, reboot and post an IDLE log for 4 to 5 hours.

Idle = Phone is on but not being used at all.
The Following User Says Thank You to Perseus For This Useful Post: [ View ]

Read More
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes