Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] On M919UVUAMDB. What are my options?

OP RazoE

12th March 2014, 12:09 AM   |  #1  
RazoE's Avatar
OP Senior Member
Thanks Meter: 50
 
451 posts
Join Date:Joined: Aug 2011
Donate to Me
More
Hi Guys. I got my T-Mobile Galaxy S4 in May of last year. I promptly (as soon as I got home) rooted it. It is on Baseband M919UVUAMDB and I am currently running a December 9 nightly of CM11 (4.4.1) because any newer versions cause an issue with sleep and Wifi. If my phone goes into deep sleep with WIFI on, my screen will completely freeze, requiring a battery pull.

Now I've tried multiple roms running TW based on 4.3 (Guessing they're based on the M919UVUEMK2 OTA), but they all drop data.

Now that M919UVUFNB4 is out, I was wondering what would happen if I flashed to that (waiting for a pre-rooted ROM)?

Will I have the same issues? I love CM, but TW is full of features I like to use and would like to swap back and forth if possible.

What are my options? I no longer have any backups of any stock roms (I do have a 4.2 TW ROM backed up that had NO issues. I believe it was deodexed as well, if that has to do with anything).
12th March 2014, 12:58 AM   |  #2  
crawler9's Avatar
Senior Member
Flag Ohio
Thanks Meter: 290
 
687 posts
Join Date:Joined: Mar 2010
Donate to Me
More
Quote:
Originally Posted by RazoE

Hi Guys. I got my T-Mobile Galaxy S4 in May of last year. I promptly (as soon as I got home) rooted it. It is on Baseband M919UVUAMDB and I am currently running a December 9 nightly of CM11 (4.4.1) because any newer versions cause an issue with sleep and Wifi. If my phone goes into deep sleep with WIFI on, my screen will completely freeze, requiring a battery pull.

Now I've tried multiple roms running TW based on 4.3 (Guessing they're based on the M919UVUEMK2 OTA), but they all drop data.

Now that M919UVUFNB4 is out, I was wondering what would happen if I flashed to that (waiting for a pre-rooted ROM)?

Will I have the same issues? I love CM, but TW is full of features I like to use and would like to swap back and forth if possible.

What are my options? I no longer have any backups of any stock roms (I do have a 4.2 TW ROM backed up that had NO issues. I believe it was deodexed as well, if that has to do with anything).

The data drops are because you have the MDB modem. If you want to run those 4.3 based ROMs, you need either the hybrid MK2 modem (reversible, knox-free) or the full MK2 modem (not currently reversible, installs knox). The same situation would exist with the MDL modem.

See this thread for instructions to install the hybrid modem: http://forum.xda-developers.com/show....php?t=2546024

I don't know, but I'd guess the situation will be similar with the new KitKat release. To run the new ROMs properly, you'll probably need the newest modem (either a hybrid or full). I'm fairly confident that you'll run into the same issues if you're on MDB, but again, this portion is speculation. MK2 might end up being sufficient, or NB4 might be required. I won't be surprised if a hybrid MDL/NB4 modem pops up soon.

Sent from my SGH-M919 using Tapatalk
Last edited by crawler9; 12th March 2014 at 01:56 AM.
The Following User Says Thank You to crawler9 For This Useful Post: [ View ]
12th March 2014, 01:32 AM   |  #3  
RazoE's Avatar
OP Senior Member
Thanks Meter: 50
 
451 posts
Join Date:Joined: Aug 2011
Donate to Me
More
Thank you, exactly the info I was looking for.
The Following User Says Thank You to RazoE For This Useful Post: [ View ]
12th March 2014, 04:30 PM   |  #4  
RazoE's Avatar
OP Senior Member
Thanks Meter: 50
 
451 posts
Join Date:Joined: Aug 2011
Donate to Me
More
Quote:
Originally Posted by crawler9

The data drops are because you have the MDB modem. If you want to run those 4.3 based ROMs, you need either the hybrid MK2 modem (reversible, knox-free) or the full MK2 modem (not currently reversible, installs knox). The same situation would exist with the MDL modem.

See this thread for instructions to install the hybrid modem: http://forum.xda-developers.com/show....php?t=2546024

I don't know, but I'd guess the situation will be similar with the new KitKat release. To run the new ROMs properly, you'll probably need the newest modem (either a hybrid or full). I'm fairly confident that you'll run into the same issues if you're on MDB, but again, this portion is speculation. MK2 might end up being sufficient, or NB4 might be required. I won't be surprised if a hybrid MDL/NB4 modem pops up soon.

Sent from my SGH-M919 using Tapatalk

Just to be sure, I can run this via ODIN, since it's not MK2, it's MD, right?

http://forum.xda-developers.com/show....php?t=2678774
12th March 2014, 04:59 PM   |  #5  
crawler9's Avatar
Senior Member
Flag Ohio
Thanks Meter: 290
 
687 posts
Join Date:Joined: Mar 2010
Donate to Me
More
Quote:
Originally Posted by RazoE

Just to be sure, I can run this via ODIN, since it's not MK2, it's MD, right?

http://forum.xda-developers.com/show....php?t=2678774

I think so, but I'm not 100% sure. It looks like the same deal as the hybrid I've been using, and that I linked in my first response in this thread, just with the NB4 GSM modem and the MDL bootloader instead of the MK2 modem and MDL bootloader.

I never want to be among the first to flash new radios though. I hold off until I see a LOT of success stories and a lot of devs recommending them.

Sent from my SGH-M919 using Tapatalk
The Following User Says Thank You to crawler9 For This Useful Post: [ View ]
12th March 2014, 05:14 PM   |  #6  
RazoE's Avatar
OP Senior Member
Thanks Meter: 50
 
451 posts
Join Date:Joined: Aug 2011
Donate to Me
More
Yeah, it's also the reason I never flash OTAs, and am on such an ancient baseband. Thanks again!
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes