Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,728,117 Members 47,270 Now Online
XDA Developers Android and Mobile Development Forum

After 4.3 update camera shutter sound gone?

Tip us?
 
code101
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 11
Join Date: Dec 2010
Default After 4.3 update camera shutter sound gone?

Hi all,

This may be a totally noob question and feel free to delete the thread if it's been answered before but here goes. I updated my S3 via Kies to the 4.3 update and all went well and seemed to be working ok. However the camera now has no shutter sounds. I know having it silenced is a good option but sometimes hearing it helps. I've tried changing volumes, rebooting, everything. The only answer I get from Samsung is to factory rest the phone. Would that help? Is there another way? Any help would be greatly appreciated.
 
flynhawn2002
Old
#2  
Senior Member
Thanks Meter 37
Posts: 105
Join Date: Feb 2012
Please check your camera settings?
 
bilgerryan
Old
#3  
bilgerryan's Avatar
Recognized Developer
Thanks Meter 24196
Posts: 14,294
Join Date: Oct 2011
Location: Garrett, IN

 
DONATE TO ME
A factory reset probably won't fix it

 
code101
Old
#4  
Junior Member - OP
Thanks Meter 0
Posts: 11
Join Date: Dec 2010
Thanks for the replies. I checked all the settings and volumes and they all seem fine. Looks like it's time to root.
 
g_money
Old
#5  
g_money's Avatar
Senior Member
Thanks Meter 235
Posts: 334
Join Date: Mar 2013
Quote:
Originally Posted by code101 View Post
Thanks for the replies. I checked all the settings and volumes and they all seem fine. Looks like it's time to root.
Don't want to be a dork, but ur sure it's not in settings?



Sent from my SPH-L710 using Xparent Cyan Tapatalk 2


I'm just saying....
g_money

PROUD owner of a Sprint Galaxy sIII
(My wife thinks her Note2 is better.
She gets no root access until she apologizes...)
 
code101
Old
#6  
Junior Member - OP
Thanks Meter 0
Posts: 11
Join Date: Dec 2010
I checked and theres no option. I don't think the Sprint variant has this option. It would definitely make life a lot easier if it did though. Thanks for the reply.
 
g_money
Old
#7  
g_money's Avatar
Senior Member
Thanks Meter 235
Posts: 334
Join Date: Mar 2013
Found this. Didn't test it myself (I'm running MOAR rom). Might work for you?



Cool - I done this and it works a treat!!

**EDIT: This post refers to a mod which activates an unused menu option to switch off the shutter sound. Other sounds in the camera app will still be present. Thought I'd clarify this in case of any confusion. 

Just in case anyone else wants to do this (I think this would be the 'correct' method of applying this fix as opposed to removing the sound file or muting your phone!), then here is a little guide.

Root access required of course, and I used Root Explorer to do the following:

1. In Root Explorer, navigate to the following location:

/system/csc and look for a file called 'others.xml'.


2. Long-press on this file and select 'Open With', and then select 'Text Editor'.

3. Scroll all of the way to the end and look for the following:

</FeatureSet>
</SamsungMobileFeauture>


4. Insert the following line just before the </FeatureSet> code.



5. Then pressing the 'Back' button will automatically save the file and back-up the original in the folder.

6. Restart your phone.

7. Now when you go into the camera, tap on the settings, so you get camera settings, video settings, and the general settings in a pop-up, press the settings icon/tab and scroll down and you can now select to toggle the sound on/off (second-last option).


Thanks to all above for guiding me to this little fix, it takes no time at all to apply. The camera sound was annoying me a bit and was surprised to see it wasn't a supplied function.

To revert, simply go back to the file you edited, delete it, then remove the '.bak' from the backed-up file.



And all credit to the original Dev. for the code for this mod, at this thread:
http://forum.xda-developers.com/show....php?t=2162906


Sent from my SPH-L710 using Xparent Cyan Tapatalk 2


I'm just saying....
g_money

PROUD owner of a Sprint Galaxy sIII
(My wife thinks her Note2 is better.
She gets no root access until she apologizes...)
 
code101
Old
#8  
Junior Member - OP
Thanks Meter 0
Posts: 11
Join Date: Dec 2010
I'm wondering if flashing a stock 4.3 tar via Odin would fix this?

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes