Default LS-980 "stock" 4.4.2 support? where is it???

The title says it all... and I find this very sad... Why is this the case? I mean, I know there's cloudy's rom but they aren't daily drivers for the LS980 because it just doesn't smoothly transition from antenna to antenna and the "no sim card" error when using LG apps... bleh. I'd love to use a flex rom port or something well customized but there's nothing. If you know a way to get cloudy to work without force closing when walking around on the street... mind helping out?