Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,806,279 Members 53,134 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Camera not working on any ROM, hboot, firmware, or newest RUU WORKS on old RUU

Tip us?
 
thethinkman
Old
#1  
Junior Member - OP
Thanks Meter 1
Posts: 26
Join Date: Aug 2012
Thumbs down [Q] Camera not working on any ROM, hboot, firmware, or newest RUU WORKS on old RUU

Okay I've been working on this for two days with no luck. I was on CM11 to begin with, on a nightly build when I noticed that the camera was no longer working along with some wifi issues and stuff, with occasional reboots.

I "downgraded" to the SNAPSHOT build. No luck, if not worse because now wifi didn't work at all.
Flashed stock T-mobile Sense 5 rom. Everything works except camera.

Used RUU for AT&T 1.44. EVERYTHING WORKS! However, I'm on AT&T 1.44 which is extremely old.
Installed CleanROM 7.0R2. Everything works except camera.
RUU'd to 1.44 again
Installed MIUI ROM from thread. Everything works except camera.

Updated firmware and hboot to 2.18 and retried all of the above steps with same results.
Downgraded hboot to 2.15, repeated above steps.
I am S-OFF and CID 1111111. I obviously relocked bootloader for RUU but unlocked to flash recovery.

Gave up on custom roms entirely and flashed RUU for AT&T 5.18 (android 4.2.2). THE CAMERA DOESN"T WORK ON THIS EITHER. I have tried changing kernels too. Is there something I'm missing or is the ONLY solution to return to the old ICS RUU?
 
thethinkman
Old
(Last edited by thethinkman; 13th March 2014 at 10:09 PM.)
#2  
Junior Member - OP
Thanks Meter 1
Posts: 26
Join Date: Aug 2012
Current information:

*** RELOCKED ***
EVITA PVT SHIP S-OFF RL
CID-111111111
HBOOT-2.18.0000
RADIO-1.35a.32.45.27
OpenDSP-v33.1.0.45.1128
eMMC-boot
Dec 3 2013, 17:10:01:-1

Running stock 5.18 RUU with stock recovery unrooted
 
timmaaa
Old
#3  
timmaaa's Avatar
Recognized Contributor
Thanks Meter 6,221
Posts: 13,128
Join Date: Jun 2011
Location: Melbourne

 
DONATE TO ME
"I obviously relocked bootloader for RUU"

You don't need to relock your bootloader to run an RUU when you're s-off, just thought I'd clear that up. As for your camera issues, I'm really not sure. My fiance has a similar (kinda) issue with her Evita. It won't boot any ROM that includes any variation on the 3.4 kernel, whether it's via a ROM flash or an RUU. Sometimes Bluetooth works, sometimes it doesn't. WiFi never works. There seems to be no rhyme or reason, no logical cause at all. I'm sorry I can't really be of any help, other than to say that for a select few people these things just happen.

Sent from my Evita
OnePlus One | crDroid/AK | TWRP 2.7.1.1

Do not PM me asking for assistance, that's what my Q&A thread is for!
The Following User Says Thank You to timmaaa For This Useful Post: [ Click to Expand ]
 
thethinkman
Old
(Last edited by thethinkman; 14th March 2014 at 04:44 PM.)
#4  
Junior Member - OP
Thanks Meter 1
Posts: 26
Join Date: Aug 2012
Quote:
Originally Posted by timmaaa View Post
"I obviously relocked bootloader for RUU"

You don't need to relock your bootloader to run an RUU when you're s-off, just thought I'd clear that up. As for your camera issues, I'm really not sure. My fiance has a similar (kinda) issue with her Evita. It won't boot any ROM that includes any variation on the 3.4 kernel, whether it's via a ROM flash or an RUU. Sometimes Bluetooth works, sometimes it doesn't. WiFi never works. There seems to be no rhyme or reason, no logical cause at all. I'm sorry I can't really be of any help, other than to say that for a select few people these things just happen.

Sent from my Evita
Ah, interesting, I will forgo that step in the future

Well that's really unfortunate for her and I guess for me too. It is especially frustrating because I was on CM with 4.4 for a long time with no issues with the camera. I guess I'll start exploring different RUUs to flash until I find something that is passable.

If anybody has any ideas on what else I can do to have a better experience with the phone, please let me know.

EDIT:

I'm currently ]trying to get to RUU AT&T 3.18. The RUU is a zip file though, not an exe. So I'm not entirely sure how to run it. It doesn't just flash from fastboot, I heard I can only install OEMs from stock recovery. So I ran the RUU for 1.45. Now I'm on 1.45 and fully stock with stock recovery and everything. How do I install this zip file? Booting to stock recovery just gives me an icon with a triangle that turns red after a while, there are no visible options to flash things, and it isn't connected to adb or fastboot so it doesn't seem like I can push anything through USB while it is in this mode. SO...


EDIT 2

I figured out how to work stock recovery. Disregard last edit. I still am up for a better solution than running old stock roms :\

EDIT 3

I'm going to list RUUs that seem to run the camera properly, and those that don't.

CAMERA WORKING RUUs
1.44 AT&T

NOT WORKING
2.20 AT&T
3.18 AT&T
5.18 AT&T
Cyanogenmod
Sense Roms
MIUI
Any other random ROMS I've tried
I am trying 2.20 now. My goal is to find the exact version where the camera breaks, so then maybe I will be able to pinpoint the feature that is causing the problem

EDIT: It appears that the 1.44 RUU is the only one that has a working camera on.
 
twistedddx
Old
#5  
Senior Member
Thanks Meter 478
Posts: 823
Join Date: Oct 2010
AT&T 3.18 and 5.18 RUU is exe not zip. Did you download the correct file and flash the RUU correctly? It sounds like you have downloaded the wrong file as you mention stock recovery and such which all sounds horribly wrong.
Post the filenames you are flashing.

Also AT&T says you can not skip 2.20 RUU when upgrading from older builds.
Eg 1.44 through to 3.18 requires 2.20 between.

I would try:
Install 2.20 RUU
Test camera
Install 3.18 RUU
Test camera
Install 5.18 RUU
Test Camera
Install custom ROM
Test Camera
The Following User Says Thank You to twistedddx For This Useful Post: [ Click to Expand ]
 
thethinkman
Old
(Last edited by thethinkman; 14th March 2014 at 04:44 PM.)
#6  
Junior Member - OP
Thanks Meter 1
Posts: 26
Join Date: Aug 2012
Quote:
Originally Posted by twistedddx View Post
AT&T 3.18 and 5.18 RUU is exe not zip. Did you download the correct file and flash the RUU correctly? It sounds like you have downloaded the wrong file as you mention stock recovery and such which all sounds horribly wrong.
Post the filenames you are flashing.

Also AT&T says you can not skip 2.20 RUU when upgrading from older builds.
Eg 1.44 through to 3.18 requires 2.20 between.

I would try:
Install 2.20 RUU
Test camera
Install 3.18 RUU
Test camera
Install 5.18 RUU
Test Camera
Install custom ROM
Test Camera
I skipped 2.20 to get to both 3.18 and 5.18 with no problems other than the camera. The RUU flashes you to stock recovery, how is that horribly wrong?

Right now I'm on version 2.2 as we speak, and the camera doesn't work. It only works on 1.44.

http://androidruu.com/?developer=Evita I got most of the RUUs from there. The Cingular 3.18 is definitely a zip file. The 1.45 AT&T is an exe.

Here is a list of filenames of stuff I have tried.

htc_one_x_RUU_2.20.502.7_att_us_08022012.exe
HTC_One_X_RUU_5.18.502.1.exe
RUU_Evita_UL_ATT_US_1.44.502.1_Radio_0.15.3201.09_ release_249105.exe
OTA_EVITA_UL_JB_45_S_Cingular_US_3.18.502.6_0.24p. 32.09.06_10.130.32.34_release_3061616bcty3drvawwo0 1k.zip

They are all AT&T and display the AT&T boot.

I will try exactly as you said and see what happens, starting from 1.44.
 
timmaaa
Old
#7  
timmaaa's Avatar
Recognized Contributor
Thanks Meter 6,221
Posts: 13,128
Join Date: Jun 2011
Location: Melbourne

 
DONATE TO ME
Quote:
Originally Posted by thethinkman View Post
I skipped 2.20 to get to both 3.18 and 5.18 with no problems other than the camera. The RUU flashes you to stock recovery, how is that horribly wrong?

Right now I'm on version 2.2 as we speak, and the camera doesn't work. It only works on 1.44.

http://androidruu.com/?developer=Evita I got most of the RUUs from there. The Cingular 3.18 is definitely a zip file. The 1.45 AT&T is an exe.

Here is a list of filenames of stuff I have tried.

htc_one_x_RUU_2.20.502.7_att_us_08022012.exe
HTC_One_X_RUU_5.18.502.1.exe
RUU_Evita_UL_ATT_US_1.44.502.1_Radio_0.15.3201.09_ release_249105.exe
OTA_EVITA_UL_JB_45_S_Cingular_US_3.18.502.6_0.24p. 32.09.06_10.130.32.34_release_3061616bcty3drvawwo0 1k.zip

They are all AT&T and display the AT&T boot.

I will try exactly as you said and see what happens, starting from 1.44.
I think the point was that you're using the stock recovery to flash whatever zip it was you found. An RUU is never a zip file, it's always an exe, so the 3.18 file you flashed was wrong.

The 3.18 zip file you used is an OTA, it says that in the filename, and that's why it's a zip. You've just downloaded the wrong file from androidruu. The one you should have grabbed is the one with RUU in the filename, and the exe extension (see the bottom most file in attached screenshot).

Sent from my Evita
OnePlus One | crDroid/AK | TWRP 2.7.1.1

Do not PM me asking for assistance, that's what my Q&A thread is for!
The Following User Says Thank You to timmaaa For This Useful Post: [ Click to Expand ]
 
thethinkman
Old
(Last edited by thethinkman; 14th March 2014 at 05:29 PM.)
#8  
Junior Member - OP
Thanks Meter 1
Posts: 26
Join Date: Aug 2012
Quote:
Originally Posted by timmaaa View Post
I think the point was that you're using the stock recovery to flash whatever zip it was you found. An RUU is never a zip file, it's always an exe, so the 3.18 file you flashed was wrong.

The 3.18 zip file you used is an OTA, it says that in the filename, and that's why it's a zip. You've just downloaded the wrong file from androidruu. The one you should have grabbed is the one with RUU in the filename, and the exe extension (see the bottom most file in attached screenshot).

Sent from my Evita
OHHH. Okay, I'm downloading the RUU for 3.18 now. Sorry to both of you for the confusion.

Here's my progress:
Installed 1.44 via RUU. Camera... Working!
 
thethinkman
Old
#9  
Junior Member - OP
Thanks Meter 1
Posts: 26
Join Date: Aug 2012
Quote:
Originally Posted by thethinkman View Post
OHHH. Okay, I'm downloading the RUU for 3.18 now. Sorry to both of you for the confusion.

Here's my progress:
Installed 1.44 via RUU. Camera... Working!

Installed 2.20 via RUU. Camera... NOT working!

I guess continuing the process from there isn't useful =(
 
twistedddx
Old
#10  
Senior Member
Thanks Meter 478
Posts: 823
Join Date: Oct 2010
Quote:
Originally Posted by thethinkman View Post
I guess continuing the process from there isn't useful =(
Yea it would seem there is no hope for your device running updates at this point.
The new versions had updates to the camera and clearly your camera doesnt like them. Lots of "performance" improvements push hardware closer and closer to their limits, your camera no longer can handle being that close to the limit.

Tags
broken, camera, rom, ruu, sense
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes