Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] sdcard mount and unmount issue

OP dicks93277

15th March 2014, 01:31 AM   |  #1  
dicks93277's Avatar
OP Senior Member
Thanks Meter: 11
 
160 posts
Join Date:Joined: Feb 2014
I can't find any quick and noob-friendly resolution to the problem so if you got the easy one please help... thank you

I found that some of my photos were "broken", then I thought the sdcard may be the one that caused this..
after that, I used the unmount button in settings>storage, but it just "stucked" and no unmount , so I just pull the sdcard out from my phone
then backup with acronis true image 2014, then "fully" format the card, test the card with h2testw, restore the data with acronis true image 2014,
and checked my restored files on computer, hmm... is ok now, but when I replugged the card to my phone, my phone just can't read or write any file/folder on that card...
tried with other sdcard..I found that the phone shows the information for the sd card is the one before I unplugged it...

pls help me!! please...
I don't want to wipe my phone...
Last edited by dicks93277; 15th March 2014 at 01:39 AM. Reason: additional describing my problem
15th March 2014, 04:09 AM   |  #2  
MgudFrn's Avatar
Member
Flag Kathmandu
Thanks Meter: 9
 
69 posts
Join Date:Joined: Oct 2013
Donate to Me
Quote:
Originally Posted by dicks93277

I can't find any quick and noob-friendly resolution to the problem so if you got the easy one please help... thank you

I found that some of my photos were "broken", then I thought the sdcard may be the one that caused this..
after that, I used the unmount button in settings>storage, but it just "stucked" and no unmount , so I just pull the sdcard out from my phone
then backup with acronis true image 2014, then "fully" format the card, test the card with h2testw, restore the data with acronis true image 2014,
and checked my restored files on computer, hmm... is ok now, but when I replugged the card to my phone, my phone just can't read or write any file/folder on that card...
tried with other sdcard..I found that the phone shows the information for the sd card is the one before I unplugged it...

pls help me!! please...
I don't want to wipe my phone...

I'm not sure it will help or not but you can give it a try coz I fixed the same issue with my phone before:
First remove you battery and let it be like this until you connect your sdcard to the pc. Then open command prompt and type this:
chkdsk /f G:
Here replace G: with the drive with your sdcard.
After this try to mount your sdcard back to your phone.
15th March 2014, 09:21 AM   |  #3  
dicks93277's Avatar
OP Senior Member
Thanks Meter: 11
 
160 posts
Join Date:Joined: Feb 2014
Oh...I see.
Thanks for reply...
I will try later...
Btw my sdcard is readable now
But the missing photo still not fixed I think I will wait til I pass my middle exam

Sent from my HTC_Desire_200 using XDA Premium 4 mobile app
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes