Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,742,143 Members 51,897 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Strange boot loop problem

Tip us?
 
Xperia_Play
Old
#1  
Junior Member - OP
Thanks Meter 3
Posts: 24
Join Date: Oct 2012
Default [Q] Strange boot loop problem

So, yesterday my phone kept turning itself off for no apparent reason and then it would start vibrating constantly. I would take the battery out and restart the phone as normal and it would work. Later on, it shut off completely and did the same thing it had done for most of the day so I tried restarting it again like I had been doing. However, this time it would load the loading screen and get no further than it saying the model number before it turned off again and started vibrating. Before this time the phone would at least stay on for 10-15 minutes. I kept trying what I had been doing all day with no luck of it getting any further than the loading screen. If I put the battery in, it would immediately start up and then turn itself off and start vibrating again which it shouldn't do because I'd need to turn the phone on for it to load up. I looked up what the problem might be and people were saying to reboot the phone. I managed to get the recovery screen up for about 3 seconds before it turned off and started vibrating with a black screen again. Now the phone doesn't boot up/turn on at all if the battery is in. However if the battery is out and the phone is plugged into charge, then it would start up with the same problem as earlier. I would like to get to recovery to be able to either hard reset or flash a new rom, however, the phone will not boot into recovery, instead it will just turn it'self off again. The phone is not in usb debugging mode so I am unable to flash the phone via a third party software. Any help would be much appreciated as the phone is currently completely unusable.

Thank you.
 
Androidoo
Old
#2  
Androidoo's Avatar
Senior Member
Thanks Meter 48
Posts: 260
Join Date: Aug 2013
Location: indore
check your power button ,it might be damaged...!!
PHONE-GALAXY ACE PLUS
rom -CM 10 PURE GALAXY 1.0
CPU Governor= ONDEMAND
I/O Scheduler=DEADLINE
 
Xperia_Play
Old
#3  
Junior Member - OP
Thanks Meter 3
Posts: 24
Join Date: Oct 2012
No it's definitely not that because I could use it for get into recovery (even though it was for just a second, not long enough to be able to do anything). I have no idea what the problem could be.
 
ShadowsDie
Old
#4  
ShadowsDie's Avatar
Senior Member
Thanks Meter 137
Posts: 488
Join Date: May 2013
Location: Galati
Quote:
Originally Posted by Xperia_Play View Post
No it's definitely not that because I could use it for get into recovery (even though it was for just a second, not long enough to be able to do anything). I have no idea what the problem could be.
that is the idea, if the power button is blocked you can enter recovery just for a sex then it reboots,
when you put the battery on it turns on?
 
Xperia_Play
Old
#5  
Junior Member - OP
Thanks Meter 3
Posts: 24
Join Date: Oct 2012
Yes, it used to turn on straight away when the battery was inserted but this isn't happening now. Probably time for a new phone.
 
ShadowsDie
Old
#6  
ShadowsDie's Avatar
Senior Member
Thanks Meter 137
Posts: 488
Join Date: May 2013
Location: Galati
Quote:
Originally Posted by Xperia_Play View Post
Yes, it used to turn on straight away when the battery was inserted but this isn't happening now. Probably time for a new phone.
if it isnt happening now its because you have no more battery left
you can fix it to a service, its not so expensive
 
Sepsis12
Old
#7  
Junior Member
Thanks Meter 0
Posts: 8
Join Date: Mar 2014
Quote:
Originally Posted by ShadowsDie View Post
if it isnt happening now its because you have no more battery left
you can fix it to a service, its not so expensive
I have the same problem right now after a failed flash. So I would suppose it is not a stuck power button... I can't even get to recovery by the way....
 
ShadowsDie
Old
#8  
ShadowsDie's Avatar
Senior Member
Thanks Meter 137
Posts: 488
Join Date: May 2013
Location: Galati
Quote:
Originally Posted by Sepsis12 View Post
I have the same problem right now after a failed flash. So I would suppose it is not a stuck power button... I can't even get to recovery by the way....
can you get to download mode?
 
Sepsis12
Old
#9  
Junior Member
Thanks Meter 0
Posts: 8
Join Date: Mar 2014
Quote:
Originally Posted by ShadowsDie View Post
can you get to download mode?
I could get to download mode (for about 6 seconds)

After a lot of trying I suppose it must be the power button, as you suggested. I even succeded in installing a stock rom (by pressing the power button in the download mode every seconds or two)...

Seems strange though. I suppose pressing the power button to get into the download and recovery mode gets it stuck....

Thanks for your suggestion though. I will bring the smartphone to a store tomorrow and see if they can get it fixed.

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes