Post Reply

Unhappy [Q] SOS! Internet super slow! (Should I change modems?)

OP ugartina

14th March 2014, 09:24 PM   |  #1  
OP Junior Member
Flag Bayamon/Dorado
Thanks Meter: 1
 
16 posts
Join Date:Joined: Jun 2011
More
Im sorry to be asking this (I've searched the forums and google and can't find anything conclusive)

Background:
I have a service contract with AT&T and I'm currently a customer of them. I used to have the Galaxy S4 (i747), and the usb charging port stopped working. I took it into a repair shop where they messed the whole phone up and had to give me back the phone with a whole new board in it, the only problem with the new board it's a board for i747M. I was having issues with the phone being stuck on edge - so I proceeded to unlock it again (I do not trust the work they did, and even thou I had network with my AT&T SIM Card, I had to make sure it was unlocked), I also restored the old IMEI - and after all this I was able to get out of edge.

The problem:
Even thou the phone reports 4G LTE, the internet is super slow!!
I made a speed test and the speeds are at 256 download // 512 upload - WEIRD!
The new board is for i747M - I already restored the IMEI to the one the original board had, I checked my APN and everything is in order.

(Did I missed anything? other than calling the repair shop and scream at them!)


I was wondering if I flash an i747 modem (MJB to be exact, since I'm on 4.3 with MK5), will the speeds improve, or will I brick the phone?

Any help greatly appreciated, I'm desperate!
14th March 2014, 10:05 PM   |  #2  
Senior Member
Atlanta, GA
Thanks Meter: 74
 
354 posts
Join Date:Joined: Feb 2014
More
Quote:
Originally Posted by ugartina

Im sorry to be asking this (I've searched the forums and google and can't find anything conclusive)

Background:
I have a service contract with AT&T and I'm currently a customer of them. I used to have the Galaxy S4 (i747), and the usb charging port stopped working. I took it into a repair shop where they messed the whole phone up and had to give me back the phone with a whole new board in it, the only problem with the new board it's a board for i747M. I was having issues with the phone being stuck on edge - so I proceeded to unlock it again (I do not trust the work they did, and even thou I had network with my AT&T SIM Card, I had to make sure it was unlocked), I also restored the old IMEI - and after all this I was able to get out of edge.

The problem:
Even thou the phone reports 4G LTE, the internet is super slow!!
I made a speed test and the speeds are at 256 download // 512 upload - WEIRD!
The new board is for i747M - I already restored the IMEI to the one the original board had, I checked my APN and everything is in order.

(Did I missed anything? other than calling the repair shop and scream at them!)

I was wondering if I flash an i747 modem (MJB to be exact, since I'm on 4.3 with MK5), will the speeds improve, or will I brick the phone?

Any help greatly appreciated, I'm desperate!

You are unlikely to brick the phone by flashing the modem alone (although I affirm no guarantees to this effect) unless you try to flash the wrong bootloader and/or ROM. You did not, however, say which ROM your phone is currently on. Is it currently on the I747MVLUEMK5 or I747UCUEMJB? There is always a problem with incompatibility between your modem and ROM respectively which is what you'll have if you flash the MJB model whilst on the MK5 ROM plus, of course, subsequent firmware upgrades may be compromised. Are you sure also it's not an hardware issue you are having and the "repair shop" didn't muck up something on the mother board or install a dud? At this stage, however, I don't see how you have much to lose in trying a different modem. If it doesn't help, you can always go back to the previous one. All discussions about warranty are probably off the table already.
The Following User Says Thank You to Larry2999 For This Useful Post: [ View ]
17th March 2014, 03:24 PM   |  #3  
OP Junior Member
Flag Bayamon/Dorado
Thanks Meter: 1
 
16 posts
Join Date:Joined: Jun 2011
More
Quote:
Originally Posted by Larry2999

You are unlikely to brick the phone by flashing the modem alone (although I affirm no guarantees to this effect) unless you try to flash the wrong bootloader and/or ROM. You did not, however, say which ROM your phone is currently on. Is it currently on the I747MVLUEMK5 or I747UCUEMJB? There is always a problem with incompatibility between your modem and ROM respectively which is what you'll have if you flash the MJB model whilst on the MK5 ROM plus, of course, subsequent firmware upgrades may be compromised. Are you sure also it's not an hardware issue you are having and the "repair shop" didn't muck up something on the mother board or install a dud? At this stage, however, I don't see how you have much to lose in trying a different modem. If it doesn't help, you can always go back to the previous one. All discussions about warranty are probably off the table already.

I'm using S3Rx for i747M (MK5) -- and latest modem for at&t is MJB, but my board it's not AT&T anymore so Im guessing Im not gonna be able to flash the modem

it's too too slow I downloaded the Speedtest.net app and it's reporting: 0.14 Mbps download and 0.10 Mbps upload
Post Reply Subscribe to Thread

Tags
i747, imei, mjb, mk5, modem
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes