PebbleOS 2.2 - Possible Battery Drain ?

99 posts
Thanks Meter: 32
 
By SX86, Member on 6th June 2014, 01:43 PM
Post Reply Subscribe to Thread Email Thread
Good day!

Anybody noticed fast battery draining since the update to 2.2?

First day, I went to bed getting my first 20% "low battery" warning, waking up next morning to a dead battery (watch was completely turned off).
My watch seems to be losing 30% battery a day, for the last 2 days.
I used to lose 10% a day, maybe a bit less...

It may be the watchfaces I have installed, but I haven't made any significant changes since the update.

~SX
 
 
7th June 2014, 06:33 PM |#2  
Junior Member
Thanks Meter: 0
 
More
I think I experience the same thing with the battery drain of the new firmware, go back to 2.1 for now
Last edited by thedeath93; 7th June 2014 at 06:40 PM.
8th June 2014, 08:45 AM |#3  
Junior Member
Thanks Meter: 0
 
More
same here. had 7 days uptime with 2.1 and now 2.5 days with 2.2
8th June 2014, 08:26 PM |#4  
SX86's Avatar
OP Member
Flag QC
Thanks Meter: 32
 
More
I was still loosing 30% a day on 2.2 after a few days, full charge.
Also, my friend with a Steel had the same issue.

I use to get 10 days on 2.1.... hopefully they can fix 2.2 to bring back the extra good battery life.

I went back to 2.1 from PebbleBits.
8th June 2014, 10:07 PM |#5  
Junior Member
Thanks Meter: 0
 
More
Same here, losing 40% in 19 hours. May have to downgrade if updates don't roll out soon enough!
8th June 2014, 11:05 PM |#6  
Senior Member
Thanks Meter: 47
 
More
I have 1d15h uptime and 60% battery left on fw v2.2.
10th June 2014, 11:42 PM |#7  
rogerperk's Avatar
Senior Member
Thanks Meter: 9
 
More
No problems here. I'm getting an easy 5 days and hitting 40%. Had 100% Monday morning. Its 4:43 pm on Tuesday and I'm at 90%. I don't use alot of whistles and bells - just time and notifications. Maybe that's why? New user and probably haven't figured out all it can do yet.

Note: Just checked and my version is 2.0.15.4, for whatever that's worth. I updated just a few days ago though.
Last edited by rogerperk; 10th June 2014 at 11:46 PM.
11th June 2014, 12:42 AM |#8  
SX86's Avatar
OP Member
Flag QC
Thanks Meter: 32
 
More
I've had mine since christmas, and even at that time the battery life wasn't that great, but that changed when we hit 2.1 (I think...).
Maybe I'd have to try and do a factory reset after re-installing 2.2.

What I find strange is that I haven't changed anything, same watchface, same apps.... just a new PebbleOS...
On the same night I had installed it, I was at 30%. Next morning (8h later) the watch was completely dead. Unless I use my Pebble while sleepwalking, I don't know what happened there!
I have quiet hours setup too.
12th June 2014, 09:26 PM |#9  
Senior Member
Thanks Meter: 45
 
Donate to Me
More
same here. had 12 days with my watchface on 2.1 and now 2 days with 2.2

Sent from my Nexus 5 using XDA Premium 4 mobile app
13th June 2014, 10:26 PM |#10  
Junior Member
Flag Pittsburgh
Thanks Meter: 11
 
More
My battery life sucked as well on 2.2 I just reflashed pebblebits 2.1 this morning so I'll see if it really was 2.2 it my imagination.

Sent from my SAMSUNG-SM-G900A using Tapatalk
17th June 2014, 09:40 AM |#11  
Junior Member
Thanks Meter: 0
 
More
I have this too on my kickstarter edition - how do I downgrade to 2.1?

Read More
Post Reply Subscribe to Thread

Tags
2.2, battery, drain, pebble, pebbleos

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes