Solution (temporary) to "sns_eve_sync_wakelock"

20 posts
Thanks Meter: 2
By daro.brussa, Junior Member on 3rd April 2014, 06:35 PM
Post Reply Subscribe to Thread Email Thread
Well, I've benn having this wakelocks keeping my phone fully awake since a little more than a week when I installed AOSPA build 2.
This problem happens even in fresh installs without gapps (I tried it), so the problem is on the OS.
According to a guick google search, this problem was most likely NFC related. But I already had it disabled.

Seeing build 3 didn't fixed it and PA legacy community didn't pay attention, I switched back to CM11 but, to my surprise, the same wakelock was still there and my phone not sleeping.
Since it was a fresh install, I went to settings and disabled NFC. sns_eve_syn_wakelock was gone, but a new wakelock occupied it's place: Nfce:EemWakelock (or something like that, not sure), so I got confirmation that google was right, it was NFC.

So I proceeded to flash this
Problem is fixed. My phone is deep sleeping again.

Of course, it's a TEMPORARY fix, until developers can find out what's wrong with android sources.
Last edited by daro.brussa; 3rd April 2014 at 06:52 PM. Reason: Actual fix, don't delete apks, flash the file in the linked thread
The Following User Says Thank You to daro.brussa For This Useful Post: [ View ]
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes