Android 5.0 Favorite Features, Release November 3rd? – XDA TV

Google Confirms Android 5.0 Lollipop for November 3rd! That and much more … more

Prepare Your Build Machines: Ubuntu 14.10 Utopic Unicorn Now Official

Today is an important day for any and all Linux enthusiasts. One of the … more

Track the Time You Waste on Social Media with Socials Addict

When you use your phone, you often don’t even realize how much time you … more

Document the Story of Your Social Life with 8tory

The different forms of social media are growing every day. It’s hard to imagine a day … more
Post Reply

[Q] Battery Drain 50% in 12 Hours Idle

OP BigbenNZ

17th March 2014, 01:29 AM   |  #1  
OP Junior Member
Flag Kapiti NZ
Thanks Meter: 2
 
14 posts
Join Date:Joined: Nov 2012
Moto G XT1032 high Battery drain

We have 2 phones both with the latest System software, No WiFi and Location setting on, display shuts down with a magnetic case.

Both have the same App's my wife phone has 4 added app's, mine has the same app's plus more.

My wife's phone was draining the battery very fast 50% at idle in 12 hours.

Checking the battery drain was showing System use of 50% and Keep awake of over 12 hours, Plus NO Included Packages Showing.

My phone was OK.

So ended up removing the 4 added App's, Forced Stop on all app's that I did think that where being used, turned off the Location setting and re powered the phone, after some 10 min's the phone was back to normal System use of 4% and now showing Included Packages.

Its still OK after 2 days, so what was going on, have since added the 4 app's and still OK.

The 4 Added app's are 1Weather, ES File Explorer, Alert Me and Tunein Radio all added from Google.
17th March 2014, 02:00 AM   |  #2  
liveroy's Avatar
Senior Member
Flag Stara Zagora
Thanks Meter: 72
 
300 posts
Join Date:Joined: Jun 2007
Donate to Me
More
You had a wake lock from some of these apps most likely.By removing them, you just eliminated it.

In general it seems that some apps that need to wake the device for a brief period and update some data are causing these issues on KitKat due to not being optimized for it yet.
17th March 2014, 04:07 AM   |  #3  
vkk178's Avatar
Senior Member
Flag Bangalore
Thanks Meter: 87
 
579 posts
Join Date:Joined: Feb 2012
More
Try clearing the cache from recovery

Sent from my XT1033 using Tapatalk
17th March 2014, 05:53 AM   |  #4  
OP Junior Member
Flag Kapiti NZ
Thanks Meter: 2
 
14 posts
Join Date:Joined: Nov 2012
Quote:
Originally Posted by liveroy

You had a wake lock from some of these apps most likely.By removing them, you just eliminated it.

In general it seems that some apps that need to wake the device for a brief period and update some data are causing these issues on KitKat due to not being optimized for it yet.

Yes have seen this in some forum

Pity their is no App to checks this on a none rooted phone.

Plus this must be a System fault as NO [Included Packages] Showing or app stuffed it up.

Settings/Battery/Android System, its a list at the bottom with the heading Included Packages
17th March 2014, 09:59 AM   |  #5  
Senior Member
Thanks Meter: 132
 
438 posts
Join Date:Joined: Dec 2011
Quote:
Originally Posted by BigbenNZ

Yes have seen this in some forum

Pity their is no App to checks this on a none rooted phone.

Plus this must be a System fault as NO [Included Packages] Showing or app stuffed it up.

Settings/Battery/Android System, its a list at the bottom with the heading Included Packages

Android OS and Android system will often show as high battery usage, the wakelock in android is held by the app. Android just reports it as android OS or Android system. Its an app that is at fault.
17th March 2014, 01:21 PM   |  #6  
Senior Member
Thanks Meter: 21
 
186 posts
Join Date:Joined: Nov 2013
Does this look like a wakelock issue? Data was off but radio was on. Click image for larger version

Name:	uploadfromtaptalk1395058839607.jpg
Views:	62
Size:	35.0 KB
ID:	2635155

Sent from my One S running Kitkat
17th March 2014, 01:21 PM   |  #7  
liveroy's Avatar
Senior Member
Flag Stara Zagora
Thanks Meter: 72
 
300 posts
Join Date:Joined: Jun 2007
Donate to Me
More
Quote:
Originally Posted by BigbenNZ

Yes have seen this in some forum

Pity their is no App to checks this on a none rooted phone.

Plus this must be a System fault as NO [Included Packages] Showing or app stuffed it up.

Settings/Battery/Android System, its a list at the bottom with the heading Included Packages

Oh well, Android works that way, the app requests data access and the system processes it. In this case the app fails to receive what it requested and requests it again, which fails again.Then it all gets repeated countless times for hours and hours, but the app itself doesn't consume much of a battery, while the OS components responsible for processing the request do consume way more power and that's why it shows android system as the highest power consuming component.

Post Reply Subscribe to Thread

Tags
battery drain
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in Moto G Q&A, Help & Troubleshooting by ThreadRank