Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] SD card not working

OP Hssarth

31st May 2013, 08:28 PM   |  #1  
OP Member
Thanks Meter: 1
 
40 posts
Join Date:Joined: Jul 2010
So, I have a 64gb class 10 card from Patriot in here, which I formatted from the phone when I first got it. Last week, the device kept telling me there was an issue with the card and that it needed to be formatted. Despite rebooting, remounting and checking the contacts, the only thing that seemed to work was to pull the battery.

Today, I had the same issue and went through the same motions. Only now, the phone doesn't seem to think the card is even there. I checked the log in recovery and found multiple lines saying it failed to mount.

I'm not currently able to test the card in another device, or another card in the slot. But until I am in a couple of hours does anyone here have a suggestion?
1st June 2013, 11:51 AM   |  #2  
Junior Member
Thanks Meter: 1
 
7 posts
Join Date:Joined: May 2013
Donate to Me
More
Going to have to do some research on that...
Quote:
Originally Posted by Hssarth

So, I have a 64gb class 10 card from Patriot in here, which I formatted from the phone when I first got it. Last week, the device kept telling me there was an issue with the card and that it needed to be formatted. Despite rebooting, remounting and checking the contacts, the only thing that seemed to work was to pull the battery.

Today, I had the same issue and went through the same motions. Only now, the phone doesn't seem to think the card is even there. I checked the log in recovery and found multiple lines saying it failed to mount.

I'm not currently able to test the card in another device, or another card in the slot. But until I am in a couple of hours does anyone here have a suggestion?

I've read that even the S3 was finicky with different microSD card brands, and it seems to continue in the S4. You may have to try a Samsung brand card or I suggest search around to see which brands people have had the best luck with and go with that. Until then check if your card is ok with a reader or another phone and then if you have to, use the lifetime warranty or exchange at store. I've been using a Lexar brand (also Class 10) for well over two weeks now in my S4 with zero issues, but a couple of weeks is no test.
2nd June 2013, 02:17 AM   |  #3  
Senior Member
Thanks Meter: 36
 
110 posts
Join Date:Joined: Aug 2011
Quote:
Originally Posted by Hssarth

So, I have a 64gb class 10 card from Patriot in here, which I formatted from the phone when I first got it. Last week, the device kept telling me there was an issue with the card and that it needed to be formatted. Despite rebooting, remounting and checking the contacts, the only thing that seemed to work was to pull the battery.

Today, I had the same issue and went through the same motions. Only now, the phone doesn't seem to think the card is even there. I checked the log in recovery and found multiple lines saying it failed to mount.

I'm not currently able to test the card in another device, or another card in the slot. But until I am in a couple of hours does anyone here have a suggestion?

You could try to repair it with a Windows PC. I had a similar issue and the following fixed it for me.

Open a cmd prompt and type

chkdsk /X /F E:

Where E was the drive letter of my SD card when mounted using a card reader. You will need to put the appropriate drive letter there.

If this helps thank "mr_deimos" at http://forum.xda-developers.com/showthread.php?t=367912 That is where I found this info.
3rd June 2013, 07:40 PM   |  #4  
endwhysee.bk's Avatar
Senior Member
Flag Dania beach
Thanks Meter: 25
 
180 posts
Join Date:Joined: Aug 2011
More
I had the problem with the s3 and s4 . I even had to call sandisk and replace it . But at the end it kept doing the same thing . So what I did was put it in my computer and did a full format it toke about two to three to format it but it finally worked. I called samsung I mean I tryed everything. So I talk to a I.t. guy and told me to do that and it work but keep in mind my card was a sandisk 64gb class 10.Hope that help.

O.Nice
3rd June 2013, 10:23 PM   |  #5  
Member
Thanks Meter: 3
 
45 posts
Join Date:Joined: May 2013
How are you formatting the sd?
ex-fat or fat32?
17th March 2014, 05:27 PM   |  #6  
scandiun's Avatar
Senior Member
Thanks Meter: 773
 
1,314 posts
Join Date:Joined: Jul 2010
S4 another SD destroyer? Damaged SD Card
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes