FORUMS

CloudPlayer: DIY HiFi Music Streaming Solution

In our Helpful Guide to Music Streaming Services, we mentioned several different services … more

Optimize Battery Life with This Useful App

Battery life is an important aspect of your smartphone, especially if you use it for more … more

The OnePlus 2 & The Year of Smartphone Compromises

We are very close to entering the last third of 2015, and we have now seen many of … more

OnePlus 2 Teardown, Major Android Vulnerability – XDA TV

The OnePlus 2 has been officially released. That and much more news is … more

Downgraded To 4.2 Build Number 532...Here Is Why.

1,121 posts
Thanks Meter: 184
 
By kanej2006, Senior Member on 17th March 2014, 07:15 AM
Post Reply Subscribe to Thread Email Thread
This is the third or fourth time downgrading. Unfortunately I've encountered bugs, performance issues and force closes in various system applications.

Last night, I tried AGAIN to move forward and update. The latest update was 4.3. Unfortunately 4.4 has not yet been released and even if it was it is likely to come with bugs until an update or two rectifies any issues.

Now, these are some problems/bugs experienced with 4.3:

1 - Camera is now laggy whereas on 4.2 is was silky smooth. Only improvements I see on the latest update is a decrease in both noise/iso sensitivity as well as many other various camera effects.

Focusing takes far longer than before.

2 - Sound Settings keeps force closing in the 4.3 update. I'm not able to access or change the xLoud setting. I've cleared data, cache and even re-flashed. Keeps crashing. Downgrading to 4.2 solved this issue. Sound is LOUDER and xLoud works as it should.

3 - Screen - There is a slight delay when finishing from a call. It takes a few seconds for the proximity sensor to wake the screen to end the call. On 4.2 it is instant.

4 - Performance issue. 4.2 was smooth, fluid and instant. 4.3 feels heavier and not as quick as it previously was.

Therefore, with the above issues, I've had no choice but to downgrade. There were more advantages in 4.2 than in 4.3 which had issues, unfortunately.

I hope these problems are solved in the upcoming 4.4 Kitkat. Could other users share any problems caused by the latest updates? Was the stock 4.2 rom any better?
Last edited by kanej2006; 17th March 2014 at 07:18 AM.
 
 
17th March 2014, 08:27 AM |#2  
Senior Member
Thanks Meter: 23
 
More
Sorry, pal, I am on 4.3 .136 and the only thing I have observed is the laggy proximity sensor, which was fixed after some calibration (search for Hammdog's post). No traces at all of the other problems you mention. Camera shots are far better, and overall performance is excellent. Is it possible that you experience some sort of software incompatibility due to the apps you use?

Sent from my C6833 using XDA Premium 4 mobile app
Last edited by stopa10; 17th March 2014 at 08:58 AM.
17th March 2014, 09:34 AM |#3  
OP Senior Member
Flag Dubai
Thanks Meter: 184
 
More
Quote:
Originally Posted by stopa10

Sorry, pal, I am on 4.3 .136 and the only thing I have observed is the laggy proximity sensor, which was fixed after some calibration (search for Hammdog's post). No traces at all of the other problems you mention. Camera shots are far better, and overall performance is excellent. Is it possible that you experience some sort of software incompatibility due to the apps you use?

Sent from my C6833 using XDA Premium 4 mobile app

Ahh, so the laggy proximity sensor was a problem for others, not only me.

In 4.3 .136, the camera is better as you said but I'm experiencing lag, it's slow and takes 3-5 seconds to focus should the light be poor.

4.2 camera was substantially faster. Any reason why my sound settings keep crashing on 4.3?
17th March 2014, 09:44 AM |#4  
Saikyo_San's Avatar
Member
Thanks Meter: 14
 
More
so it crashes even after a CLEAN re-flash or factory reset?
clean as in no app data restored, just pure stock naked rom
17th March 2014, 10:34 AM |#5  
OP Senior Member
Flag Dubai
Thanks Meter: 184
 
More
Quote:
Originally Posted by Saikyo_San

so it crashes even after a CLEAN re-flash or factory reset?
clean as in no app data restored, just pure stock naked rom

Yes. The ONLY thing crashing is when attempting to open the sound settings and enable the xLoud option. Force closes even after flashing, factory reset, etc.
17th March 2014, 02:05 PM |#6  
Saikyo_San's Avatar
Member
Thanks Meter: 14
 
More
my humble opinion is that in the same situation i'd either stay on 4.2 or just root, get recovery and flash a stock based custom ROM or some AOKP, PA goodness or maybe GPe ROM

i have not encountered this issue before nor have I heard of it
18th March 2014, 06:23 AM |#7  
OP Senior Member
Flag Dubai
Thanks Meter: 184
 
More
Quote:
Originally Posted by Saikyo_San

my humble opinion is that in the same situation i'd either stay on 4.2 or just root, get recovery and flash a stock based custom ROM or some AOKP, PA goodness or maybe GPe ROM

i have not encountered this issue before nor have I heard of it

GPe Rom sound like a nice idea.

However, I'm thinking to patiently wait for the highly anticipated KitKat to be officially released.

That said, staying on the current 532 Android 4.2 will make rooting easier before upgrading to 4.4.
18th March 2014, 07:53 AM |#8  
iBuzman's Avatar
Senior Member
Flag Melbourne
Thanks Meter: 660
 
More
No issues (incl proximity sensor or cam lag) for me on any 4.3 rom. If we were all having xloud fc there would be many threads about it - so it's not a Sony 4.3 issue, it's a @kanej2006 issue (not having a go at you, just saying your problems can't be automatically assumed to be problems for all and therefore flaws in 4.3)

Sent from my C6833 using Tapatalk
18th March 2014, 08:52 AM |#9  
OP Senior Member
Flag Dubai
Thanks Meter: 184
 
More
Quote:
Originally Posted by iBuzman

No issues (incl proximity sensor or cam lag) for me on any 4.3 rom. If we were all having xloud fc there would be many threads about it - so it's not a Sony 4.3 issue, it's a @kanej2006 issue (not having a go at you, just saying your problems can't be automatically assumed to be problems for all and therefore flaws in 4.3)

Sent from my C6833 using Tapatalk

Very strange as I only had these problems when upgrading to 4.3. Hopefully, these issues will be resolved in the future when upgrading to Kitkat.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes