Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,737,406 Members 42,032 Now Online
XDA Developers Android and Mobile Development Forum

[DEV/DEBUG/OFF-TOPIC/COMPLAINTS] CM11 debug thread for Falcon

Tip us?
 
matmutant
Old
(Last edited by matmutant; 29th April 2014 at 03:05 PM.)
#1  
matmutant's Avatar
Recognized Contributor - OP
Thanks Meter 3372
Posts: 2,742
Join Date: Mar 2011
Location: ~/
Default [DEV/DEBUG/OFF-TOPIC/COMPLAINTS] CM11 debug thread for Falcon

CM11 debug thread for Falcon
This thread is related to CM11 by @dhacker29

for debugging purpose, i need this only thread to centralize the data
==> Report bugs (documented) i'll sort them by relevance (importance : low [L]; medium [M]; high [H]) and follow them to @dhacker29.
Ok, we know there will still some complainers, but please complain here and not in CM thread

Before Asking anything here, please refer to RC-FAQ & CM11 FAQ by @pinguijxy
refer to this post for general commands
to improve CM11 for Falcon, you could :
  • post results after following protocols,
  • help me to set up test new protocols,
  • give advices about them
  • suggest things to investigate IF you can prove it worths to
How To Report?
give at least :
  • model : XT103* ?
  • rom build : cm-11-yyyymmdd-NIGHTLY-falcon ?
  • kernel build :
  • logcat?
  • way to reproduce ? (ok this is the best, but not always easy, or even possible to do)
The Following 17 Users Say Thank You to matmutant For This Useful Post: [ Click to Expand ]
 
matmutant
Old
(Last edited by matmutant; 2nd July 2014 at 10:10 PM.)
#2  
matmutant's Avatar
Recognized Contributor - OP
Thanks Meter 3372
Posts: 2,742
Join Date: Mar 2011
Location: ~/
Default Known Bugs

Known and already reported:
  • OTG Mode does not charge [M]
  • LINE doesn't work in free call mode [M]
  • Hardware KB doesn't have layout settings in "language&input" [M]
  • CM file manager crashes [M] [click for more]
  • GPS NO tracking at all issue [M] [click for more]
  • In-Game freeze and Force-close [H] [click for more] (CM11-20140621~20140702 Nightlies)]
  • Audio freeze and lags [H] [surely linked to above issue - click for more]
  • Quiet Hours and Blacklist issue with XT1033 [M] [more info]
  • ATT Straight talk issue [H][more info; and more info; even more info]

Solved (kept for achive):
  • The flip case turns the screen on when opened, but not off when closed. (fixed since CM11-20140317-NIGHTLY)
  • Incall volume cannot be tuned [H] [click for more](fixed since cm-11-20140402-NIGHTLY)
  • Boot animation is lagging. [L] (fixed since cm11-20140611-NIGHTLY)
  • CPU minMAX stuck @1190MHz by default [H] (solved but frequency display is still somewhat broken)
The Following 4 Users Say Thank You to matmutant For This Useful Post: [ Click to Expand ]
 
matmutant
Old
(Last edited by matmutant; 27th June 2014 at 08:48 AM.)
#3  
matmutant's Avatar
Recognized Contributor - OP
Thanks Meter 3372
Posts: 2,742
Join Date: Mar 2011
Location: ~/
Default Pending bugs

Pending bugs: (lack of data)
The Following 3 Users Say Thank You to matmutant For This Useful Post: [ Click to Expand ]
 
matmutant
Old
(Last edited by matmutant; 26th June 2014 at 07:48 AM.)
#4  
matmutant's Avatar
Recognized Contributor - OP
Thanks Meter 3372
Posts: 2,742
Join Date: Mar 2011
Location: ~/
Default irrelevant bugs

irrelevant: (kept for archive)
  • I have a bug. [H]
  • Applying Wallpaper issue with trebuchet [L] [click for more] ==> Trebuchet related issues are no more tracked here (or it will clutter OP with numerous entries!
 
myabc
Old
#5  
Senior Member
Thanks Meter 25
Posts: 343
Join Date: Jan 2006
in call receiving or outgoing the interlocutor listen echo of its own voice. this is very strong bug that keep this rom not good for using phone !
The Following User Says Thank You to myabc For This Useful Post: [ Click to Expand ]
 
matmutant
Old
(Last edited by matmutant; 21st March 2014 at 02:09 PM.)
#6  
matmutant's Avatar
Recognized Contributor - OP
Thanks Meter 3372
Posts: 2,742
Join Date: Mar 2011
Location: ~/
Default more info about the "ram bug"

first there is that story of "lost RAM" :
Code:
Select Code
su
dumpsys meminfo
contrary to what i've been told, the "lost RAM" isn't increasing with time going on :
a few minutes ago i had more than 115MB of Lost RAM, and now it is 74209kB (74MB)
so... lost RAM can be somewhat turned into Free RAM ?

Note that i use CM11-2140317 on top of PinkKernel-exp-20140317, and greenify is installed.

Just to show it can actually decrease : see uptime as a piece of evidence ==> one time and a minute later


http://forum.xda-developers.com/show...8&postcount=33
http://forum.xda-developers.com/show...8&postcount=49
http://forum.xda-developers.com/show...0&postcount=57


we need more data
Moto G running Android 4.4.2 KK CM11 /!\ twitter ~ Blog : Andrux&me /!\
Bug Hunter for : Render Kernel, and AcDisplay
supported devices:
 

Motorola : Moto G (falcon)
RC-FAQ ; CM11 DeBug Thread

Xperia: X10mini (robyn); X10miniPRO (mimmi); X8/W8 (shakira)
MiniCM10: MiniFAQ
MiniCM9: MiniFAQ
MiniCM7: MiniFAQ
i don't have power of ubiquity : if you want me to answer, please quote me or mention me using "@matmutant" in the post
 
matmutant
Old
(Last edited by matmutant; 18th March 2014 at 10:07 AM.)
#7  
matmutant's Avatar
Recognized Contributor - OP
Thanks Meter 3372
Posts: 2,742
Join Date: Mar 2011
Location: ~/
Quote:
Originally Posted by myabc View Post
in call receiving or outgoing the interlocutor listen echo of its own voice. this is very strong bug that keep this rom not good for using phone !
ok ... i have an idea about this one, the top_of_device microphone is really near the speaker

hypothesis : top_of_device microphone catch both user voice and interlocutor's one and then send them to device creating the echo for interlocutor.
==> potential fix : disabling that microphone during call and only keep the other one.
Moto G running Android 4.4.2 KK CM11 /!\ twitter ~ Blog : Andrux&me /!\
Bug Hunter for : Render Kernel, and AcDisplay
supported devices:
 

Motorola : Moto G (falcon)
RC-FAQ ; CM11 DeBug Thread

Xperia: X10mini (robyn); X10miniPRO (mimmi); X8/W8 (shakira)
MiniCM10: MiniFAQ
MiniCM9: MiniFAQ
MiniCM7: MiniFAQ
i don't have power of ubiquity : if you want me to answer, please quote me or mention me using "@matmutant" in the post
 
matmutant
Old
(Last edited by matmutant; 18th March 2014 at 10:29 AM.)
#8  
matmutant's Avatar
Recognized Contributor - OP
Thanks Meter 3372
Posts: 2,742
Join Date: Mar 2011
Location: ~/
Default Screen turns off during call

bug: Screen randomly turns off after the action of emitting call (confirmed to exist on any nighlty with stock or pinkkernel)

workaround: force reboot or wait for interlocutor to end call.

potential fix: [?]

Would need more data from other users to confirm this bug on more devices.
Moto G running Android 4.4.2 KK CM11 /!\ twitter ~ Blog : Andrux&me /!\
Bug Hunter for : Render Kernel, and AcDisplay
supported devices:
 

Motorola : Moto G (falcon)
RC-FAQ ; CM11 DeBug Thread

Xperia: X10mini (robyn); X10miniPRO (mimmi); X8/W8 (shakira)
MiniCM10: MiniFAQ
MiniCM9: MiniFAQ
MiniCM7: MiniFAQ
i don't have power of ubiquity : if you want me to answer, please quote me or mention me using "@matmutant" in the post
 
ph4zrd
Old
(Last edited by ph4zrd; 18th March 2014 at 01:09 PM.)
#9  
Member
Thanks Meter 87
Posts: 72
Join Date: Nov 2012
Location: Dresden, Saxony
Quote:
Originally Posted by matmutant View Post
first there is that story of "lost RAM" :
Code:
Select Code
su
dumpsys meminfo
contrary to what i've been told, the "lost RAM" isn't increasing with time going on :
a few minutes ago i had more than 115MB of Lost RAM, and now it is 74209kB (74MB)
so... lost RAM can be somewhat turned into Free RAM ?

Note that i use CM11-2140317 on top of PinkKernel-exp-20140317, and greenify is installed.

we need more data
For me the "Lost RAM" increased constantly since I rebooted yesterday. It was around 400,0 MB 10 minutes ago. I then tried to kill surfaceflinger: "Lost RAM" was at ~318 MB for a short time and began increasing again, now it's around 360 MB.

CM 20140317, CM default kernel, Dalvik btw...

Edit: It's a XT1032.
Tried killing one system process after another. "Lost RAM" value did not decrease. Induced soft reboots took very long. Any idea what I can try or which data could help locating the problem?

Edit 2: Phone slow as f*** now. Soft-rebooting itself, resetting the wallpaper, randomly killing apps, etc. Need to wait >30sec for it to open terminal emulator. I have a theory that the CM stock browser is somewhat involved cause after using it for ~10 min, my "Lost RAM" stat has risen by around 80 MB.
 
SWTR
Old
#10  
SWTR's Avatar
Senior Member
Thanks Meter 136
Posts: 489
Join Date: Jan 2012
Location: Cham
The recorded speak message in whatsapp sounds terrible.

The Following User Says Thank You to SWTR For This Useful Post: [ Click to Expand ]
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes