Gmail 5.0: Material Design and Multiple Account Support

Google started to materialize many of its applications right after announcing the … more

Some of Our Favorite Features in Android 5.0 Lollipop

Android 5.0 Lollipop is the latest major revision to Google’s mobile operating … more

Sony SmartEyeglass SDK Developer Preview Released

A little over a month ago in Tokyo, Japan, Sony unveiled its new SmartEyeglasstechnology. … more

XDA and Leaseweb: Server Trial/Moto 360 Contest (Winners!)

About a month ago, we held a contest along with XDA’s host, Leaseweb, to … more
Post Reply

BetterBatteryStats says my wifi is running 100% of the time?

OP RCizzle65

10th October 2013, 05:28 PM   |  #1  
OP Member
Thanks Meter: 0
 
50 posts
Join Date:Joined: Sep 2012
The ROM I'm on is ParanoidAndroid 3.99-RC2 on an AT&T Galaxy S3. I've been having battery problems for awhile on this phone, but after upgrading to this, it has just gotten much worse. I take a look at BetterBatteryStats and it says my wifi is running all the time. I don't have wifi on most of the time, and I've reset the phone and it is still occurring.
29th November 2013, 12:57 AM   |  #2  
Senior Member
Thanks Meter: 8
 
334 posts
Join Date:Joined: Jan 2007
Quote:
Originally Posted by RCizzle65

The ROM I'm on is ParanoidAndroid 3.99-RC2 on an AT&T Galaxy S3. I've been having battery problems for awhile on this phone, but after upgrading to this, it has just gotten much worse. I take a look at BetterBatteryStats and it says my wifi is running all the time. I don't have wifi on most of the time, and I've reset the phone and it is still occurring.

I'm on task650's most recent 4.3 ROM and I got the same issue. Its draining 10% batt every hour. Killing me. Reinstalling the ROM or resetting did not help. It has in the past but not this time.
2nd April 2014, 07:30 AM   |  #3  
Senior Member
Thanks Meter: 57
 
217 posts
Join Date:Joined: Jul 2008
Quote:
Originally Posted by eatkabab

I'm on task650's most recent 4.3 ROM and I got the same issue. Its draining 10% batt every hour. Killing me. Reinstalling the ROM or resetting did not help. It has in the past but not this time.

I saw this post:
http://forum.xda-developers.com/show...php?p=51574320

i am trying it now to see if it really works. I Also have wifi running 100%
2nd April 2014, 11:46 PM   |  #4  
Senior Member
Thanks Meter: 53
 
257 posts
Join Date:Joined: Jul 2007
More
Quote:
Originally Posted by RCizzle65

The ROM I'm on is ParanoidAndroid 3.99-RC2 on an AT&T Galaxy S3. I've been having battery problems for awhile on this phone, but after upgrading to this, it has just gotten much worse. I take a look at BetterBatteryStats and it says my wifi is running all the time. I don't have wifi on most of the time, and I've reset the phone and it is still occurring.

Is it the wlan_rx_wake stat? This came up on mine last week and I found a solution.
3rd April 2014, 01:01 AM   |  #5  
OP Member
Thanks Meter: 0
 
50 posts
Join Date:Joined: Sep 2012
Quote:
Originally Posted by pc103

Is it the wlan_rx_wake stat? This came up on mine last week and I found a solution.

What was your solution?
3rd April 2014, 02:01 AM   |  #6  
Senior Member
Thanks Meter: 53
 
257 posts
Join Date:Joined: Jul 2007
More
wlan_rx_wake solution
Quote:
Originally Posted by RCizzle65

What was your solution?

For wlan_rx_wake, the research was saying this error is triggered by settings and/or background activity on 1 or more particular wlans you connect on (not by anything on your phone). Different posters saw it draining their battery on their school, work or home wifi networks accordingly.

I took 2 approaches: Since it was my home network, I disabled the UPnP service on my main router. I also separately configured a static IP (one that is outside the range of automatic addresses) on my phone for the home wifi connection using the "Modify network config" command available by long pressing an SSID in the list on Wifi settings. It worked. 1.4% / hour overnight drain is restored. (It had risen to 4%).

Both approaches isolate the phone from some types of network broadcast activity that triggers excessive wake time.
The Following User Says Thank You to pc103 For This Useful Post: [ View ]
15th May 2014, 07:43 PM   |  #7  
Aiden88's Avatar
Member
Thanks Meter: 19
 
87 posts
Join Date:Joined: May 2008
More
For me, seems working this operation
Go to WiFi settings-> Advanced-> Uncheck "Scanning always available"

Credits to @phanitej for this post

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes