Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,806,934 Members 37,609 Now Online
XDA Developers Android and Mobile Development Forum

[Q] CAMERA crash!

Tip us?
 
obaid_rock
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 10
Join Date: Mar 2012
Default [Q] CAMERA crash!

ok so i bought Galaxy S4 i9500.. like a week ago.. then i updated my firmware using keis like 2 days ago.. n now my camera crashes.. when not used after a very long time. im not sure is it either the samsung fault or android fault.. my current version is 4.2.2. if u need anymore details.. i will love to provide them!!
 
cameracartwright
Old
#2  
Senior Member
Thanks Meter 32
Posts: 231
Join Date: Dec 2012
Quote:
Originally Posted by obaid_rock View Post
ok so i bought Galaxy S4 i9500.. like a week ago.. then i updated my firmware using keis like 2 days ago.. n now my camera crashes.. when not used after a very long time. im not sure is it either the samsung fault or android fault.. my current version is 4.2.2. if u need anymore details.. i will love to provide them!!
Does it say "warning;camera failed" ? And are you loading the camera from the lock screen or home screen?
x102x96x Old
#3  
Guest
Thanks Meter 0
Posts: n/a
Quote:
Originally Posted by obaid_rock View Post
ok so i bought Galaxy S4 i9500.. like a week ago.. then i updated my firmware using keis like 2 days ago.. n now my camera crashes.. when not used after a very long time. im not sure is it either the samsung fault or android fault.. my current version is 4.2.2. if u need anymore details.. i will love to provide them!!
the easiest way is to flash another firmware (Stock*) by Odin
download anther firmware from sammobile.com
ur setting and data will remain but problem will fix
 
gili1234
Old
#4  
Junior Member
Thanks Meter 0
Posts: 1
Join Date: May 2013
Default I bought a new samsung galaxy 4s and the camera failed

Quote:
Originally Posted by obaid_rock View Post
ok so i bought Galaxy S4 i9500.. like a week ago.. then i updated my firmware using keis like 2 days ago.. n now my camera crashes.. when not used after a very long time. im not sure is it either the samsung fault or android fault.. my current version is 4.2.2. if u need anymore details.. i will love to provide them!!
I had the same problem with my new Galaxy S4 that I bought on 8 of may in 2013.
In the beginning, the camera work fine, but after several minutes, on each time that I tried to open the camera aplication it had black screen with an error message.
I tried to exit the battery and return it, it didn't help.
I tried to rebot to manufacturer settings, at the first couple of minutes the camera work fine, but later the black screen appear again at each time I open the camera application.
Here is a link to youtube that show the same problem that I had :

Search on youtube "samsung galaxy s4 camera fail"

What can I do ?
 
kenshi1023
Old
#5  
Member
Thanks Meter 6
Posts: 56
Join Date: Feb 2012
I am having the same problem with my s4; tried system update, factory reset... maybe i need to try to flash my firmware. so disappointed with Samsung. a flagship phone shouldn't have this problem!
to be safe, getting it exchanged... i never bought insurance before but it looks like i might need to if i am sticking with the s4.
 
runedrune
Old
#6  
runedrune's Avatar
Senior Member
Thanks Meter 2,296
Posts: 4,509
Join Date: Nov 2010
Location: Lahore
It's a known problem. Loads of people have it. You'll just have to wait for Samsung to fix it.
[Device] Google Nexus 5 [Memory] 32GB [Rom] ParanoidAndroid [Kernel] Stock [Modem] 1.0.25.0.23 [Launcher] Stock [Theme] Stock [Font] Stock

[Device] Google Nexus 7 2nd Gen [Memory] 32GB [Rom] Stock KitKat [Kernel] Stock [Launcher] Stock [Theme] Stock [Font] Stock

Sony Ericsson W810i -> Samsung Galaxy S i9000 -> Samsung Galaxy S2 i9100 -> Samsung Galaxy S4 i9500 -> Google Nexus 5

Nexus 7 -> Nexus 7 2nd Gen

My Apps: Konvertr
 
cameracartwright
Old
#7  
Senior Member
Thanks Meter 32
Posts: 231
Join Date: Dec 2012
Quote:
Originally Posted by gili1234 View Post
I had the same problem with my new Galaxy S4 that I bought on 8 of may in 2013.
In the beginning, the camera work fine, but after several minutes, on each time that I tried to open the camera aplication it had black screen with an error message.
I tried to exit the battery and return it, it didn't help.
I tried to rebot to manufacturer settings, at the first couple of minutes the camera work fine, but later the black screen appear again at each time I open the camera application.
Here is a link to youtube that show the same problem that I had :

Search on youtube "samsung galaxy s4 camera fail"

What can I do ?

From today speaking to a guy who repairs samsungs this is a hardware issue. Reboots and factory resets seem to fix the issue but the root of the problem is the the camera module either not correctly attached/or soldered to the connection so when rebooting or resetting the phone the movement of the device in your hand or laying the phone face up briefly re-connects the module to the device. I'm awaiting my new device as my carrier told me a few people have had this issue also.

Hope that helps
 
obaid_rock
Old
#8  
Junior Member - OP
Thanks Meter 0
Posts: 10
Join Date: Mar 2012
Quote:
Originally Posted by cameracartwright View Post
Does it say "warning;camera failed" ? And are you loading the camera from the lock screen or home screen?
no it dosent.. it just crashes.. with a black screen!
 
WitchMX
Old
#9  
WitchMX's Avatar
Senior Member
Thanks Meter 12
Posts: 156
Join Date: Feb 2011
I have taken several pictures with my 2 days old GS4 but in one occasion when I opened the camera and switched from the front camera to the main, the phone froze and reboot it self :/

I hope i only was a one time failure and not hardware or software relate.

Cheers


Starting Line Up: Samsung Galaxy S 4, Galaxy Note 10.1
Warming the bench: Galaxy Nexus, Sony Xperia S
 
G-XtremE
Old
(Last edited by G-XtremE; 14th May 2013 at 02:02 PM.)
#10  
G-XtremE's Avatar
Member
Thanks Meter 11
Posts: 71
Join Date: Dec 2011
Location: Cluj-Napoca, Romania
There are several other topics created for this issue Slow or reboot when opening camera apps and [Q] Galaxy S4 - reboot launching camera from lockscreen

So far, temporary fixes are limiting the background processes to 4 from the developer options in the settings menu and disabling air view options and smart screen options. This has worked for me, I haven't experienced any other reboots but the lag is still present and sometimes when enabling both cameras feature the app would freeze.

I'm not sure whether this is a hardware or a software issue but nevertheless most GS4s experience lag with the camera app, especially those on the octa version, the GT-I9500. I bought the phone internationally, not using a carrier and switching mine will be a pain; therefore i really hope it's a solvable software issue.

Black Galaxy S4 GT-I9505
All Stock 4.2.2 XXUBMGA

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes