Android 5.0.2 and New Factory Images For Nexus 7 (Wi-Fi) Available

Android 5.0 is has been publicly available since early November, and the … more

Github Tutorial App Shows You How to Use… Github

Github can get pretty complicated and using it can become quite daunting, especially … more

Google Glass-like Clip-On For Regular Glasses Developed by Sony

For the price of $2,000, a pair of glasses that can run apps, take pictures, … more

Micromax Takes OnePlus to Court! Android Wear Receives Lollipop – XDA TV

Android 5.0 Lollipop is available officially for the Moto 360! … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] CAMERA crash!

OP obaid_rock

12th May 2013, 07:34 AM   |  #1  
OP Junior Member
Thanks Meter: 0
 
10 posts
Join Date:Joined: Mar 2012
ok so i bought Galaxy S4 i9500.. like a week ago.. then i updated my firmware using keis like 2 days ago.. n now my camera crashes.. when not used after a very long time. im not sure is it either the samsung fault or android fault.. my current version is 4.2.2. if u need anymore details.. i will love to provide them!!
12th May 2013, 09:41 PM   |  #2  
Senior Member
Thanks Meter: 32
 
232 posts
Join Date:Joined: Dec 2012
Quote:
Originally Posted by obaid_rock

ok so i bought Galaxy S4 i9500.. like a week ago.. then i updated my firmware using keis like 2 days ago.. n now my camera crashes.. when not used after a very long time. im not sure is it either the samsung fault or android fault.. my current version is 4.2.2. if u need anymore details.. i will love to provide them!!

Does it say "warning;camera failed" ? And are you loading the camera from the lock screen or home screen?
x102x96x
12th May 2013, 09:54 PM   |  #3  
Guest
Thanks Meter: 0
 
n/a posts
Quote:
Originally Posted by obaid_rock

ok so i bought Galaxy S4 i9500.. like a week ago.. then i updated my firmware using keis like 2 days ago.. n now my camera crashes.. when not used after a very long time. im not sure is it either the samsung fault or android fault.. my current version is 4.2.2. if u need anymore details.. i will love to provide them!!

the easiest way is to flash another firmware (Stock*) by Odin
download anther firmware from sammobile.com
ur setting and data will remain but problem will fix
12th May 2013, 10:03 PM   |  #4  
Junior Member
Thanks Meter: 0
 
1 posts
Join Date:Joined: May 2013
I bought a new samsung galaxy 4s and the camera failed
Quote:
Originally Posted by obaid_rock

ok so i bought Galaxy S4 i9500.. like a week ago.. then i updated my firmware using keis like 2 days ago.. n now my camera crashes.. when not used after a very long time. im not sure is it either the samsung fault or android fault.. my current version is 4.2.2. if u need anymore details.. i will love to provide them!!

I had the same problem with my new Galaxy S4 that I bought on 8 of may in 2013.
In the beginning, the camera work fine, but after several minutes, on each time that I tried to open the camera aplication it had black screen with an error message.
I tried to exit the battery and return it, it didn't help.
I tried to rebot to manufacturer settings, at the first couple of minutes the camera work fine, but later the black screen appear again at each time I open the camera application.
Here is a link to youtube that show the same problem that I had :

Search on youtube "samsung galaxy s4 camera fail"

What can I do ?
13th May 2013, 07:22 PM   |  #5  
Member
Thanks Meter: 6
 
56 posts
Join Date:Joined: Feb 2012
I am having the same problem with my s4; tried system update, factory reset... maybe i need to try to flash my firmware. so disappointed with Samsung. a flagship phone shouldn't have this problem!
to be safe, getting it exchanged... i never bought insurance before but it looks like i might need to if i am sticking with the s4.
13th May 2013, 07:53 PM   |  #6  
runedrune's Avatar
Senior Member
Flag Lahore
Thanks Meter: 2,296
 
4,509 posts
Join Date:Joined: Nov 2010
More
It's a known problem. Loads of people have it. You'll just have to wait for Samsung to fix it.
13th May 2013, 08:56 PM   |  #7  
Senior Member
Thanks Meter: 32
 
232 posts
Join Date:Joined: Dec 2012
Smile
Quote:
Originally Posted by gili1234

I had the same problem with my new Galaxy S4 that I bought on 8 of may in 2013.
In the beginning, the camera work fine, but after several minutes, on each time that I tried to open the camera aplication it had black screen with an error message.
I tried to exit the battery and return it, it didn't help.
I tried to rebot to manufacturer settings, at the first couple of minutes the camera work fine, but later the black screen appear again at each time I open the camera application.
Here is a link to youtube that show the same problem that I had :

Search on youtube "samsung galaxy s4 camera fail"

What can I do ?


From today speaking to a guy who repairs samsungs this is a hardware issue. Reboots and factory resets seem to fix the issue but the root of the problem is the the camera module either not correctly attached/or soldered to the connection so when rebooting or resetting the phone the movement of the device in your hand or laying the phone face up briefly re-connects the module to the device. I'm awaiting my new device as my carrier told me a few people have had this issue also.

Hope that helps
14th May 2013, 06:30 AM   |  #8  
OP Junior Member
Thanks Meter: 0
 
10 posts
Join Date:Joined: Mar 2012
Quote:
Originally Posted by cameracartwright

Does it say "warning;camera failed" ? And are you loading the camera from the lock screen or home screen?

no it dosent.. it just crashes.. with a black screen!
14th May 2013, 02:17 PM   |  #9  
WitchMX's Avatar
Senior Member
Thanks Meter: 12
 
156 posts
Join Date:Joined: Feb 2011
More
I have taken several pictures with my 2 days old GS4 but in one occasion when I opened the camera and switched from the front camera to the main, the phone froze and reboot it self :/

I hope i only was a one time failure and not hardware or software relate.

Cheers
14th May 2013, 02:58 PM   |  #10  
G-XtremE's Avatar
Member
Flag Cluj-Napoca, Romania
Thanks Meter: 11
 
71 posts
Join Date:Joined: Dec 2011
More
There are several other topics created for this issue Slow or reboot when opening camera apps and [Q] Galaxy S4 - reboot launching camera from lockscreen

So far, temporary fixes are limiting the background processes to 4 from the developer options in the settings menu and disabling air view options and smart screen options. This has worked for me, I haven't experienced any other reboots but the lag is still present and sometimes when enabling both cameras feature the app would freeze.

I'm not sure whether this is a hardware or a software issue but nevertheless most GS4s experience lag with the camera app, especially those on the octa version, the GT-I9500. I bought the phone internationally, not using a carrier and switching mine will be a pain; therefore i really hope it's a solvable software issue.
Last edited by G-XtremE; 14th May 2013 at 03:02 PM.

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes