Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,811,702 Members 53,813 Now Online
XDA Developers Android and Mobile Development Forum

(Q) serious lag when updating apps

Tip us?
 
maverick1103
Old
#1  
maverick1103's Avatar
Senior Member - OP
Thanks Meter 128
Posts: 1,112
Join Date: Jun 2011
Location: Birmingham
Default (Q) serious lag when updating apps

Help, i've had my Note 3 just about a month now and ever since I've had it I get seriously bad lag when I'm updating apps from Play Store.
It's that bad that if I update all apps and there are 3/4 apps I have to wait until they are done otherwise the phone gets that laggy I can't do anything.

I haven't done a reset but I'm thinking I probably will need too, unless anyone else knows what it could be?

Thanks

Sent from my SM-N9005 using Tapatalk
Current phone....

HTC One M8, Gunmetal Grey

Current tablet

Nexus 7 (2013)

Previously owned...

Samsung Note 3, Sony Xperia Z1, HTC One, Sony Xperia Z White, Samsung Galaxy Note 2 Grey (N7100), Samsung Galaxy S3 Blue (i9300), HTC One X White, HTC Desire HD, Nokia Lumia 800, Samsung Galaxy S2 (i9200), iPhone 4, iPhone 3GS, iPhone 3G.
 
nicholaschum
Old
#2  
nicholaschum's Avatar
Senior Member
Thanks Meter 1,114
Posts: 1,741
Join Date: Feb 2011
Location: Toronto, ON (Hong Kong S.A.R.)

 
DONATE TO ME
Happens to me, I don't really care for it because it only updates on WiFi. My phone gets stuttery when it installs the update more than when it is downloading. Also to note, it's recurrent on 4.3 and 4.4.2.

Sent from my fingers to your face using my Samsung Galaxy Note 3!
ROM Problem? Try this or ask me on G+!
Root/TWRP/Kernel/ROM and KNOX 0x0 on N900W8? My guide.

Primary Phone: OnePlus One - A0001
Mahdi v2.7 14/09, ak v40b08, MR-TWRP 2.8.0

Secondary Phone: Note 3 - SM-N900W8
Temasek UO v133, Temasek v3.93, TWRP 2.7.2, NA2 BL, NB7 CP, 0x0

Tablet: Nexus 7 (2012)

OnePlus One ◆ Note 3 ◆ Xperia Tab P ◆ Nexus 7 ◆ Note II LTE ◆ S III LTE ◆ One X ◆ Note I ◆ Galaxy Nexus ◆ S II LTE ◆ S II


 
maverick1103
Old
#3  
maverick1103's Avatar
Senior Member - OP
Thanks Meter 128
Posts: 1,112
Join Date: Jun 2011
Location: Birmingham
Quote:
Originally Posted by nicholaschum View Post
Happens to me, I don't really care for it because it only updates on WiFi. My phone gets stuttery when it installs the update more than when it is downloading. Also to note, it's recurrent on 4.3 and 4.4.2.

Sent from my fingers to your face using my Samsung Galaxy Note 3!
Well I'm slightly relived that it's just not me, but now I'm thinking doing a reset won't solve it. It's not a major issue but just shouldn't be doing it.

Sent from my SM-N9005 using Tapatalk
Current phone....

HTC One M8, Gunmetal Grey

Current tablet

Nexus 7 (2013)

Previously owned...

Samsung Note 3, Sony Xperia Z1, HTC One, Sony Xperia Z White, Samsung Galaxy Note 2 Grey (N7100), Samsung Galaxy S3 Blue (i9300), HTC One X White, HTC Desire HD, Nokia Lumia 800, Samsung Galaxy S2 (i9200), iPhone 4, iPhone 3GS, iPhone 3G.
 
nicholaschum
Old
#4  
nicholaschum's Avatar
Senior Member
Thanks Meter 1,114
Posts: 1,741
Join Date: Feb 2011
Location: Toronto, ON (Hong Kong S.A.R.)

 
DONATE TO ME
Quote:
Originally Posted by maverick1103 View Post
Well I'm slightly relived that it's just not me, but now I'm thinking doing a reset won't solve it. It's not a major issue but just shouldn't be doing it.

Sent from my SM-N9005 using Tapatalk
Doing a reset won't solve the issue, it's more that the system is focused on getting the install to be quickly and painlessly finished and causes other processes to slow down due to CPU demand changes. I'm running a custom ROM and kernel and still get these problems, and before I was on stock 4.3 so I can confirm it's not your hardware or personal configuration issue.

Also when your launcher lags, it's due to the fact that you're on the launcher but it has to do a live app removal from the drawer and then reinsertion of the app.

Sent from my fingers to your face using my Samsung Galaxy Note 3!
ROM Problem? Try this or ask me on G+!
Root/TWRP/Kernel/ROM and KNOX 0x0 on N900W8? My guide.

Primary Phone: OnePlus One - A0001
Mahdi v2.7 14/09, ak v40b08, MR-TWRP 2.8.0

Secondary Phone: Note 3 - SM-N900W8
Temasek UO v133, Temasek v3.93, TWRP 2.7.2, NA2 BL, NB7 CP, 0x0

Tablet: Nexus 7 (2012)

OnePlus One ◆ Note 3 ◆ Xperia Tab P ◆ Nexus 7 ◆ Note II LTE ◆ S III LTE ◆ One X ◆ Note I ◆ Galaxy Nexus ◆ S II LTE ◆ S II


The Following User Says Thank You to nicholaschum For This Useful Post: [ Click to Expand ]
 
maverick1103
Old
#5  
maverick1103's Avatar
Senior Member - OP
Thanks Meter 128
Posts: 1,112
Join Date: Jun 2011
Location: Birmingham
Quote:
Originally Posted by nicholaschum View Post
Doing a reset won't solve the issue, it's more that the system is focused on getting the install to be quickly and painlessly finished and causes other processes to slow down due to CPU demand changes. I'm running a custom ROM and kernel and still get these problems, and before I was on stock 4.3 so I can confirm it's not your hardware or personal configuration issue.

Also when your launcher lags, it's due to the fact that you're on the launcher but it has to do a live app removal from the drawer and then reinsertion of the app.

Sent from my fingers to your face using my Samsung Galaxy Note 3!
Thanks for that explanation, that does make sense now, however coming from previous phones (Sony Z1 and HTC One) these never had that issue and the Note 3 is more powerful, im a bit confused. So basically it's Samsung's software that's the cause?

Sent from my SM-N9005 using Tapatalk
Current phone....

HTC One M8, Gunmetal Grey

Current tablet

Nexus 7 (2013)

Previously owned...

Samsung Note 3, Sony Xperia Z1, HTC One, Sony Xperia Z White, Samsung Galaxy Note 2 Grey (N7100), Samsung Galaxy S3 Blue (i9300), HTC One X White, HTC Desire HD, Nokia Lumia 800, Samsung Galaxy S2 (i9200), iPhone 4, iPhone 3GS, iPhone 3G.
 
nicholaschum
Old
#6  
nicholaschum's Avatar
Senior Member
Thanks Meter 1,114
Posts: 1,741
Join Date: Feb 2011
Location: Toronto, ON (Hong Kong S.A.R.)

 
DONATE TO ME
Quote:
Originally Posted by maverick1103 View Post
Thanks for that explanation, that does make sense now, however coming from previous phones (Sony Z1 and HTC One) these never had that issue and the Note 3 is more powerful, im a bit confused. So basically it's Samsung's software that's the cause?

Sent from my SM-N9005 using Tapatalk
I believe it is something to do with TouchWiz. My other Samsung phones lag like crazy as well whilst installing apps.

Sent from my fingers to your face using my Samsung Galaxy Note 3!
ROM Problem? Try this or ask me on G+!
Root/TWRP/Kernel/ROM and KNOX 0x0 on N900W8? My guide.

Primary Phone: OnePlus One - A0001
Mahdi v2.7 14/09, ak v40b08, MR-TWRP 2.8.0

Secondary Phone: Note 3 - SM-N900W8
Temasek UO v133, Temasek v3.93, TWRP 2.7.2, NA2 BL, NB7 CP, 0x0

Tablet: Nexus 7 (2012)

OnePlus One ◆ Note 3 ◆ Xperia Tab P ◆ Nexus 7 ◆ Note II LTE ◆ S III LTE ◆ One X ◆ Note I ◆ Galaxy Nexus ◆ S II LTE ◆ S II


 
CravingMender9
Old
#7  
Senior Member
Thanks Meter 41
Posts: 120
Join Date: Jun 2011
Location: Charlotte
Default Lookout slowing down the phone too

Quote:
Originally Posted by nicholaschum View Post
I believe it is something to do with TouchWiz. My other Samsung phones lag like crazy as well whilst installing apps.

Sent from my fingers to your face using my Samsung Galaxy Note 3!
I noticed something on my TMob Note 3, I have Lookout security pre-installed and I see slight improvement if it is not scanning apps after every install and if it is disabled. Can someone check if you are seeing any improvements without Lookout Security or is it just my placebo?

Also, the Lookout backup upload slows both my phone and the internet. Any idea why that is happening? Is it uploading everything again and again or just the changes?
 
nicholaschum
Old
#8  
nicholaschum's Avatar
Senior Member
Thanks Meter 1,114
Posts: 1,741
Join Date: Feb 2011
Location: Toronto, ON (Hong Kong S.A.R.)

 
DONATE TO ME
Quote:
Originally Posted by rahulisola View Post
I noticed something on my TMob Note 3, I have Lookout security pre-installed and I see slight improvement if it is not scanning apps after every install and if it is disabled. Can someone check if you are seeing any improvements without Lookout Security or is it just my placebo?

Also, the Lookout backup upload slows both my phone and the internet. Any idea why that is happening? Is it uploading everything again and again or just the changes?
My other Samsung phones don't have anything installed and still lags.

However, I do have some security apps installed to check for viruses, but the thing is, it only checks after the app is installed, not during install, and the lag spikes in only during the install and not after.

I use Avast Mobile Security to scan my apps.
ROM Problem? Try this or ask me on G+!
Root/TWRP/Kernel/ROM and KNOX 0x0 on N900W8? My guide.

Primary Phone: OnePlus One - A0001
Mahdi v2.7 14/09, ak v40b08, MR-TWRP 2.8.0

Secondary Phone: Note 3 - SM-N900W8
Temasek UO v133, Temasek v3.93, TWRP 2.7.2, NA2 BL, NB7 CP, 0x0

Tablet: Nexus 7 (2012)

OnePlus One ◆ Note 3 ◆ Xperia Tab P ◆ Nexus 7 ◆ Note II LTE ◆ S III LTE ◆ One X ◆ Note I ◆ Galaxy Nexus ◆ S II LTE ◆ S II


 
maverick1103
Old
#9  
maverick1103's Avatar
Senior Member - OP
Thanks Meter 128
Posts: 1,112
Join Date: Jun 2011
Location: Birmingham
Quote:
Originally Posted by rahulisola View Post
I noticed something on my TMob Note 3, I have Lookout security pre-installed and I see slight improvement if it is not scanning apps after every install and if it is disabled. Can someone check if you are seeing any improvements without Lookout Security or is it just my placebo?

Also, the Lookout backup upload slows both my phone and the internet. Any idea why that is happening? Is it uploading everything again and again or just the changes?






Quote:
Originally Posted by nicholaschum View Post
My other Samsung phones don't have anything installed and still lags.

However, I do have some security apps installed to check for viruses, but the thing is, it only checks after the app is installed, not during install, and the lag spikes in only during the install and not after.

I use Avast Mobile Security to scan my apps.
I have no AV app on my phone, do not believe in them, so it's got to be TouchWiz.

Sent from my SM-N9005 using Tapatalk
Current phone....

HTC One M8, Gunmetal Grey

Current tablet

Nexus 7 (2013)

Previously owned...

Samsung Note 3, Sony Xperia Z1, HTC One, Sony Xperia Z White, Samsung Galaxy Note 2 Grey (N7100), Samsung Galaxy S3 Blue (i9300), HTC One X White, HTC Desire HD, Nokia Lumia 800, Samsung Galaxy S2 (i9200), iPhone 4, iPhone 3GS, iPhone 3G.
 
Bulbous
Old
#10  
Senior Member
Thanks Meter 66
Posts: 265
Join Date: Nov 2012
Location: Dubai
Quote:
Originally Posted by maverick1103 View Post
I have no AV app on my phone, do not believe in them, so it's got to be TouchWiz.
Or it's the malware that's on your phone

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes