Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,732,020 Members 41,086 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Lenovo S820 boot loop help!

Tip us?
 
SIMPLEFBB
Old
#1  
Junior Member - OP
Thanks Meter 1
Posts: 21
Join Date: Jan 2013
Default [Q] Lenovo S820 boot loop help!

Hi! I recently purchased Lenovo S820 and I'm ultra happy with this device from any aspect! But.. Well, I searched but didn't find CWM for S820 to flash zips, so I decided to try Flash Gordon to flash a zip file, which, all in all, drove my device to have a boot loop, meaning that it stucks on the boot logo and never turns on. I know that the developer of Flash Gordon isn't responsible at all for my brick, but I don't know what to do now because the default recovery of Lenovo S820 is in chinese and I cannot understand a single thing. Can you help me translate it please? You can see the recovery pic below:



I googled it and found this, do you think it could work, I mean can I install a whole new rom via SP Flash Tools?

Thanks!
 
bakuLaw
Old
#2  
bakuLaw's Avatar
Member
Thanks Meter 1
Posts: 35
Join Date: Dec 2012
Location: OEJN
Re flash ur unit with stock ROM using flashtool

Sent from my Lenovo S820_ROW using xda app-developers app
Xperia PRO UHD v2.0.2

 
rohit16
Old
#3  
Junior Member
Thanks Meter 1
Posts: 5
Join Date: Dec 2013
Default Same problem!

My Lenovo s820 is also stuck in a bootloop after I tried to flash a cwm to it using mobileuncle mtk tools
Now the phone won't go into recovery mode. Everytime I try, it gets stuck in the bootloop where it only shows the lenovo logo and goes off and boots to the same point again, and the loop continues.
It still goes into meta mode and factory mode.
I don't know where to find the stock rom, although I have a backup of it which I took using mtk droid tools
I tried restoring the backup while keeping my phone in meta mode but it did not work
Is it possible to flash the backup using flash tools? Could you give me a tutorial if possible? I'm new to android and don't know much

Please help! I'm panicking and don't know what to do!
 
bakuLaw
Old
#4  
bakuLaw's Avatar
Member
Thanks Meter 1
Posts: 35
Join Date: Dec 2012
Location: OEJN
First,install MTK preloader drivers

then dL SP_Flash_Tool_v3.1332.0.187

reflash with Stock ROM S820 ROW

after flashing stock rom,you can install
CWM Recovery using Flashtool again.
Xperia PRO UHD v2.0.2

 
rohit16
Old
(Last edited by rohit16; 20th December 2013 at 04:33 PM.)
#5  
Junior Member
Thanks Meter 1
Posts: 5
Join Date: Dec 2013
Quote:
Originally Posted by bakuLaw View Post
First,install MTK preloader drivers

then dL SP_Flash_Tool_v3.1332.0.187

reflash with Stock ROM S820 ROW

after flashing stock rom,you can install
CWM Recovery using Flashtool again.
It isn't getting flashed! I've tried a lot of times
I put the phone in meta mode and started the flashing process
A pink progress bar happened about 3 or 4 times and then it just stops at 0% and nothing happens at all
Screenshot attached
Attached Thumbnails
Click image for larger version

Name:	Screenshot (13).png
Views:	668
Size:	32.9 KB
ID:	2465339  
 
SIMPLEFBB
Old
#6  
Junior Member - OP
Thanks Meter 1
Posts: 21
Join Date: Jan 2013
Quote:
Originally Posted by bakuLaw View Post
First,install MTK preloader drivers

then dL SP_Flash_Tool_v3.1332.0.187

reflash with Stock ROM S820 ROW

after flashing stock rom,you can install
CWM Recovery using Flashtool again.
Thanks! I finally found it!
 
bakuLaw
Old
#7  
bakuLaw's Avatar
Member
Thanks Meter 1
Posts: 35
Join Date: Dec 2012
Location: OEJN
Quote:
Originally Posted by rohit16 View Post
It isn't getting flashed! I've tried a lot of times
I put the phone in meta mode and started the flashing process
A pink progress bar happened about 3 or 4 times and then it just stops at 0% and nothing happens at all
Screenshot attached
tick preload image



more GUIDE
Xperia PRO UHD v2.0.2

 
Komander_Krispy
Old
#8  
Junior Member
Thanks Meter 0
Posts: 2
Join Date: Jun 2014
Same problem here. And when i try to install the preloader drivers i have a massive problem and its really annoying. when i plug in my usb without the battery in into my pc to install the preloader drivers it keeps disconnecting itself i tried using USBDeview but it doesnt help I really need help what is causing my phone to keep disconnecting? Pease Help
 
JM33KS
Old
#9  
Junior Member
Thanks Meter 0
Posts: 4
Join Date: May 2014
Default please help!?

My s820 was very excellent, after updating my phone, my phone when booting, battery from 100 down to 32, then I charged it. When charging my phone, it is really slow. Please help???
 
rohit16
Old
#10  
Junior Member
Thanks Meter 1
Posts: 5
Join Date: Dec 2013
Quote:
Originally Posted by Komander_Krispy View Post
Same problem here. And when i try to install the preloader drivers i have a massive problem and its really annoying. when i plug in my usb without the battery in into my pc to install the preloader drivers it keeps disconnecting itself i tried using USBDeview but it doesnt help I really need help what is causing my phone to keep disconnecting? Pease Help
You have to install the preloaded drivers first. Then start the flashing process on SP Flash Tools. You'll be prompted to connect your phone. That's when you have to hold the volume down button and connect it without the battery. Your phone will be connected then and the flashing process will happen normally. I had the same issue as you initially but I think its normal because I could still flash my phone and restore it.

The Following User Says Thank You to rohit16 For This Useful Post: [ Click to Expand ]
Tags
boot, brick, lenovo, s820, stuck
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes