Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

Jiayu G3S MT6589 Bricked without any flashing

OP crackgm

24th March 2014, 12:27 AM   |  #1  
OP Junior Member
Thanks Meter: 0
 
4 posts
Join Date:Joined: Nov 2009
Hello,
I have Jiayu G3S MT6589 and phone was working perfect, I was keeping it in my pocket and yesterday i took the phone off the pocket and i couldn't boot it. I can't charge it either. I tried to put other battery in my phone and it still didn't boot up. But when i connect it by USB i can see that its MTK USB Port, or MTK DA port or something like this (that's after installing drivers, before I installed it i was getting Unknown Device on the list - it shold be MT65xx Preloader) So i tried to flash a stock rom (SP flash tool), but i can't do it too - I'm getting error connected with DRAM, or the red bar is loading like 100% and then nothing..I can wait and wait and nothing more...
I didn't broke my phone like it was never on the floor or something like that and I didn't change Preloader by SP Flash Tools
It's very important to me to fix it fast because I'm working on dual sim and I need smartphone... I don't want to send it back to China - it would take at least 2 months to complete repair, so I'm determinated to do it on my own, but I need your help...
24th March 2014, 12:59 AM   |  #2  
anonimo95's Avatar
Senior Member
Thanks Meter: 85
 
223 posts
Join Date:Joined: Mar 2011
Quote:
Originally Posted by crackgm

Hello,
I have Jiayu G3S MT6589 and phone was working perfect, I was keeping it in my pocket and yesterday i took the phone off the pocket and i couldn't boot it. I can't charge it either. I tried to put other battery in my phone and it still didn't boot up. But when i connect it by USB i can see that its MTK USB Port, or MTK DA port or something like this (that's after installing drivers, before I installed it i was getting Unknown Device on the list - it shold be MT65xx Preloader) So i tried to flash a stock rom (SP flash tool), but i can't do it too - I'm getting error connected with DRAM, or the red bar is loading like 100% and then nothing..I can wait and wait and nothing more...
I didn't broke my phone like it was never on the floor or something like that and I didn't change Preloader by SP Flash Tools
It's very important to me to fix it fast because I'm working on dual sim and I need smartphone... I don't want to send it back to China - it would take at least 2 months to complete repair, so I'm determinated to do it on my own, but I need your help...

if you didnt mess up with anything, its hw issue i would say
24th March 2014, 03:08 AM   |  #3  
superdragonpt's Avatar
Recognized Contributor
Flag Lisbon
Thanks Meter: 5,209
 
1,812 posts
Join Date:Joined: Apr 2013
Donate to Me
More
Quote:
Originally Posted by crackgm

Hello,
I have Jiayu G3S MT6589 and phone was working perfect, I was keeping it in my pocket and yesterday i took the phone off the pocket and i couldn't boot it. I can't charge it either. I tried to put other battery in my phone and it still didn't boot up. But when i connect it by USB i can see that its MTK USB Port, or MTK DA port or something like this (that's after installing drivers, before I installed it i was getting Unknown Device on the list - it shold be MT65xx Preloader) So i tried to flash a stock rom (SP flash tool), but i can't do it too - I'm getting error connected with DRAM, or the red bar is loading like 100% and then nothing..I can wait and wait and nothing more...
I didn't broke my phone like it was never on the floor or something like that and I didn't change Preloader by SP Flash Tools
It's very important to me to fix it fast because I'm working on dual sim and I need smartphone... I don't want to send it back to China - it would take at least 2 months to complete repair, so I'm determinated to do it on my own, but I need your help...


Hi

Try this:

1:Remove the battery, and keep the phone WITHOUT the battery for >2 hours
2: Re-insert the battery and charge the phone (check if its charging) either by the led (in case it haves one), or by the off-line charge animation
3: If its charging GOOD , continue to the next step, if its not, im affraid its really bricked (if the phone doesnt display the off-line charge animation its in most mtk devices an hard brick)
4: If the phone charges ok, then re-flash ALL the nand via SPFlashTools (including the pre-loader) keep in mind to flash the right spflashtools rom version
5: And of course you need to have the Mediatek drivers installed for this to work, if your using windows8 , you may have some drivers problems, since the mediatek drivers have issues with this windows version, so just use windows 7 or xp.

For the drivers download this ones:
http://forum.xda-developers.com/devd...ct/dl/?id=4282

This are Universal Mediatek drivers...

Good Luck
Best regards
The Following 2 Users Say Thank You to superdragonpt For This Useful Post: [ View ]
24th March 2014, 08:30 PM   |  #4  
OP Junior Member
Thanks Meter: 0
 
4 posts
Join Date:Joined: Nov 2009
Quote:
Originally Posted by superdragonpt

Hi

Try this:

1:Remove the battery, and keep the phone WITHOUT the battery for >2 hours
2: Re-insert the battery and charge the phone (check if its charging) either by the led (in case it haves one), or by the off-line charge animation
3: If its charging GOOD , continue to the next step, if its not, im affraid its really bricked (if the phone doesnt display the off-line charge animation its in most mtk devices an hard brick)
4: If the phone charges ok, then re-flash ALL the nand via SPFlashTools (including the pre-loader) keep in mind to flash the right spflashtools rom version
5: And of course you need to have the Mediatek drivers installed for this to work, if your using windows8 , you may have some drivers problems, since the mediatek drivers have issues with this windows version, so just use windows 7 or xp.

For the drivers download this ones:
http://forum.xda-developers.com/devd...ct/dl/?id=4282

This are Universal Mediatek drivers...

Good Luck
Best regards

Thanks for your reply... I left the phone without battery for 4 hours, and it's not charging...
But what I've noticed:
When i connect phone with battery it shows on computer as MTK USB Port, then when i take the battery out (and it's still connected) it disappears, but when i hold VOL- it shows again, but still I can't flash...

I've checked voltage on phone (battery slot) and it's like 0.5V-2V when the phone is connected, so I guess the phone charges the battery...
Last edited by crackgm; 24th March 2014 at 09:39 PM.
26th March 2014, 10:06 PM   |  #5  
OP Junior Member
Thanks Meter: 0
 
4 posts
Join Date:Joined: Nov 2009
I've decided to send it back to Pandawill but they requested a short movie showing what is happening...
I'll send phone on Monday if it won't start, so if you have any ideas to make it work...I will be very happy
Thanks
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes