Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,728,832 Members 50,470 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Problem with File transfers to SD Card

Tip us?
 
ashtonsd
Old
#1  
Junior Member - OP
Thanks Meter 2
Posts: 7
Join Date: Feb 2014
Unhappy [Q] Problem with File transfers to SD Card

I received my Note Pro (WiFi) on Wednesday.
It really is superb and I am loving it, however I have a really irritating problem.
When connecting to my PC and attempting to transfer content to the Micro SDCard (SanDisk 64gb - mainly video files) the connection frequently drops causing the transfer to fail. Sometimes it is fine for a file or two, sometimes it fails on the first file. The PC then cannot see any content on the card untl I reboot the Note Pro.
Any ideas?

Please note:
1) I have tried two other cards, another 64gb SanDisk and a 32gb Samsung but this happens with all transfers (suggesting its not the card)
2) All cards work fine in my Note 3 and Note 10.1 2014
3) Transfers to the internal memory are fast (on USB 3.0) and work fine (suggesting it is the Note Pro)
4) Transfers from my PC to my Note 3 and Note 10.1 2014 work fine (suggesting it is not the PC)
5) The problem occurs with both USB 2.0 and USB 3.0 transfers, and with various cables to any PC port
6) My MX Player Pro app cannot delete files from the SDCard but can see them
7) Some apps (e.g. My Drives) cannot see the SD Card but the stock apps can all see the content and delete/modify files
8) I have tried reformatting the cards both in the Note Pro and the PC but that makes no difference
9) I have used Kies 3 to re-install the USB drivers but this didn't cure the problem

As my primary use for the tablet is watching pre-downloaded video on my commute to work this is very frustrating.

It might be that this is a firmware problem that gets sorted as the device becomes more available and I am working round it atm.

Any help would be appreciated.
 
bitpushr
Old
#2  
bitpushr's Avatar
XDA:Administrator
Thanks Meter 1172
Posts: 974
Join Date: Mar 2007
Quote:
Originally Posted by ashtonsd View Post
I received my Note Pro (WiFi) on Wednesday.
It really is superb and I am loving it, however I have a really irritating problem.
When connecting to my PC and attempting to transfer content to the Micro SDCard (SanDisk 64gb - mainly video files) the connection frequently drops causing the transfer to fail. Sometimes it is fine for a file or two, sometimes it fails on the first file. The PC then cannot see any content on the card untl I reboot the Note Pro.
Any ideas?

Please note:
1) I have tried two other cards, another 64gb SanDisk and a 32gb Samsung but this happens with all transfers (suggesting its not the card)
2) All cards work fine in my Note 3 and Note 10.1 2014
3) Transfers to the internal memory are fast (on USB 3.0) and work fine (suggesting it is the Note Pro)
4) Transfers from my PC to my Note 3 and Note 10.1 2014 work fine (suggesting it is not the PC)
5) The problem occurs with both USB 2.0 and USB 3.0 transfers, and with various cables to any PC port
6) My MX Player Pro app cannot delete files from the SDCard but can see them
7) Some apps (e.g. My Drives) cannot see the SD Card but the stock apps can all see the content and delete/modify files
8) I have tried reformatting the cards both in the Note Pro and the PC but that makes no difference
9) I have used Kies 3 to re-install the USB drivers but this didn't cure the problem

As my primary use for the tablet is watching pre-downloaded video on my commute to work this is very frustrating.

It might be that this is a firmware problem that gets sorted as the device becomes more available and I am working round it atm.

Any help would be appreciated.
Are you able to check out logcat to see if it is spitting out any errors?
Current Phone: Nexus 5 (Android L) | Oppo Find 5 (Omni)

Past Phones: Nexus 4, Samsung Galaxy SIII i9300, HTC One X, Galaxy Note, iPhone 4S, 4, 3G, 3 (Jailbroken), Motorola V360, HTC TyTN
Past Tablets/Devices: Arnova 10G2, Asus EEEPC 900a, IBM/Lenovo Thinkpads
 
ashtonsd
Old
#3  
Junior Member - OP
Thanks Meter 2
Posts: 7
Join Date: Feb 2014
Default Logcat

I have repeated the process a few times but cannot see anything obvious in logcat. There are certainly no errors in the log immediately after the event.

logcat.zip file attached.
Attached Files
File Type: zip logcat.zip - [Click for QR Code] (109.1 KB, 45 views)
 
extrememonkey
Old
#4  
extrememonkey's Avatar
Senior Member
Thanks Meter 51
Posts: 332
Join Date: Oct 2010
I'm having a similar issue when transferring a 1.3g video file from my notepro storage to the micro sd card.... It starts to transfer the data and then fails.

It's like the sd card had been removed as when I look at the sd card using a file Explorer it is accessible but all info on the card isn't present. If I unmount the sd card I can't remount it, I have to manually remove the card and put it back in to see any info on the card!!!!


Definitely a faulty sd card reader or a bug in the firmware!!!

Sent from my SM-P900 using xda app-developers app
The Following User Says Thank You to extrememonkey For This Useful Post: [ Click to Expand ]
 
ashtonsd
Old
#5  
Junior Member - OP
Thanks Meter 2
Posts: 7
Join Date: Feb 2014
Quote:
Originally Posted by extrememonkey View Post
I'm having a similar issue when transferring a 1.3g video file from my notepro storage to the micro sd card.... It starts to transfer the data and then fails.

It's like the sd card had been removed as when I look at the sd card using a file Explorer it is accessible but all info on the card isn't present. If I unmount the sd card I can't remount it, I have to manually remove the card and put it back in to see any info on the card!!!!


Definitely a faulty sd card reader or a bug in the firmware!!!

Sent from my SM-P900 using xda app-developers app
Well at least I know I am not going mad 716

Samsung will need to sort this out quickly with the impending release of the Note Pro in the US on 13th Feb.
I hope it can be fixed with a firmware update.
 
extrememonkey
Old
#6  
extrememonkey's Avatar
Senior Member
Thanks Meter 51
Posts: 332
Join Date: Oct 2010
Quote:
Originally Posted by extrememonkey View Post
I'm having a similar issue when transferring a 1.3g video file from my notepro storage to the micro sd card.... It starts to transfer the data and then fails.

It's like the sd card had been removed as when I look at the sd card using a file Explorer it is accessible but all info on the card isn't present. If I unmount the sd card I can't remount it, I have to manually remove the card and put it back in to see any info on the card!!!!


Definitely a faulty sd card reader or a bug in the firmware!!!

Sent from my SM-P900 using xda app-developers app
Yes I know - whats the point of having a micro sd card slot if you cant write to the card!!! I know I can do this on my S4 and Note 2 and I used to be able to do this on my old 10.1 - all are rooted but that shouldn't make a difference!!!!

Sent from my GT-I9505 using xda app-developers app

---------- Post added at 02:54 PM ---------- Previous post was at 02:01 PM ----------

Just got off the phone to samsung support..... its definitely a problem with how 4.4 is implemented on the NotePro, even though the Samsung Support Guy did everything he could to blame my SD Card.

Hopefully a firmware update will fix it a little down the line.... so for the time being my micro sd card adapter is going to get a lot of use!!!!



Sent from my GT-I9505 using xda app-developers app
 
extrememonkey
Old
#7  
extrememonkey's Avatar
Senior Member
Thanks Meter 51
Posts: 332
Join Date: Oct 2010
Looking around the net and looking at Note 3 and Note 10.1 (2014) forums there have been lots of problems when people upgrade to 4.4 and aren't rooted.

It looks like the permissions are set to disable write access to the ext micro card, if your rooted it's is easy to change these, if your not it can't be changed.

Samsung will need to change these permissions if they see fit and release an update. I have sent an email to Samsung support advising them of the issue and also advising them how to fix it..... Just have to wait and see!!!

Sent from my SM-P900 using xda app-developers app
 
bitpushr
Old
#8  
bitpushr's Avatar
XDA:Administrator
Thanks Meter 1172
Posts: 974
Join Date: Mar 2007
Quote:
Originally Posted by ashtonsd View Post
I have repeated the process a few times but cannot see anything obvious in logcat. There are certainly no errors in the log immediately after the event.

logcat.zip file attached.
Maybe a problem with SELinux permissions on the card? I see a lot of errors with Knox/SELinux from that logcat.

MTP is the media transfer protocol.

Quote:
W/ContextImpl( 7677): Calling a method in the system process without a qualified user: android.app.ContextImpl.sendBroadcast:1464 android.content.ContextWrapper.sendBroadcast:377 android.content.ContextWrapper.sendBroadcast:377 com.samsung.android.MtpApplication.MtpReceiver.fin ishSync:606 com.samsung.android.MtpApplication.MtpReceiver$2.h andleMessage:485

W/ContextImpl( 7677): Calling a method in the system process without a qualified user: android.app.ContextImpl.sendBroadcast:1464 android.content.ContextWrapper.sendBroadcast:377 android.content.ContextWrapper.sendBroadcast:377 com.samsung.android.MtpApplication.MtpReceiver.fin ishSync:613 com.samsung.android.MtpApplication.MtpReceiver$2.h andleMessage:485
Quote:
I/SELinux (13275): Function: selinux_android_load_priority [0], There is no sepolicy file.

I/SELinux (13275):

I/SELinux (13275): Function: selinux_android_load_priority [1], There is no sepolicy version file.

I/SELinux (13275):

I/SELinux (13275): Function: selinux_android_load_priority , loading version is VE=SEPF_SM-P900_4.4.2_0004

I/SELinux (13275):

I/SELinux (13275):

I/SELinux (13275): selinux_android_seapp_context_reload: seapp_contexts file is loaded from /seapp_contexts

I/JAM ( 2248): isRunningJackd : stopped...

W/System.err(13275): java.lang.NoSuchFieldException: SYSTEM_UI_FLAG_REMOVE_NAVIGATION

E/JAM ( 5470): print sendControlCommand error: Invalid argument

W/System.err(13275): at java.lang.Class.getField(Class.java:724)

W/System.err(13275): at com.sec.android.gallery3d.util.GalleryFeature.chec kSystemUiVisibility(GalleryFeature.java:1517)

W/System.err(13275): at com.sec.android.gallery3d.util.GalleryFeature.init (GalleryFeature.java:320)

W/System.err(13275): at com.sec.android.gallery3d.app.GalleryAppImpl.getDa taManager(GalleryAppImpl.java:229)

W/System.err(13275): at com.sec.android.gallery3d.provider.GalleryProvider .onCreate(GalleryProvider.java:126)

W/System.err(13275): at android.content.ContentProvider.attachInfo(Content Provider.java:1591)

W/System.err(13275): at android.content.ContentProvider.attachInfo(Content Provider.java:1562)

W/System.err(13275): at android.app.ActivityThread.installProvider(Activit yThread.java:5029)

W/System.err(13275): at android.app.ActivityThread.installContentProviders (ActivityThread.java:4624)

W/System.err(13275): at android.app.ActivityThread.handleBindApplication(A ctivityThread.java:4538)

W/System.err(13275): at android.app.ActivityThread.access$1500(ActivityThr ead.java:164)

W/System.err(13275): at android.app.ActivityThread$H.handleMessage(Activit yThread.java:1318)

W/System.err(13275): at android.os.Handler.dispatchMessage(Handler.java:10 2)

W/System.err(13275): at android.os.Looper.loop(Looper.java:157)

W/System.err(13275): at android.app.ActivityThread.main(ActivityThread.jav a:5341)

W/System.err(13275): at java.lang.reflect.Method.invokeNative(Native Method)

W/System.err(13275): at java.lang.reflect.Method.invoke(Method.java:515)

W/System.err(13275): at com.android.internal.os.ZygoteInit$MethodAndArgsCa ller.run(ZygoteInit.java:1259)

W/System.err(13275): at com.android.internal.os.ZygoteInit.main(ZygoteInit .java:1075)

W/System.err(13275): at dalvik.system.NativeStart.main(Native Method)

E/EnterpriseContainerManager( 2707): ContainerPolicy Service is not yet ready!!!
As a temporary workaround you should be able to transfer files to the sdcard using an external reader. I should be getting mine soon so I can test this out.
Current Phone: Nexus 5 (Android L) | Oppo Find 5 (Omni)

Past Phones: Nexus 4, Samsung Galaxy SIII i9300, HTC One X, Galaxy Note, iPhone 4S, 4, 3G, 3 (Jailbroken), Motorola V360, HTC TyTN
Past Tablets/Devices: Arnova 10G2, Asus EEEPC 900a, IBM/Lenovo Thinkpads
The Following User Says Thank You to bitpushr For This Useful Post: [ Click to Expand ]
 
deathdreams
Old
#9  
Member
Thanks Meter 0
Posts: 36
Join Date: Jul 2007
Is this an issue with all note pro 12.2s? just returned one and ordered another for this issue... Was able to transfer to main memory over WiFi then copy to SD card but transferring to the SD card over WiFi was a 50/50 chance if even that...
 
ashtonsd
Old
#10  
Junior Member - OP
Thanks Meter 2
Posts: 7
Join Date: Feb 2014
I was expecting a lot more reports once the tablet launched in the US but haven't seen too many so far.

It's a real pain but I can live with it. I'm waiting it out for firmware fix for now, but if that doesn't come then it's going back. There is time yet and I love the screen size too much to let it go...

Let us know how you get on with the replacement.

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes