Mural Watchface Brings 500px to Android Wear

On a traditional watch, you can’t really do too much to change its appearance once … more

Android 5.0 Favorite Features, Release November 3rd? – XDA TV

Google Confirms Android 5.0 Lollipop for November 3rd! That and much more … more

Prepare Your Build Machines: Ubuntu 14.10 Utopic Unicorn Now Official

Today is an important day for any and all Linux enthusiasts. One of the … more

Track the Time You Waste on Social Media with Socials Addict

When you use your phone, you often don’t even realize how much time you … more
Post Reply

[MOD]{CM10.1}{CM10.2}{CM11}{AOSP}Working Int2Ext for Xperia 2011 [ART-compatible]

OP nos1609

26th March 2014, 06:48 AM   |  #1  
nos1609's Avatar
OP Senior Member
Flag Moscow
Thanks Meter: 93
 
102 posts
Join Date:Joined: Feb 2009
More
After days of looking for a solution to the problem of every 2011 device I've finally managed to do it!

Many of you wanna enable ART functionnality in 4.4.2 because the device start "flying" with such a pill. So I've managed to modify the Int2Ext v2 script to run it lagless and conserving initial performance.

Prerequesites:
1. You have to make an EXT partition (I've got an EXT4 1 GB partition)
2. Flash the script BEFORE the first boot (like any other package such as gapps).
3. (Optionnal) Reboot once, and enable ART in developement menu.
4. Enjoy!

What it does exactly?
1. Increase the readahead cache for your sd to 4096 kb
2. Transfers /data/app & /data/app-private to the ext partition of the SD
3. Everything that a CronMod-INT2EXT script does

Screenshots



All credits goes to the creator of the original script. Ive simply deleted a line inside


You're welcome for testing.

Small FAQ & corrected verision to avoid signal loss:
Quote:
Originally Posted by nos1609

1. Tested in couple with Vanir/Carbon - unstable under ART, Dalvik recommanded
Tested on PAC working like a charm on both ART & Dalvik

2. To avoid reboots / FCs try flashing ART compatible gapps

3. About the "internal memory waste" Guys, please check the description of what the script is doing and what folders are moved onto EXT-partition. If everything would so simle as that, even ART mode couldn't overcome the laggynes and the lack of performance after moving everything to sdcard. The script is moving ONLY APKs to the EXT-partition. Dalvik, libs etc remains on the 470 Mb NAND to conserve initial performance. But enen that amount of free space is not enough to run ART experience at it full potential. because of very large dalvik-cache size.

4. EXT partition. Just google, XDA contains tons of manuals and tools to create one. If you'd like to simply try ART 512 MB one will be enough, you'll reach the internal NAND limitation. If you want using it in normal mode you can make the partition as large as you like.

5. Concerning the loss of signal, I think there are some lack of time for the device itself to get the new location of the files, so try this new package.

Quote:
Originally Posted by vipinpvarghese

Those who have issue with signal loss after flash this script there is a way out... Just install Link2sd after flashing the script... Open Link2sd, give super user permissions and Link2sd will automatically create scripts and ask you to reboot.... thats is..... you should be able to get signals after reboot.... You can even uninstall Link2Sd after rebooting....

For me it is working in Mike's latest build, PA final build and Pac man latest build....

Last edited by nos1609; 29th August 2014 at 07:49 AM.
The Following 13 Users Say Thank You to nos1609 For This Useful Post: [ View ]
28th March 2014, 02:33 AM   |  #2  
WaterMelon90's Avatar
Senior Member
Flag Perak
Thanks Meter: 87
 
355 posts
Join Date:Joined: Mar 2013
More
If i update the nightly rom. Am i need to re-flash the zip? This worked with Dalvik too right?
30th March 2014, 02:03 PM   |  #3  
nos1609's Avatar
OP Senior Member
Flag Moscow
Thanks Meter: 93
 
102 posts
Join Date:Joined: Feb 2009
More
Quote:
Originally Posted by WaterMelon90

If i update the nightly rom. Am i need to re-flash the zip? This worked with Dalvik too right?

Yes you need to reflash & sure it works with Dalvik
The Following 2 Users Say Thank You to nos1609 For This Useful Post: [ View ]
31st March 2014, 11:52 AM   |  #4  
Member
Flag Hyderabad
Thanks Meter: 9
 
76 posts
Join Date:Joined: May 2011
More
Unhappy
Hello, I really wanted to try this, and partitioned my SD card. Now, i am not able to see the created 1GB ext4 partition. I created that partition with MINITool Partition Wizard. For restoring it, I tried using GParted also but of no use. Out of 7.4 GB, only 6.4 is accessible. Kindly help. And one more thing. Dark Kernel is not even recognizing the SD Card.
5th April 2014, 02:31 PM   |  #5  
WaterMelon90's Avatar
Senior Member
Flag Perak
Thanks Meter: 87
 
355 posts
Join Date:Joined: Mar 2013
More
@nos1609 , I had tried it in C-rom. I flashed it after the installation of C-rom then reboot. However, it can't boot into system. Anyone faced this problem? I had wait for the boot around 15-20 minutes but it stuck.

Can I:
1) Install rom, reboot into system.
2) Reboot into recovery and flash the zip then reboot.??
5th April 2014, 10:58 PM   |  #6  
Member
Flag Aurillac
Thanks Meter: 11
 
84 posts
Join Date:Joined: Nov 2007
Quote:
Originally Posted by WaterMelon90

@nos1609 , I had tried it in C-rom. I flashed it after the installation of C-rom then reboot. However, it can't boot into system. Anyone faced this problem? I had wait for the boot around 15-20 minutes but it stuck.

Can I:
1) Install rom, reboot into system.
2) Reboot into recovery and flash the zip then reboot.??

for me, it's also the only way to boot. nevertheless, i have no signal i tried the 2.1 version but no more success...
15th April 2014, 08:17 AM   |  #7  
mengxaxau's Avatar
Senior Member
Thanks Meter: 13
 
115 posts
Join Date:Joined: Oct 2012
More
work on mike legacy xperia rom?
15th April 2014, 09:17 AM   |  #8  
Senior Member
Thanks Meter: 47
 
150 posts
Join Date:Joined: Jun 2009
Yes it's working like a charm

Wysłane z mojego MT11i przy użyciu Tapatalka
16th April 2014, 08:56 PM   |  #9  
Member
Flag Aurillac
Thanks Meter: 11
 
84 posts
Join Date:Joined: Nov 2007
Quote:
Originally Posted by atomrat

Yes it's working like a charm

Wysłane z mojego MT11i przy użyciu Tapatalka

i'm really surprise because i build my rom from mike's sources and i've no succesd with this mod. if it's really ok for the memory use is ok, i've no signal..., so the phone is unusable
19th April 2014, 10:40 AM   |  #10  
wolvgank's Avatar
Member
Flag SAMARINDA
Thanks Meter: 4
 
46 posts
Join Date:Joined: Aug 2011
More
Question
It's not working on AOSB, XUK, and C-ROM.. i tried it in the first boot after install new rom and i got a bootloop,, 30 minutes and still at boot animation..
anyone know how to make it works? really wanted to use it in 4.4 rom.. is it because the kernel? because i using the kernel provide in the rom.
sorry for the noob question.

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in Xperia Neo V Android Development by ThreadRank