Post Reply

[Q] Need Help, HTC One XL Australia, recovery wont load SD Card

OP meesotrev

27th March 2014, 12:24 PM   |  #1  
meesotrev's Avatar
OP Member
Thanks Meter: 13
 
51 posts
Join Date:Joined: Oct 2012
More
HTC One XL stuck in boot loop, recovery will no load System, or SD Card, so i cannot retrieve my restores. have fastboot usb capabilities still, Does anyone know how to resolve this problem?
27th March 2014, 01:07 PM   |  #2  
timmaaa's Avatar
Recognized Contributor
Flag Melbourne
Thanks Meter: 6,821
 
14,168 posts
Join Date:Joined: Jun 2011
Donate to Me
More
More information required. Please state your bootloader details, current ROM and kernel, current recovery, and a detailed description of the effects that lead to this situation.

Sent from my Evita
The Following User Says Thank You to timmaaa For This Useful Post: [ View ]
27th March 2014, 01:33 PM   |  #3  
meesotrev's Avatar
OP Member
Thanks Meter: 13
 
51 posts
Join Date:Joined: Oct 2012
More
HBOOT 2.15.0000 --- S-Off & Unlocked
Radio 1.31a.32.45.16_2
ROM Viper xl
Recovery TWRP 2.5

I flashed oxp_elitekernel_130413, which i now realize was wrong, which led to the boot loop, So i tried to flash back to previous Kernal but it cam up with error device not found.
So i tried to access recovery and it just kept bootlooping. So i then flashed recovery again, now i have recovery but sd and system won't load.
27th March 2014, 01:45 PM   |  #4  
timmaaa's Avatar
Recognized Contributor
Flag Melbourne
Thanks Meter: 6,821
 
14,168 posts
Join Date:Joined: Jun 2011
Donate to Me
More
You need to update your recovery, TWRP 2.5 is full of bugs. Get 2.6 or above from here and flash it using fastboot. Out of interest, how exactly did you try to flash back to your original kernel? You said you got a "device not found" message which doesn't seem right.

I'm not sure where you found that oxp_elitekernel but it certainly wasn't from within our device forum. You need to make sure you don't stray into other forums, nothing outside of our forum is compatible with our device, you're actually very lucky you didn't brick your phone. Our device forum main page is here:

http://forum.xda-developers.com/one-x-att

Bookmark that page and make sure you stay within it.

Sent from my Evita
The Following User Says Thank You to timmaaa For This Useful Post: [ View ]
28th March 2014, 09:57 PM   |  #5  
meesotrev's Avatar
OP Member
Thanks Meter: 13
 
51 posts
Join Date:Joined: Oct 2012
More
I think i have bricked it....lol. Nothing is loading.
28th March 2014, 11:33 PM   |  #6  
meesotrev's Avatar
OP Member
Thanks Meter: 13
 
51 posts
Join Date:Joined: Oct 2012
More
I flashed in fastboot cmd prompt. Because the sdcard isn't loading anymore it can't write or read the phone. so i don't care if i have to format the whole dam thing, i just dont know how to do it, without risking what little access i have left.
29th March 2014, 01:51 AM   |  #7  
meesotrev's Avatar
OP Member
Thanks Meter: 13
 
51 posts
Join Date:Joined: Oct 2012
More
All Good, i worked it out in the end :)
Thanks to all who gave me feedback but i ended up figuring it out. If anyone has that problem in the future, all you have to do is format system and sdcard, (yeah i know you loose everything, but thats better than losing the whole phone.) then mount sdcard in TWRP, and place on the zip files for your roms, un-mount the partitions, then install the zips. If your S-ON, i guess you would flash boot image (unless S-ON stops you from wiping those partitions, in which case your screwed.) . But if you're S-OFF Just install and your back.
29th March 2014, 02:27 AM   |  #8  
timmaaa's Avatar
Recognized Contributor
Flag Melbourne
Thanks Meter: 6,821
 
14,168 posts
Join Date:Joined: Jun 2011
Donate to Me
More
S-on doesn't stop you from wiping any partitions. Good to see you worked it out though. You might benefit from reading the Evita FAQ and How-To Guide For Beginners threads in my signature.

Sent from my Evita
The Following User Says Thank You to timmaaa For This Useful Post: [ View ]
29th March 2014, 06:56 AM   |  #9  
meesotrev's Avatar
OP Member
Thanks Meter: 13
 
51 posts
Join Date:Joined: Oct 2012
More
I am not really a beginner, started hacking my phones 3.5 years ago. Been in love with it ever since, I was at the end of three nights with no sleep, and I wasn't thinking very clearly, and so I failed to notice that I had strayed into just the one x+ forum, and flashed the wrong kernal, very nearly bricking it in the process. Rookie mistake, one I'm not likely to repeat. Scared the crap outa me...lol.
Thanks for your help once again bud.

Sent from my HTC One XL using xda app-developers app
29th March 2014, 10:00 AM   |  #10  
timmaaa's Avatar
Recognized Contributor
Flag Melbourne
Thanks Meter: 6,821
 
14,168 posts
Join Date:Joined: Jun 2011
Donate to Me
More
All good, no offence intended.

Sent from my Evita

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools
Display Modes


Top Threads in One X Q&A, Help & Troubleshooting by ThreadRank