Post Reply

[Q] HTC Battery not charging

OP krunalking

28th March 2014, 07:27 AM   |  #1  
OP Junior Member
Thanks Meter: 0
 
3 posts
Join Date:Joined: Dec 2012
hi all,

my phone got bathed in water ... so went for the repair now everything is working fine except the battery not getting charged.
Tht data cable is working fine - all functions like USB storage , internet pass through are working ..
but when charging it just charges for 2-3 seconds and then an symbol comes where there is battery drawn with the red exclamation mark on top right ...
bought a new battery still the same problem , flashed the rom, took it to repair shop but no results ???

any updates or suggestion will be of great help... thanks

update - when i plug in my charger is shows charging in battery status in settings for 2-3 secinds and then is shows discharging .
but when not charger connected it shows not charging

any pointers will be helpfull ???????
Last edited by krunalking; 28th March 2014 at 10:53 AM.
1st April 2014, 06:00 AM   |  #2  
OP Junior Member
Thanks Meter: 0
 
3 posts
Join Date:Joined: Dec 2012
Quote:
Originally Posted by krunalking

hi all,

my phone got bathed in water ... so went for the repair now everything is working fine except the battery not getting charged.
Tht data cable is working fine - all functions like USB storage , internet pass through are working ..
but when charging it just charges for 2-3 seconds and then an symbol comes where there is battery drawn with the red exclamation mark on top right ...
bought a new battery still the same problem , flashed the rom, took it to repair shop but no results ???

any updates or suggestion will be of great help... thanks

update - when i plug in my charger is shows charging in battery status in settings for 2-3 secinds and then is shows discharging .
but when not charger connected it shows not charging

any pointers will be helpfull ???????

Any one please help guys
6th April 2014, 11:01 PM   |  #3  
Account currently disabled
Flag Sialkot
Thanks Meter: 79
 
296 posts
Join Date:Joined: Jan 2013
More
Quote:
Originally Posted by krunalking

hi all,

my phone got bathed in water ... so went for the repair now everything is working fine except the battery not getting charged.
Tht data cable is working fine - all functions like USB storage , internet pass through are working ..
but when charging it just charges for 2-3 seconds and then an symbol comes where there is battery drawn with the red exclamation mark on top right ...
bought a new battery still the same problem , flashed the rom, took it to repair shop but no results ???

any updates or suggestion will be of great help... thanks

update - when i plug in my charger is shows charging in battery status in settings for 2-3 secinds and then is shows discharging .
but when not charger connected it shows not charging

any pointers will be helpfull ???????

Your Phone's recharging IC gone *****3 up

Idk why the service centre didn't repaired it!

Well try repairing it from a professional who knows this repairing thingy!
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in Pico (Explorer) Q&A, Help & Troubleshooting by ThreadRank