Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,771,646 Members 46,158 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Google Play Error 927.. DRIVING ME NUTS

Tip us?
 
Guitarfreak26
Old
#1  
Guitarfreak26's Avatar
Senior Member - OP
Thanks Meter 80
Posts: 1,885
Join Date: Nov 2009
Location: Birmingham, UK
Question [Q] Google Play Error 927.. DRIVING ME NUTS

Hi Guys

This issue has been going on for 4 months now, i can rarely download or update an app on the play store because it gives me error 927. Only the odd update or install will work and this happens over both Wifi and Celluar

I have several android devices, 2013 Nexus 7, SGS4, Optimus G Pro, Xperia Z Tablet, Note 1 and the same happens on every single device. If i use a different account after resetting the phone i dont have the issue but the problem is i have purchased 100's of applications on my normal account so i cant afford to use another one.

I have tried wiping caches,factory resets and nothing seems to work. I contacted google and they dont have any idea either!!

I was hoping someone here had a similar issue?

Thanks
Samsung Mobiler
O2 Guru

My Devices:
Galaxy Note 3 - Temasek Rom - Zerolemon Battery
Galaxy Tab Pro 8.4 - Crpalmer CM11
 
TheArc
Old
#2  
TheArc's Avatar
Recognized Themer
Thanks Meter 1716
Posts: 2,160
Join Date: Jan 2012
Location: Auckland City
I've had a similar error occur for me. Whenever I install/update an app where on WiFi or Mobile Network it would send off and error.

It was a constant annoyance for me.

It stopped when I did this, I headed into Manage Apps>All Apps, and opened Google Play Store, cleared data and cache. And did the same to Google Play Services, I proceeded by rebooting the device next thing I know, my phone starts updating apps .

I hope this'll work for you.

Cake...
iOS7 Kik Messenger | Svelte UI CM11 Theme | Active Launcher
The Following User Says Thank You to TheArc For This Useful Post: [ Click to Expand ]
 
Guitarfreak26
Old
#3  
Guitarfreak26's Avatar
Senior Member - OP
Thanks Meter 80
Posts: 1,885
Join Date: Nov 2009
Location: Birmingham, UK
Quote:
Originally Posted by krishneelg3 View Post
I've had a similar error occur for me. Whenever I install/update an app where on WiFi or Mobile Network it would send off and error.

It was a constant annoyance for me.

It stopped when I did this, I headed into Manage Apps>All Apps, and opened Google Play Store, cleared data and cache. And did the same to Google Play Services, I proceeded by rebooting the device next thing I know, my phone starts updating apps .

I hope this'll work for you.

Cake...
Doesnt make no difference on mine
Samsung Mobiler
O2 Guru

My Devices:
Galaxy Note 3 - Temasek Rom - Zerolemon Battery
Galaxy Tab Pro 8.4 - Crpalmer CM11
 
Rostislav.89
Old
#4  
Rostislav.89's Avatar
Junior Member
Thanks Meter 5
Posts: 9
Join Date: Feb 2013
Location: Ivano-Frankovsk
Hello!
 
TheArc
Old
#5  
TheArc's Avatar
Recognized Themer
Thanks Meter 1716
Posts: 2,160
Join Date: Jan 2012
Location: Auckland City
Contact Google, it is their right to investigate this problem, if you've payed that much money for apps, one certainly wouldn't move to another account, tell them about this problem.

Cake...
iOS7 Kik Messenger | Svelte UI CM11 Theme | Active Launcher
 
Guitarfreak26
Old
#6  
Guitarfreak26's Avatar
Senior Member - OP
Thanks Meter 80
Posts: 1,885
Join Date: Nov 2009
Location: Birmingham, UK
Yeah they suggested I use another account or wipe the cache. I've tried contacting on 3 different occasions. Each one has been a waste of time

Sent from my GT-I9505 using Tapatalk 4
Samsung Mobiler
O2 Guru

My Devices:
Galaxy Note 3 - Temasek Rom - Zerolemon Battery
Galaxy Tab Pro 8.4 - Crpalmer CM11
 
TheArc
Old
#7  
TheArc's Avatar
Recognized Themer
Thanks Meter 1716
Posts: 2,160
Join Date: Jan 2012
Location: Auckland City
Worst support at its best, try going into play store, clear the data for store and service, and go back to play store and go on uninstall updates.

Cake...
iOS7 Kik Messenger | Svelte UI CM11 Theme | Active Launcher
 
aheeejd
Old
#8  
aheeejd's Avatar
Senior Member
Thanks Meter 1174
Posts: 2,722
Join Date: Jan 2012
Location: off the coast o the kontiki!
Just so people are aware, this is still happening, I'm writing this today because things were going ok for a while, but, the play store got updated again, to 4.6.17. It happens on my Nexus 5, HTC Evo 4 G, & galaxy tab 8.9, it happens on different versions of play store. If I create new account, play store works great. I contacted Google as well, basically got pissed cause they were completely useless. Right from beginning I was honest, & told them I was rooted. They basically blamed it on that. Anyways, Google play suck$

Sent from my Nexus 5 using Xparent Red Tapatalk 2
 
Guitarfreak26
Old
#9  
Guitarfreak26's Avatar
Senior Member - OP
Thanks Meter 80
Posts: 1,885
Join Date: Nov 2009
Location: Birmingham, UK
Yeah it still happens to me too. Exactly the same issue as your having but only on my main account.

If I keep pressing install it will eventually work but sometimes it takes around 20 attempts.. Google gave me no support either

Sent from my SM-N9005 using Tapatalk
Samsung Mobiler
O2 Guru

My Devices:
Galaxy Note 3 - Temasek Rom - Zerolemon Battery
Galaxy Tab Pro 8.4 - Crpalmer CM11
 
TheArc
Old
#10  
TheArc's Avatar
Recognized Themer
Thanks Meter 1716
Posts: 2,160
Join Date: Jan 2012
Location: Auckland City
Quote:
Originally Posted by Guitarfreak26 View Post
Yeah it still happens to me too. Exactly the same issue as your having but only on my main account.

If I keep pressing install it will eventually work but sometimes it takes around 20 attempts.. Google gave me no support either

Sent from my SM-N9005 using Tapatalk
If you're rooted go into system>etc and look for hosts.

Open it and delete exert line except the "local" one the local one will also contain numbers in the line. Do not delete them.

Restart your device, and try.

Sent from my Nexus 5 using Tapatalk
iOS7 Kik Messenger | Svelte UI CM11 Theme | Active Launcher

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes