Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

Huge battery drain with android OS wakelock

OP Asadroid

17th July 2013, 05:09 PM   |  #1  
OP Senior Member
Flag Panama
Thanks Meter: 17
 
287 posts
Join Date:Joined: Feb 2011
More
Im getting a huge drain on my phone because of "android OS" on the battery stats and BSS says the major wakelocks are ril-fd , l2_hsic, radio interface, umts_ipc0

screen shots later

this is my second S4 i9500 and im about to say, screw samsung sell the phone and idk, get something that works
17th July 2013, 05:52 PM   |  #2  
Member
Flag Tien Giang
Thanks Meter: 20
 
84 posts
Join Date:Joined: Oct 2006
More
Quote:
Originally Posted by Asadroid

Im getting a huge drain on my phone because of "android OS" on the battery stats and BSS says the major wakelocks are ril-fd , l2_hsic, radio interface, umts_ipc0

screen shots later

this is my second S4 i9500 and im about to say, screw samsung sell the phone and idk, get something that works

I get this problem, too. And it seems like a common Android 4.2.2 problem. The Android OS on 4.2.2 using battery like 10 times it did on my S3, 4.1.2
17th July 2013, 08:57 PM   |  #3  
OP Senior Member
Flag Panama
Thanks Meter: 17
 
287 posts
Join Date:Joined: Feb 2011
More
Quote:
Originally Posted by nudawa

I get this problem, too. And it seems like a common Android 4.2.2 problem. The Android OS on 4.2.2 using battery like 10 times it did on my S3, 4.1.2

i will try to update the phone but this wasnt that bad when i got my second copy... something is wrong on this firmwares
17th July 2013, 09:33 PM   |  #4  
Member
Thanks Meter: 7
 
30 posts
Join Date:Joined: Aug 2009
Do you have Wi-Fi enabled? Apparently this is a well-known problem on certain networks with lots of broadcast/multicast packets (like DropBox LAN sync discovery). I've been trying to figure out a way to filter those out, like this: https://code.google.com/p/android/is...etail?id=56471
Last edited by arip; 17th July 2013 at 09:39 PM.
17th July 2013, 10:02 PM   |  #5  
OP Senior Member
Flag Panama
Thanks Meter: 17
 
287 posts
Join Date:Joined: Feb 2011
More
Quote:
Originally Posted by arip

Do you have Wi-Fi enabled? Apparently this is a well-known problem on certain networks with lots of broadcast/multicast packets (like DropBox LAN sync discovery). I've been trying to figure out a way to filter those out, like this: https://code.google.com/p/android/is...etail?id=56471

on my phone everything is off, sync is off, S features Off, maps off, i only have data active, whatsapp and line are the only services on as far i know, and using the stock browser not even chrome.

its... annoying

i9500 btw
17th July 2013, 10:24 PM   |  #6  
About these:
ril-fd , l2_hsic, radio interface, umts_ipc0

ril.fd & umts_ipc0: Wlan advanced konfiguration: Keep Wlan on during sleep - off & open Data Usage, press Menu-button: Restrict background data
radio interface: Do you use the radio? If you don't get Link to SD and freeze the app.
l2_hsic:
Quote:
Originally Posted by Braxos

Main reason is unplugging the charger without unlocking lockscreen (swipe to unlock) or unplugging when screen is black.

Last edited by Nebelwolfi; 17th July 2013 at 10:29 PM. Reason: Forgot l2_hsic
6th October 2013, 03:11 AM   |  #7  
Senior Member
Thanks Meter: 17
 
118 posts
Join Date:Joined: Jun 2012
Do you ever figure this out? It's killing my battery on my note 3....
6th April 2014, 05:56 PM   |  #8  
Senior Member
Thanks Meter: 8
 
194 posts
Join Date:Joined: Mar 2005
Quote:
Originally Posted by Twmade

Do you ever figure this out? It's killing my battery on my note 3....

Same here on my S4 - I seem to have noticed it after it upgraded to KitKat?
7th April 2014, 12:04 AM   |  #9  
Senior Member
Thanks Meter: 99
 
615 posts
Join Date:Joined: Jun 2009
More
Quote:
Originally Posted by Aitch

Same here on my S4 - I seem to have noticed it after it upgraded to KitKat?

+1, no deep sleep state.

I have kk since published, but this issue only since a pair of weeks ago without any flashing or app installing... Tried releasing my stock TTT fw and last India fw without wipe data, nothing... Last thing i left to try is wipe data, format every thing and refreshing fw when i get some time...

Enviado desde mi GT-I9500 usando Tapatalk 2
9th April 2014, 06:01 AM   |  #10  
Senior Member
Thanks Meter: 99
 
615 posts
Join Date:Joined: Jun 2009
More
Quote:
Originally Posted by jaswinky

+1, no deep sleep state.

I have kk since published, but this issue only since a pair of weeks ago without any flashing or app installing... Tried releasing my stock TTT fw and last India fw without wipe data, nothing... Last thing i left to try is wipe data, format every thing and refreshing fw when i get some time...

Enviado desde mi GT-I9500 usando Tapatalk 2

I think i fixed it for me with Perseus kernel. Check my post here:

[Q] What is l2_hsic kernel wakelock and I9500 not entering deep sleep
http://forum.xda-developers.com/show...php?p=51758966


Enviado desde mi GT-P7510 usando Tapatalk 2

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes