Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,783,072 Members 45,019 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Wifi slow, 3g fast, any ideas why?

Tip us?
 
fredkadet
Old
(Last edited by fredkadet; 26th February 2014 at 08:54 AM.) Reason: clarify
#1  
Junior Member - OP
Thanks Meter 1
Posts: 11
Join Date: Nov 2009
Question [Q] Wifi slow, 3g fast, any ideas why?

hi all,

Something has been bothering me for a while with my p6800, when connected to wifi my connection intermittently slows down to a crawl or even times out, taking forever to load a webpage. No problems on 3g though... My wifi connection is not disconnecting or anything, full bars all the way.

Anybody know why and how I can fix this, as annoying is an understatement

Thanks!

Ps. using 300n router, not a congested channel. No problems with wifi on notebook or other devices. On Android 4.1.2.
 
Arobase40
Old
#2  
Senior Member
Thanks Meter 118
Posts: 771
Join Date: Nov 2010
Quote:
Originally Posted by fredkadet View Post
hi all,

Something has been bothering me for a while with my p6800, when connected to wifi my connection intermittently slows down to a crawl or even times out, taking forever to load a webpage. No problems on 3g though... My wifi connection is not disconnecting or anything, full bars all the way.

Anybody know why and how I can fix this, as annoying is an understatement

Thanks!

Ps. using 300n router, not a congested channel. No problems with wifi on notebook or other devices. On Android 4.1.2.
What are you using WEP, WPA, WPA2,... ??? Stock or custom ROMs ???

As last resort, do a full factory reset...
 
fredkadet
Old
#3  
Junior Member - OP
Thanks Meter 1
Posts: 11
Join Date: Nov 2009
Hi Arobase,

Thanks for your reply, had just about given up on this one.

I'm on 4.1.2 stock md3 and using WPA2 encryption. Don't think it matters though because I've had these problems from the get go, on stock ROM when just bought and on various Wifi encryptions (random browser timeouts, no Wifi connection drop though...). Can't really see a pattern, sometimes my wifi will work flawlessly, other times it just refuses...

Was wondering wether others had a similar issue. If you've got any ideas, do please let me know. Tbanks again!
 
Arobase40
Old
#4  
Senior Member
Thanks Meter 118
Posts: 771
Join Date: Nov 2010
Quote:
Originally Posted by fredkadet View Post
Hi Arobase,

Thanks for your reply, had just about given up on this one.

I'm on 4.1.2 stock md3 and using WPA2 encryption. Don't think it matters though because I've had these problems from the get go, on stock ROM when just bought and on various Wifi encryptions (random browser timeouts, no Wifi connection drop though...). Can't really see a pattern, sometimes my wifi will work flawlessly, other times it just refuses...

Was wondering wether others had a similar issue. If you've got any ideas, do please let me know. Tbanks again!
Do change your router settings to 144Mbps mode instead of 300Mbps...
The Following User Says Thank You to Arobase40 For This Useful Post: [ Click to Expand ]
Tags
connection, slow, wifi
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes