Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,729,823 Members 51,707 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Problems with Viper Rom

Tip us?
 
Martin_Weterholt
Old
(Last edited by Martin_Weterholt; 10th March 2014 at 02:38 PM.)
#1  
Junior Member - OP
Thanks Meter 1
Posts: 5
Join Date: Mar 2014
Default [Q] Problems with Viper Rom

Hello,

i'm having a lot of trouble with the viper made rom ( http://forum.xda-developers.com/show....php?t=2667758). I'm new here, so i cannot post it there.

My problems began when i try to install the updates. I have installed the original rom version 3.0.0. i get the OTA message, but when i try to install it in recovery, the phone can't mount the sd card, and the installation doesn't continu. I tried to do it manually (using the download link i found in one of the posts) and that seemed to work.

Then i got another OTA notification, to upgrade to version 3.1.0, but when i tried to boot after the installation, i couldn't enter my sim pincode, and when i reboot, the phone keeps looping. I have to install the original rom twice (once with and one time without wiping) before the ROM boots normally.

What am i doing wrong?

i'm on Hboot 1.25 and radio:1.15.50.05.29
I'm S-on (RL)
 
Martin_Weterholt
Old
#2  
Junior Member - OP
Thanks Meter 1
Posts: 5
Join Date: Mar 2014
It seems that viper made a fll rom, with the updates included.
 
fidodaj
Old
#3  
Junior Member
Thanks Meter 0
Posts: 3
Join Date: Apr 2014
Default Wrong Hboot?

Quote:
Originally Posted by Martin_Weterholt View Post
Hello,

What am i doing wrong?

i'm on Hboot 1.25 and radio:1.15.50.05.29
I'm S-on (RL)
I'm not sure but i think it starts with your Hboot, maybe one of the older members can verify, but according to the rom it requires Hboot version 2.15 or 2.16.

I am in the process of updating my Hboot by downloading and flashing the RUU as well as achieving S-OFF status
 
LS.xD
Old
#4  
LS.xD's Avatar
Senior Member
Thanks Meter 585
Posts: 1,854
Join Date: Nov 2013
Location: Lübeck

 
DONATE TO ME
Quote:
Originally Posted by fidodaj View Post
I'm not sure but i think it starts with your Hboot, maybe one of the older members can verify, but according to the rom it requires Hboot version 2.15 or 2.16.

I am in the process of updating my Hboot by downloading and flashing the RUU as well as achieving S-OFF status
You need to update hboot first

2.15 is most compatible i suppose
HTC One S @ PAC-man 4.4.2 [ALPHA1] [12/5/2014] + IceCode Kernel v4.0 // HBoot 2.15 - unlocked BL - S-OFF - NO "tampered & warning text" // TWRP mod 2.7.0.8

Samsung Galaxy W @ ParanoidAndroid 4.3 [BETA3] [6/5/2014] + KhaN Kernel v2.0 // Base: I8150XXLMI // PhilZ CWM 6.01.4

"REVIVED" HTC Wildfire S @ CyanogenMod 11(AWESOME!!!) [6/5/2014] //HBoot 1.09 - unlocked BL // TWRP 2.7.0.0


It won't hurt you to press "thanks" if me or someone other helped you...
 
fidodaj
Old
#5  
Junior Member
Thanks Meter 0
Posts: 3
Join Date: Apr 2014
Quote:
Originally Posted by LS.xD View Post
You need to update hboot first

2.15 is most compatible i suppose
Question. Is there a way for me to upgrade the hboot without the ruu wiping everything? Or will I just have to make a backup. I plan to go s-off before upgrading the hboot.
 
LS.xD
Old
(Last edited by LS.xD; 2nd April 2014 at 03:18 AM.)
#6  
LS.xD's Avatar
Senior Member
Thanks Meter 585
Posts: 1,854
Join Date: Nov 2013
Location: Lübeck

 
DONATE TO ME
Quote:
Originally Posted by fidodaj View Post
Question. Is there a way for me to upgrade the hboot without the ruu wiping everything? Or will I just have to make a backup. I plan to go s-off before upgrading the hboot.
If you're S-OFF ist possible I think
HTC One S @ PAC-man 4.4.2 [ALPHA1] [12/5/2014] + IceCode Kernel v4.0 // HBoot 2.15 - unlocked BL - S-OFF - NO "tampered & warning text" // TWRP mod 2.7.0.8

Samsung Galaxy W @ ParanoidAndroid 4.3 [BETA3] [6/5/2014] + KhaN Kernel v2.0 // Base: I8150XXLMI // PhilZ CWM 6.01.4

"REVIVED" HTC Wildfire S @ CyanogenMod 11(AWESOME!!!) [6/5/2014] //HBoot 1.09 - unlocked BL // TWRP 2.7.0.0


It won't hurt you to press "thanks" if me or someone other helped you...
 
Rapier
Old
(Last edited by Rapier; 2nd April 2014 at 07:21 AM.)
#7  
Rapier's Avatar
Recognized Contributor
Thanks Meter 1598
Posts: 3,455
Join Date: Jun 2008
Location: Bucharest

 
DONATE TO ME
No, you don't need to update the hboot. I am on 1.06 and Viper works fine...in fact any ROM works fine for me but that's another story. The updated firmware (2.13 or 2.15) is required only for Android 4.4.x KitKat due to a check present in the updater-script. There's no such check nor requirement for previous Android versions and Viper 3.x is based on Android 4.2.2

The problems first could come from not being S-Off...this makes impossible to flash the kernel from recovery so any OTA that has a kernel is not flashed properly. I remember that 3.1.0 has also a full ROM ZIP, maybe is good if you flash that one from recovery and flash the kernel after that in fastboot. Also it could matter the recovery you're using, I would recommend latest TWRP

Sent from nowhere over the air..
Don't force it...use a bigger hammer!

HTC One S - AOSPA Legacy 4+ / CandyKat
HTC Desire S - IceColdSandwich
HTC Legend - CyanogenMod V7.1.0 (sold)
 
fidodaj
Old
#8  
Junior Member
Thanks Meter 0
Posts: 3
Join Date: Apr 2014
Quote:
Originally Posted by Rapier View Post
No, you don't need to update the hboot. I am on 1.06 and Viper works fine...in fact any ROM works fine for me but that's another story. The updated firmware (2.13 or 2.15) is required only for Android 4.4.x KitKat due to a check present in the updater-script. There's no such check nor requirement for previous Android versions and Viper 3.x is based on Android 4.2.2

..
In the viper rom forum post it says ROM firmware required hboot 2.15/2.16.. Am I to j just ignore tha? Or is it that it is only required that hboot (2.15/2.16) if you are s-on and s-off can do whatever you like? Lol
 
LS.xD
Old
#9  
LS.xD's Avatar
Senior Member
Thanks Meter 585
Posts: 1,854
Join Date: Nov 2013
Location: Lübeck

 
DONATE TO ME
You need hboot 2.16 for Radio 1.20 :P

And to Flash hboot 2.16 you will need S-OFF

Sent from my loved HTC One S using (most time buggy) Tapatalk
HTC One S @ PAC-man 4.4.2 [ALPHA1] [12/5/2014] + IceCode Kernel v4.0 // HBoot 2.15 - unlocked BL - S-OFF - NO "tampered & warning text" // TWRP mod 2.7.0.8

Samsung Galaxy W @ ParanoidAndroid 4.3 [BETA3] [6/5/2014] + KhaN Kernel v2.0 // Base: I8150XXLMI // PhilZ CWM 6.01.4

"REVIVED" HTC Wildfire S @ CyanogenMod 11(AWESOME!!!) [6/5/2014] //HBoot 1.09 - unlocked BL // TWRP 2.7.0.0


It won't hurt you to press "thanks" if me or someone other helped you...
 
robdidu
Old
#10  
Junior Member
Thanks Meter 2
Posts: 6
Join Date: Nov 2012
Location: Berlin
Quote:
Originally Posted by LS.xD View Post
You need hboot 2.16 for Radio 1.20 :P

And to Flash hboot 2.16 you will need S-OFF

Sent from my loved HTC One S using (most time buggy) Tapatalk
Actually I'm on hboot 2.15 with Radio 1.20.XX

I know this doesn't help... just saying..

To contribute smth. To get the most out of the Viper 3 Rom, everyone should upgrade their Radio to 1.20.XX. And this is actually why you need to S-OFF.

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


TRENDING IN THEMER...