Post Reply

[Q] Video Player for MKV (720p)

OP Alias84270

11th November 2013, 09:52 AM   |  #1  
Alias84270's Avatar
OP Junior Member
Flag Aix en Provence
Thanks Meter: 0
 
23 posts
Join Date:Joined: Feb 2013
More
Hi everyone,

Well, i'm very happy of my surface RT, but i have one big problem : read my favourites series on my surface.

At the moment, i use "press play video" and my movies freeze all the time...

I tried to read the same movie from the sd card or from the internal storage, and the result is the same : freeze.

The result is the same with all my mkv.

does anyone have a solution?

thank's
11th November 2013, 04:05 PM   |  #2  
cx1's Avatar
Senior Member
Thanks Meter: 45
 
208 posts
Join Date:Joined: Aug 2007
I haven't heard of any MKV player that work with any reliability. VLC player is in the pipeline but looking like vaporware at the moment.

I would suggest conversion or streaming them via Plex or similar that can transcode.
12th November 2013, 08:38 PM   |  #3  
BIade's Avatar
Senior Member
Flag Cologne
Thanks Meter: 66
 
222 posts
Join Date:Joined: Apr 2013
More
Quote:
Originally Posted by Alias84270

Hi everyone,

Well, i'm very happy of my surface RT, but i have one big problem : read my favourites series on my surface.

At the moment, i use "press play video" and my movies freeze all the time...

I tried to read the same movie from the sd card or from the internal storage, and the result is the same : freeze.

The result is the same with all my mkv.

does anyone have a solution?

thank's

HD.Mobile Media Player
The Following User Says Thank You to BIade For This Useful Post: [ View ]
13th November 2013, 02:28 PM   |  #4  
cx1's Avatar
Senior Member
Thanks Meter: 45
 
208 posts
Join Date:Joined: Aug 2007
Quote:
Originally Posted by BIade

HD.Mobile Media Player

mobile.HD media player? Not seeing the reverse in the store.
The Following User Says Thank You to cx1 For This Useful Post: [ View ]
14th November 2013, 07:38 AM   |  #5  
Alias84270's Avatar
OP Junior Member
Flag Aix en Provence
Thanks Meter: 0
 
23 posts
Join Date:Joined: Feb 2013
More
Quote:
Originally Posted by BIade

HD.Mobile Media Player

Thank's a lot!

I tried and it works fine, and now i buy it !!!

Now my Surface RT ROXX
21st May 2014, 07:31 PM   |  #6  
Senior Member
Thanks Meter: 10
 
127 posts
Join Date:Joined: May 2010
Is that still working for you OK? I tried the stock Xbox video app and mobile.HD media player and both have poor audio/video sync. The video trails behind the audio by a few tenths of a second, despite the same files playing back fine on Windows 7 WMP, my Nexus 7 2nd gen, and my Roku.

Videos synced and played back through Plex are fine, and Netflix is fine, too, but I can't seem to find a basic video player app that works correctly.
22nd May 2014, 09:58 AM   |  #7  
Junior Member
Thanks Meter: 0
 
5 posts
Join Date:Joined: Oct 2010
Quote:
Originally Posted by reggie14

Is that still working for you OK? I tried the stock Xbox video app and mobile.HD media player and both have poor audio/video sync. The video trails behind the audio by a few tenths of a second, despite the same files playing back fine on Windows 7 WMP, my Nexus 7 2nd gen, and my Roku.

Videos synced and played back through Plex are fine, and Netflix is fine, too, but I can't seem to find a basic video player app that works correctly.

Hi

FilesFolders Pro works great for me.

gkarg
23rd May 2014, 05:30 AM   |  #8  
Senior Member
Thanks Meter: 10
 
127 posts
Join Date:Joined: May 2010
Quote:
Originally Posted by gkarg

Hi

FilesFolders Pro works great for me.

gkarg

Hmmm, no luck for me. I get the same audio/video sync problems.

What do you use to encode your videos? I use a slightly modified version of the High Profile preset in Handbrake. All the relevant video stuff is unchanged from the preset, which the exception being that I limit the resolution width to 1280. I'm going to try encoding something using the baseline profile just to see what happens.
23rd May 2014, 11:43 PM   |  #9  
Junior Member
Thanks Meter: 0
 
4 posts
Join Date:Joined: Jul 2008
Since there is still no VLC, i'm using power media player (power dvd).



Streaming 1080p from My NAS Works fine, besides some stuttering at the first few seconds .



Sent from my Surface with Windows RT using Tapatalk
24th May 2014, 05:15 AM   |  #10  
Senior Member
Thanks Meter: 10
 
127 posts
Join Date:Joined: May 2010
Quote:
Originally Posted by Jorgkuiper

Since there is still no VLC, i'm using power media player (power dvd).



Streaming 1080p from My NAS Works fine, besides some stuttering at the first few seconds .

Thanks!

The key seems to be the encoding settings. I tried re-encoding one movie using the H.264 baseline profile. The resulting file was about 50% bigger, but plays without any issue. I'd hate to have to use such non-optimized settings, though.

Are you playing back full blu-ray rips (e.g., rips using MakeMKV)? Or, if they're re-encoded, do you know what the encoding settings were? Otherwise I guess I'll just have to play around with some different encoding schemes, adding more H.264 high-profile features until the A/V sync breaks.

Update: Anything about baseline profile gives me audio/video sync problems. That's really disappointing, given that the Tegra3 should have no problem with high-profile content.
Last edited by reggie14; 25th May 2014 at 05:16 AM. Reason: Added results

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes