Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,785,052 Members 45,530 Now Online
XDA Developers Android and Mobile Development Forum

[Q] failed to mount /sdcard error

Tip us?
 
xomixxonix
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 4
Join Date: Dec 2010
Question [Q] failed to mount /sdcard error

hi guys

this is my first post on this kickass site and i hope that someone can help me with this rather strange error
as the subject of topic says , i get this error whenever i boot my friends sgs into recovery as normal booting goes on loop forever.
this is the error i get in the recovery of stock I9000XXJVU:
----------------------------------------------------------------------------------------
--Copying media files...
E:failed to mount /sdcard (file exists)
E:copy_dbdata_media:can't mount /sdcard
your storage not prepared yet,please use UI menu for format and reboot actions
media files copy failed

# MANUAL MODE #

-- Applying Multi-CSC...
Installing Multi-CSC
Can't access to '/system/csc/TRA/system/'.
Successfully applied multi-CSC
----------------------------------------------------------------------------------------
what happened is this:
my friend had a sgs and i wanted to flash it with cyanogenmod 10 (android 4.1)
the stock firmware was 2.2 iirc.
i just rooted the stock and flashed the 4.1
it went ok but i saw the mounting error back then sometime that i rebooted the device with 4.1 on it but didn't get that error all the time and it would boot just fine.

then the error popuped more and more.
so i decided to flash stock 2.3.6 ,rooting it and finaly go back to 4.1.
after i flashed the device using I9000XXJVU it goes on loop.
recovery and downloading mode works.but the recovery give me that error i said above.

i guess a hardware issue but i don't know for sure

i'm lost here
help me plz

Thanks in advance
 
Donovan662
Old
#2  
Senior Member
Thanks Meter 56
Posts: 206
Join Date: Oct 2012
Location: The Hague
Hi flash this http://db.tt/T8ZpfTPa in pda section in odin

Then see & follow my last post in this thread

http://forum.xda-developers.com/show....php?t=1993937
The Following User Says Thank You to Donovan662 For This Useful Post: [ Click to Expand ]
 
xomixxonix
Old
#3  
Junior Member - OP
Thanks Meter 0
Posts: 4
Join Date: Dec 2010
Quote:
Originally Posted by Donovan662 View Post
Hi flash this http://db.tt/T8ZpfTPa in pda section in odin

Then see & follow my last post in this thread

http://forum.xda-developers.com/show....php?t=1993937
thanks for the reply.
i did what you said and its still in loop and same error in recover.
why my internal sdcard isn't mountable?can it be hardware failure?
 
Donovan662
Old
#4  
Senior Member
Thanks Meter 56
Posts: 206
Join Date: Oct 2012
Location: The Hague
Same errors?
 
xomixxonix
Old
#5  
Junior Member - OP
Thanks Meter 0
Posts: 4
Join Date: Dec 2010
Quote:
Originally Posted by Donovan662 View Post
Same errors?
yep same error as before.
after flashing is done and it want to install the package,it get stock and give me that mounting error.
i just want to know if this problem is software or hardware
 
Brahmnoor
Old
#6  
Brahmnoor's Avatar
Senior Member
Thanks Meter 756
Posts: 449
Join Date: Nov 2012
Location: New Delhi

 
DONATE TO ME
Quote:
I also had this problem. Was on stock JVT with semaphore, partitions converted to ext4.

I decided to reboot my phone for no particular reason (was working reat) and when i powered it on kept boot looping without really getting past the samsung gt-i9000 white letters / black background screen.

CWM recovery said it was unable to mount any partition. External SD mounted fine, just nothing from the internel sd. No system, data, whatever. Got me thinking i may had my internal sd malfunctioning.

I just flashed it with odin and my stock branded operator rom (2.3.3) and done nothing more. No repartition. Working great. Was probably some ext4 error.

Before that i had been using cyanogen stable. Started giving FC like mad, so i flashed that stock JVT. On hindsight it may only had been the data partition that had run out of free space but i had no way of knowing when it happened and needed my phone running.

Reflashing got mine running again. Maybe try with Heimdall if odin's not working for you? Be sure to get a complete rom, with bootloaders and such. I'd suggest your operator's stock one. That way you can also send it back to samsung if it still doesn't work.
Found this post somewhere in the xda forum, it helped many people having the same problem as yours, hope it helps you !!!!
To Say Thanks , do not waste your time in writing a post just hit the Thanks button in the bottom-left side of my post !

Please consider donating to me if u feel that I deserve it !!

The Following User Says Thank You to Brahmnoor For This Useful Post: [ Click to Expand ]
 
Donovan662
Old
(Last edited by Donovan662; 24th November 2012 at 11:58 AM.)
#7  
Senior Member
Thanks Meter 56
Posts: 206
Join Date: Oct 2012
Location: The Hague
http://forum.xda-developers.com/show....php?t=1841250

See problem 11 exact same problem described
The Following User Says Thank You to Donovan662 For This Useful Post: [ Click to Expand ]
 
xomixxonix
Old
#8  
Junior Member - OP
Thanks Meter 0
Posts: 4
Join Date: Dec 2010
thanks for the help guys
i tried everything that came to my mine and used this topic for my errors but still get errors
problem 11 and 12 are the ones i get flashing different roms
even tried a Rescue kit from here but no go...

why this is happening to me?
 
kamikaze_in
Old
#9  
Senior Member
Thanks Meter 21
Posts: 122
Join Date: Aug 2011
the failed to mount as i have come to understand is internal SD card failure you will have to give external SD card a try

Check this thread
http://forum.xda-developers.com/show...2059098&page=2
 
nagapandi
Old
#10  
Junior Member
Thanks Meter 0
Posts: 5
Join Date: Aug 2013
Default file moved or deleted

hi friend, file link not working file moved or deleted........

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes