Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,803,273 Members 44,413 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Stock, rooted KF2 stuck on animated boot logo after battery ran out

Tip us?
 
RobertSW19
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 2
Join Date: Apr 2014
Default [Q] Stock, rooted KF2 stuck on animated boot logo after battery ran out

Hi Everyone

As a new user here, thanks in advance for any help that you can give me.

I've got a KF2, running 10.4.1 (I think, or maybe 10.4.3) - it's rooted, but generally stock apart from that (no TWRP).

It was left with something playing and the battery ran down to nothing yesterday. Initially it would charge, sometimes with the red light on and sometimes not, but then it would start up and as soon as it got to the lock screen it would give a low battery noise and shut down.

After leaving it plugged in overnight it is now charged but it is getting stuck on the animated kindle fire boot logo.

If I plug it into my PC it is detected in windows and I can connect to it with ADB with no obvious errors on logcat. Easy options like clearing the dalvik cache don't fix anything (only AmazonPlatform and atlasframework get recreated in the dalvik cache before it sets into doing nothing).


Searching the forum here, there are lots of different avenues discussed for "stuck at boot logo" problems - I'd appreciate some pointers on the most sensible things to try.

Thanks
 
stunts513
Old
#2  
stunts513's Avatar
Recognized Contributor
Thanks Meter 608
Posts: 2,210
Join Date: Feb 2013
Location: New Braunfels, TX

 
DONATE TO ME
Try a system restore with kindle fire first aid.

Sent from my Amazon Kindle Fire HD using Tapatalk
My Wallpaper Fix for KF2, KFHD 7", and KFHD 8.9" is HERE
Please Read the instructions and use the debugger if you run into errors.
My own modified adb drivers for just about all kindles (includes old twrp and cm versions) HERE
Tablet UI Patch for latest CM10.1 build HERE!

Please send complaints to /dev/null
 
Ricardinho_xda
Old
#3  
Ricardinho_xda's Avatar
Member
Thanks Meter 9
Posts: 32
Join Date: Mar 2014
Location: Sao Paulo
Hello, it seems that you face the same issue as I met last week with KF2 that I got for free. The KF2 got a boot problem after a low bat event and nobody was able to get him back. I seems thats the same issue. While I wasn't able to establish adb i used fastboot with a homebuild factory cable. (Forget KFfirst aid) Take a look on this thread: http://forum.xda-developers.com/show....php?t=2698935 - After formating cash and userdata user let him charging for a while on the pc usb port. Next day he returned booting showing a untouched KF2 with factory setup. Rootet him and gave him a CM11. Grate tablet for free. Take care, after formating cash and user he doesn't came back imidiatly Let him for some hours in the fastboot screen blinking his green led on screen. Next day he came back booting. My suspicion is a sw bug regarding low battery events. After cash and userdata format he need to develop valid boot conditions regarding the battery or other stuff. Who knows... But after the procedure he came back without further flaws.

Send via Tapatalk - HW: Kindl HD 8.9 - SW: Android 4.4.2 KitKat < CM 11.0 HC mod.
 
RobertSW19
Old
#4  
Junior Member - OP
Thanks Meter 0
Posts: 2
Join Date: Apr 2014
Thanks for the assistance guys. Sorry for not coming back sooner - I couldn't get my password to work this morning!

I tried restoring to 10.2.3 using KF first aide - after sitting in fastboot for ages downloading the images it flashed ok and then went back to the empty battery screen after it restarted. It stayed like that for so long I thought it was still broken, but eventually it booted back into the kindle launcher.

As I was going from 10.4 back to 10.2.3 I wiped the cache and userdata. Used ADB to get as much data off it as I could first - could I have safely used any of the KF first aide backups on it first?


One weird bit - I've rooted using bin4ry/qemu and used KF First Aide to disable OTA and install google play, maps etc, and now location services don't seem to work any more. Maps, Chrome, Silk, BBC Weather - they all give the location icon in the notification bar but then can't get a location fix.
 
stunts513
Old
#5  
stunts513's Avatar
Recognized Contributor
Thanks Meter 608
Posts: 2,210
Join Date: Feb 2013
Location: New Braunfels, TX

 
DONATE TO ME
This is why I don't use Amazon os... Seems like small things like this happen because we either forget to put something on the device that is needed or the os just breaks something like this out of nowhere. In my opinion its easier to avoid these kinda problems altogether by flashing cm but that's just my take, if you want amazon os then keep it. That sounded grouchier than I intended.

Sent from my Amazon Kindle Fire HD using Tapatalk
My Wallpaper Fix for KF2, KFHD 7", and KFHD 8.9" is HERE
Please Read the instructions and use the debugger if you run into errors.
My own modified adb drivers for just about all kindles (includes old twrp and cm versions) HERE
Tablet UI Patch for latest CM10.1 build HERE!

Please send complaints to /dev/null
 
Ricardinho_xda
Old
#6  
Ricardinho_xda's Avatar
Member
Thanks Meter 9
Posts: 32
Join Date: Mar 2014
Location: Sao Paulo
Stunts513, yes, AOS stucks out of nothing and your gone. On that way a got a kindle for free that entered in a boot loop after a low bat event and even USB recovery doesn't worked worked out by failing and access. Only fastboot and a CM makes that tablet working for real

Send from HTC Sensation - Android 4.4.3 - CM11 - Kitkat
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes