5,598,011 Members 40,967 Now Online
XDA Developers Android and Mobile Development Forum

[How-To] Install any 2.x ROM in a CID-Locked G3 or G4 Wizard

Tip us?
 
lukjod
Old
#91  
Junior Member
Thanks Meter 0
Posts: 27
Join Date: Aug 2004
Quote:
Originally Posted by evilito
I did all of these things also and still no Extension Rom, tutorial says 'Extension Rom' for the name btw, so if ROM needs to be capitalized you may need to fix that in the tutorial. I even did a hard reset this weekend. and still no Extension Rom. Does the name need to be Extension ROM? I took apart the stock Cingular upgrade from the HTC site and followed your tutorial to the letter. I got the 8125 close to what the stock Cingular settings are by manual configuration and someone was nice enough to post the Cingular Extension Rom contents elseware on this board. But I would really like to get the darn extension rom back on my phone.
1.all files in ext rom must be read only before making nk.nbf
2.If U add any cab that is not signed U must put Cert_SPCS.cab as first one to install which allows not signed cabs to install without bypassing them
HTC Evo 3D
 
GerooTech
Old
#92  
Senior Member
Thanks Meter 10
Posts: 368
Join Date: Apr 2005
good, i will try with the new tmobile 2.26
GerooTech
NeXuS One Rooted CM7
GalaXy NeXus on ARHD 3.00
 
gerasim
Old
#93  
Junior Member
Thanks Meter 0
Posts: 1
Join Date: Jul 2006
Location: moscow
Default Many thanks!

risidoro! Many thanks!
 
GerooTech
Old
#94  
Senior Member
Thanks Meter 10
Posts: 368
Join Date: Apr 2005
Default Rom Update Utility

is there any english version from the rom update utility as i do not understand the error it displayes.
GerooTech
NeXuS One Rooted CM7
GalaXy NeXus on ARHD 3.00
 
risidoro
Old
#95  
risidoro's Avatar
Senior Member - OP
Thanks Meter 1
Posts: 509
Join Date: Sep 2005
Location: Italy
Default Re: Rom Update Utility

Quote:
Originally Posted by gwassef
is there any english version from the rom update utility as i do not understand the error it displayes.
Uhm... yep... you're right, i should have posted the english RUU, and i'll do one day or another.
Anyway, when it gives you the error it also shows an error code. The file readme.doc (included in RUU.rar) contains all these error codes explained in english. Check there.

Bye
HTC Wizard - T-Mobile MDA Vario
 
GerooTech
Old
#96  
Senior Member
Thanks Meter 10
Posts: 368
Join Date: Apr 2005
thanks,
the error was about a missing file i did not copy.
i have another question, i got the new tmoible 2.26 rom and i tok the OS and GSM images and combined them with 2.16 extended rom from imate. and i made the nbf and it is sucessfully intsalled. but it does not install the contents of the extended rom. can anybody help me in that
GerooTech
NeXuS One Rooted CM7
GalaXy NeXus on ARHD 3.00
 
risidoro
Old
#97  
risidoro's Avatar
Senior Member - OP
Thanks Meter 1
Posts: 509
Join Date: Sep 2005
Location: Italy
Quote:
Originally Posted by gwassef
thanks,
the error was about a missing file i did not copy.
i have another question, i got the new tmoible 2.26 rom and i tok the OS and GSM images and combined them with 2.16 extended rom from imate. and i made the nbf and it is sucessfully intsalled. but it does not install the contents of the extended rom. can anybody help me in that
You're not the first one that experienced this problem. I'm starting to think that it may be caused by a different certificates configuration in newer t-mobile 2.26 and cingular 2.25 roms. It's the only possible solution i have in mind.

You could try to cook a rom with OS and extrom both taken from the same rom (i.e. OS and extrom both from 2.26) and see if that works. Then, we could try to find a solution for extrom taken from different roms.

It's quite weird though... I'll try to cook a rom similar to yours and install it on my phone to see if, maybe, something is wrong in newer IPL/SPLs.

BTW, which RUU tools are you using? The one i provided in the first post or the one posted by The-Equinoxe in the third page of this thread? If the latter is your case, then try using my RUU.

If anyone out there can provide a different interpretation/explanation of this problem, he's invited to tell us. Thanks!
HTC Wizard - T-Mobile MDA Vario
 
GerooTech
Old
#98  
Senior Member
Thanks Meter 10
Posts: 368
Join Date: Apr 2005
Quote:
Originally Posted by risidoro
Quote:
Originally Posted by gwassef
thanks,
the error was about a missing file i did not copy.
i have another question, i got the new tmoible 2.26 rom and i tok the OS and GSM images and combined them with 2.16 extended rom from imate. and i made the nbf and it is sucessfully intsalled. but it does not install the contents of the extended rom. can anybody help me in that
You're not the first one that experienced this problem. I'm starting to think that it may be caused by a different certificates configuration in newer t-mobile 2.26 and cingular 2.25 roms. It's the only possible solution i have in mind.

You could try to cook a rom with OS and extrom both taken from the same rom (i.e. OS and extrom both from 2.26) and see if that works. Then, we could try to find a solution for extrom taken from different roms.

It's quite weird though... I'll try to cook a rom similar to yours and install it on my phone to see if, maybe, something is wrong in newer IPL/SPLs.

BTW, which RUU tools are you using? The one i provided in the first post or the one posted by The-Equinoxe in the third page of this thread? If the latter is your case, then try using my RUU.

If anyone out there can provide a different interpretation/explanation of this problem, he's invited to tell us. Thanks!
first i tried the extended rom with the tmoible and it works great, secondely i am using the one in the 3 page, also it gives me the error on non signed apps when it starts to run
GerooTech
NeXuS One Rooted CM7
GalaXy NeXus on ARHD 3.00
 
GerooTech
Old
#99  
Senior Member
Thanks Meter 10
Posts: 368
Join Date: Apr 2005
i reupdated my device with the mixed rom, and i tried to install the files i need from the imate extened rom manually, and i got the warrning of the un certified cab with each cab i try to install.
GerooTech
NeXuS One Rooted CM7
GalaXy NeXus on ARHD 3.00
 
risidoro
Old
#100  
risidoro's Avatar
Senior Member - OP
Thanks Meter 1
Posts: 509
Join Date: Sep 2005
Location: Italy
Quote:
Originally Posted by gwassef
i reupdated my device with the mixed rom, and i tried to install the files i need from the imate extened rom manually, and i got the warrning of the un certified cab with each cab i try to install.
So we found the problem! 2.26 is problably using some certificate or doing some check that was not present/required in imate rom.

This problem can be solved. You must cook a new extrom containing:

- autorun.exe from the 2.26 rom ('cos it's correctly signed)
- disable_signature_check.cab (to install for first to disable the certificate signature check on subsequent cabs)
- cabs taken from the extrom you like (i.e. imate's one)
- config.txt file, edited accordingly to the cabs you want to install

If you send me the extrom you'd like to install (the imate one) i can try cooking a extrom for you (in case you don't know how to do). Let me know. bye
HTC Wizard - T-Mobile MDA Vario

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


XDA PORTAL POSTS

Android Control Center Becomes Quick Control Panel, Brings Host of New Features

You may recall that back in August of last year, we talked … more

Polish Your Custom Themes with Theme Debugger

Creating a custom Android theme from scratch can be quite the laborious task. In addition to … more

Clean Up Your Logcat Code with Lib Cleaner

Some of you may think that writing code is the hardest part of development. It’s not, as the … more

Tweak Your Xperia Device’s Camera App Yourself

We’ve come to expect nearly perfect cameraperformancein our modern day … more